aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2013-04-19 18:59:20 +0800
committerale <ale@FreeBSD.org>2013-04-19 18:59:20 +0800
commit425d1f12f861b165f181b489f6e9ddb1d43776a8 (patch)
treef4b3bffa032ae5f96a3331a75062e2a8b613e0bc /databases
parentc5756fc12b80ca79d85b8d43c75ad93116a42641 (diff)
downloadfreebsd-ports-gnome-425d1f12f861b165f181b489f6e9ddb1d43776a8.tar.gz
freebsd-ports-gnome-425d1f12f861b165f181b489f6e9ddb1d43776a8.tar.zst
freebsd-ports-gnome-425d1f12f861b165f181b489f6e9ddb1d43776a8.zip
Update to 2.4.2 release.
Simplify rc script. Fix build with spidermonkey [1]. PR: ports/177703 [1] Submitted by: Dmitry Sukhodoyev <raven428@gmail.com> Feature safe: yes
Diffstat (limited to 'databases')
-rw-r--r--databases/mongodb/Makefile2
-rw-r--r--databases/mongodb/distinfo4
-rw-r--r--databases/mongodb/files/mongod.in6
-rw-r--r--databases/mongodb/files/patch-SConstruct2
4 files changed, 6 insertions, 8 deletions
diff --git a/databases/mongodb/Makefile b/databases/mongodb/Makefile
index 0b49ac54c966..ae315cdbff42 100644
--- a/databases/mongodb/Makefile
+++ b/databases/mongodb/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mongodb
-PORTVERSION= 2.4.1
+PORTVERSION= 2.4.2
CATEGORIES= databases net
MASTER_SITES= http://downloads.mongodb.org/src/
DISTNAME= ${PORTNAME}-src-r${PORTVERSION}
diff --git a/databases/mongodb/distinfo b/databases/mongodb/distinfo
index cb582529a8fd..a0f3db1ed013 100644
--- a/databases/mongodb/distinfo
+++ b/databases/mongodb/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mongodb-src-r2.4.1.tar.gz) = d61ad944b8f27e0efb9a08998cbda587ee5d1a4406a938443e681502738da3b2
-SIZE (mongodb-src-r2.4.1.tar.gz) = 14101118
+SHA256 (mongodb-src-r2.4.2.tar.gz) = d0a26fef7f425a6652ebfc3addbc7e1b01a10be65c9d68e464730687bd6721c3
+SIZE (mongodb-src-r2.4.2.tar.gz) = 14106623
diff --git a/databases/mongodb/files/mongod.in b/databases/mongodb/files/mongod.in
index a06b88ff5226..bdf24bea76e0 100644
--- a/databases/mongodb/files/mongod.in
+++ b/databases/mongodb/files/mongod.in
@@ -14,8 +14,6 @@
# just before mongod starts.
# mongod_dbpath (str): Default to "/var/db/mongodb"
# Base database directory.
-# mongod_pidfile (str): Custum PID file path and name.
-# Default to "${mongod_dbpath}/mongod.pid".
# mongod_flags (str): Custom additional arguments to be passed to mongod.
# Default to "--logpath ${mongod_dbpath}/mongod.log --logappend".
#
@@ -34,9 +32,9 @@ load_rc_config $name
: ${mongod_user="mongodb"}
: ${mongod_group="mongodb"}
-pidfile=${mongod_pidfile:-"${mongod_dbpath}/mongod.pid"}
+pidfile="${mongod_dbpath}/mongod.lock"
command=%%PREFIX%%/bin/${name}
-command_args="--config %%PREFIX%%/etc/mongodb.conf --dbpath $mongod_dbpath --pidfilepath ${pidfile} --fork"
+command_args="--config %%PREFIX%%/etc/mongodb.conf --dbpath $mongod_dbpath --fork >/dev/null 2>/dev/null"
start_precmd="${name}_prestart"
mongod_create_dbpath()
diff --git a/databases/mongodb/files/patch-SConstruct b/databases/mongodb/files/patch-SConstruct
index 7fccb9f6a9fb..7aed7e777a6b 100644
--- a/databases/mongodb/files/patch-SConstruct
+++ b/databases/mongodb/files/patch-SConstruct
@@ -23,7 +23,7 @@
+ if not conf.CheckLib("snappy"):
+ Exit(1)
+
-+ if usesm and use_system_version_of_library("js"):
++ if usesm and use_system_version_of_library("sm"):
+ if not conf.CheckLib("js"):
+ Exit(1)
+