aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-04-04 17:37:23 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-04-04 17:37:23 +0800
commit457748d331d4fc15dba3973346f6aaee593c22c0 (patch)
treef438eb3d2f031e59b5dd040708b66f455ff0f7c0 /databases
parentf9bc105162c7fbb1b088ef2eeefe1992c05ada3d (diff)
downloadfreebsd-ports-gnome-457748d331d4fc15dba3973346f6aaee593c22c0.tar.gz
freebsd-ports-gnome-457748d331d4fc15dba3973346f6aaee593c22c0.tar.zst
freebsd-ports-gnome-457748d331d4fc15dba3973346f6aaee593c22c0.zip
Add ruby-xapian 1.4.3 (copied from xapian-bindings)
- Update to 1.4.3 - Add BUILD_DEPENDS - Update WWW Changes: https://trac.xapian.org/wiki/ReleaseOverview/1.4.3 https://trac.xapian.org/wiki/ReleaseOverview/1.4.2 https://trac.xapian.org/wiki/ReleaseOverview/1.4.1 https://trac.xapian.org/wiki/ReleaseOverview/1.4.0
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/ruby-xapian/Makefile39
-rw-r--r--databases/ruby-xapian/distinfo3
-rw-r--r--databases/ruby-xapian/pkg-descr3
-rw-r--r--databases/ruby-xapian/pkg-plist3
5 files changed, 49 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index e3d0adc1300a..eecae21f32ee 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -861,6 +861,7 @@
SUBDIR += ruby-odbc
SUBDIR += ruby-qdbm
SUBDIR += ruby-tokyocabinet
+ SUBDIR += ruby-xapian
SUBDIR += rubygem-activemodel4
SUBDIR += rubygem-activemodel5
SUBDIR += rubygem-activerecord-import
diff --git a/databases/ruby-xapian/Makefile b/databases/ruby-xapian/Makefile
new file mode 100644
index 000000000000..e504d6ac43e8
--- /dev/null
+++ b/databases/ruby-xapian/Makefile
@@ -0,0 +1,39 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= xapian
+PORTVERSION= 1.4.3
+DISTVERSIONPREFIX= bindings-
+CATEGORIES= databases
+MASTER_SITES= http://oligarchy.co.uk/xapian/${PORTVERSION}/ \
+ LOCAL/sunpoet
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Ruby binding for Xapian
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= xapian-core>=${PORTVERSION}:databases/xapian-core
+LIB_DEPENDS= libxapian.so:databases/xapian-core
+
+OPTIONS_DEFINE= DOCS
+
+PORTSCOUT= limitw:1,even
+
+CONFIGURE_ARGS= --datarootdir=${DATADIR} --docdir=${DOCSDIR} \
+ --enable-static --with-ruby \
+ --without-csharp --without-java --without-lua --without-perl \
+ --without-php --without-python --without-python3 --without-tcl
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USE_RUBY= yes
+USES= libtool tar:xz
+
+PORTDOCS= *
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lstdc++||g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/databases/ruby-xapian/distinfo b/databases/ruby-xapian/distinfo
new file mode 100644
index 000000000000..09c72f562dee
--- /dev/null
+++ b/databases/ruby-xapian/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1485562319
+SHA256 (xapian-bindings-1.4.3.tar.xz) = 65b5455bf81e4f39fda49a6ad99353b05889d11d7c4c2cae001a0a1e0dac0d87
+SIZE (xapian-bindings-1.4.3.tar.xz) = 1114408
diff --git a/databases/ruby-xapian/pkg-descr b/databases/ruby-xapian/pkg-descr
new file mode 100644
index 000000000000..f530fd141bf8
--- /dev/null
+++ b/databases/ruby-xapian/pkg-descr
@@ -0,0 +1,3 @@
+Ruby binding for Xapian
+
+WWW: https://xapian.org/
diff --git a/databases/ruby-xapian/pkg-plist b/databases/ruby-xapian/pkg-plist
new file mode 100644
index 000000000000..4b6df24246ed
--- /dev/null
+++ b/databases/ruby-xapian/pkg-plist
@@ -0,0 +1,3 @@
+%%RUBY_SITEARCHLIBDIR%%/_xapian.a
+%%RUBY_SITEARCHLIBDIR%%/_xapian.so
+%%RUBY_SITELIBDIR%%/xapian.rb