aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-08-04 15:27:34 +0800
committerdinoex <dinoex@FreeBSD.org>2003-08-04 15:27:34 +0800
commit53bcd114299b1551b03881dd6fdba256182e3764 (patch)
tree362ae3938370b995a71dd711b7cabfcbfeff6907 /databases
parentb59614ee405b0be8db44152e578cabea25761a14 (diff)
downloadfreebsd-ports-gnome-53bcd114299b1551b03881dd6fdba256182e3764.tar.gz
freebsd-ports-gnome-53bcd114299b1551b03881dd6fdba256182e3764.tar.zst
freebsd-ports-gnome-53bcd114299b1551b03881dd6fdba256182e3764.zip
- Fix support for python2.3
defaults to python2.2, python2.3 support is broken.
Diffstat (limited to 'databases')
-rw-r--r--databases/metakit/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/databases/metakit/Makefile b/databases/metakit/Makefile
index dc1483edb78a..547f100ee5af 100644
--- a/databases/metakit/Makefile
+++ b/databases/metakit/Makefile
@@ -32,6 +32,7 @@ ONLY_FOR_ARCHS= i386 alpha
.if defined(METAKIT_WITH_PYTHON)
USE_PYTHON= yes
+PYTHON_VERSION?= python2.2
CONFIGURE_ARGS+= --with-python=${LOCALBASE}
CATEGORIES+= python
PLIST_SUB+= WITH_PYTHON=""
@@ -68,16 +69,24 @@ pre-patch:
${SED} -e "s=doc/==" \
${WRKSRC}/../MetaKit.html.sed > ${WRKSRC}/../MetaKit.html
.if defined(METAKIT_WITH_TCL83) || defined(METAKIT_WITH_TCL84)
- @${MV} ${WRKSRC}/../unix/Makefile.in ${WRKSRC}/../unix/Makefile.in.sed
+ @${CP} ${WRKSRC}/../unix/Makefile.in ${WRKSRC}/../unix/Makefile.in.sed
${SED} -e "s/= tclsh/=tclsh${TCL_V}/" -e "s/tcl8.4/tcl${TCL_V}/" \
${WRKSRC}/../unix/Makefile.in.sed \
> ${WRKSRC}/../unix/Makefile.in
.endif
.if defined(METAKIT_WITH_PYTHON)
- @${MV} ${WRKSRC}/../unix/Makefile.in ${WRKSRC}/../unix/Makefile.in.sed
+ @${CP} ${WRKSRC}/../unix/Makefile.in ${WRKSRC}/../unix/Makefile.in.sed
${SED} -e "s=python2.2=${PYTHON_VERSION}=" \
${WRKSRC}/../unix/Makefile.in.sed \
> ${WRKSRC}/../unix/Makefile.in
+ @${CP} ${WRKSRC}/../unix/configure ${WRKSRC}/../unix/configure.sed
+ ${SED} -e "s=python2.2=${PYTHON_VERSION}=" \
+ ${WRKSRC}/../unix/configure.sed \
+ > ${WRKSRC}/../unix/configure
+.endif
+
+post-install:
+.if defined(METAKIT_WITH_PYTHON)
.endif
post-install: