aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-02-02 02:52:58 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-02-02 02:52:58 +0800
commit67e1e61331b6c00d95efa283cf2c771be45ee61e (patch)
tree55f1c40e554830d3a0623eeb6b20bab0a137328d /databases
parent9f3a4e0990bcb58713d604fa351107bea8a75624 (diff)
downloadfreebsd-ports-gnome-67e1e61331b6c00d95efa283cf2c771be45ee61e.tar.gz
freebsd-ports-gnome-67e1e61331b6c00d95efa283cf2c771be45ee61e.tar.zst
freebsd-ports-gnome-67e1e61331b6c00d95efa283cf2c771be45ee61e.zip
- Update to 1.48
- Add my LOCAL as MASTER_SITES - Take maintainership Changes: http://bazaar.launchpad.net/~python-memcached-team/python-memcached/trunk/view/head:/ChangeLog - Bug #745633: Values of maximum size are not stored API inconsistency, max value length was tested for <= while max KEY length was <. So I picked that keys and values *LONGER* than the specified max value are what is used, and added documentation and tests to that effect. The test for max value tested that length plus 4, so I've changed that to be that value plus 1. Issue found by matt-quru. - Bug #713488: Issues Invalid "delete" command. Protocol has changed so that the "delete" operation no longer takes a "time" argument. It seems that some servers will refuse a "delete key 0" while others will accept it, but the official server will NOT accept "delete key 1". So I've changed it so that if no "time" argument is specified, no time argument is sent to the server. - Bug #713451: server.expect("END") needs to be in a finally block Expect an "END" when the _recv_value() raises an exception. Patch by Jay Farrimond. - Bug: #741090: cas cache can grow unbounded. Default now is that the cache is not used, unless the "Client()" object is created with "cache_cas=True". In that case, you need to have your own cas clearing code, a simple one would be to use Client().reset_cas() to completely clear the cas_ids cache. Problem pointed out by Shaun Cutts. - Bug #728359: Make python-memcache work on memcache restarts. Patch by Tarek Ziade', reviewed and further patches submitted by Hugo Beauze'e-Luysse and Neganov Alexandr. - Bug #798342: If memcached server sends unknown flag in response for "get", results in: "UnboundLocalError: local variable 'val' referenced before assignment" Now returns "None" instead. Patch by Sharoon Thomas
Diffstat (limited to 'databases')
-rw-r--r--databases/py-memcached/Makefile7
-rw-r--r--databases/py-memcached/distinfo4
2 files changed, 6 insertions, 5 deletions
diff --git a/databases/py-memcached/Makefile b/databases/py-memcached/Makefile
index 57b86afb5f02..e16f3855cd02 100644
--- a/databases/py-memcached/Makefile
+++ b/databases/py-memcached/Makefile
@@ -6,14 +6,15 @@
#
PORTNAME= memcached
-PORTVERSION= 1.47
+PORTVERSION= 1.48
CATEGORIES= databases python
MASTER_SITES= ftp://ftp.tummy.com/pub/python-memcached/ \
- ftp://ftp.tummy.com/pub/python-memcached/old-releases/
+ ftp://ftp.tummy.com/pub/python-memcached/old-releases/ \
+ LOCAL/sunpoet
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= python-${PORTNAME}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Python API for memcached, a distributed memory cache daemon
USE_PYTHON= yes
diff --git a/databases/py-memcached/distinfo b/databases/py-memcached/distinfo
index c4612e775d31..1dd69c268605 100644
--- a/databases/py-memcached/distinfo
+++ b/databases/py-memcached/distinfo
@@ -1,2 +1,2 @@
-SHA256 (python-memcached-1.47.tar.gz) = 59c5139d0a8d03e9bd796c984d0cd75b94ef955578372158152dacdfdfe32fc3
-SIZE (python-memcached-1.47.tar.gz) = 37465
+SHA256 (python-memcached-1.48.tar.gz) = 66bbc62d9519f9d531b1f77e687d9f2f5e521cb906f1fd7231f403997e0110c4
+SIZE (python-memcached-1.48.tar.gz) = 40448