aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2005-03-09 14:01:22 +0800
committerijliao <ijliao@FreeBSD.org>2005-03-09 14:01:22 +0800
commit6967f36083d4c9ab840cadd47e4d6291da3b88a7 (patch)
treed62d1198a731c69fd2043abdc61eb334d5d367fe /databases
parent0569b3f1378bfce03f89181d32d23d73f25e0c6c (diff)
downloadfreebsd-ports-gnome-6967f36083d4c9ab840cadd47e4d6291da3b88a7.tar.gz
freebsd-ports-gnome-6967f36083d4c9ab840cadd47e4d6291da3b88a7.tar.zst
freebsd-ports-gnome-6967f36083d4c9ab840cadd47e4d6291da3b88a7.zip
add jrobin 1.4.0
A pure Java alternative to RRDTool
Diffstat (limited to 'databases')
-rw-r--r--databases/jrobin/Makefile42
-rw-r--r--databases/jrobin/distinfo2
-rw-r--r--databases/jrobin/pkg-descr14
3 files changed, 58 insertions, 0 deletions
diff --git a/databases/jrobin/Makefile b/databases/jrobin/Makefile
new file mode 100644
index 000000000000..889497fc2e66
--- /dev/null
+++ b/databases/jrobin/Makefile
@@ -0,0 +1,42 @@
+# ex:ts=8
+# Ports collection makefile for: JRobin
+# Date created: Mar 9, 2005
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= jrobin
+PORTVERSION= 1.4.0
+CATEGORIES= net java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= JRobin-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A pure Java alternative to RRDTool
+
+USE_JAVA= yes
+USE_ANT= yes
+ALL_TARGET= all-libs
+WRKSRC= ${WRKDIR}/${DISTNAME:L}
+BUILD_WRKSRC= ${WRKSRC}/ant
+
+.if !defined(NOPORTDOCS)
+ALL_TARGET+= javadoc
+PORTDOCS= *
+.endif
+
+CLASSES= jrobin jrobin-demo convertor inspector mrtg-client mrtg-server
+
+do-install:
+.for c in ${CLASSES}
+ ${INSTALL_DATA} ${WRKSRC}/lib/${c}-${PORTVERSION}.jar ${JAVAJARDIR}/${c}.jar
+ @${ECHO} '${JAVAJARDIR:S,^${PREFIX}/,,}/${c}.jar' >> ${TMPPLIST}
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/doc/ ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/jrobin/distinfo b/databases/jrobin/distinfo
new file mode 100644
index 000000000000..f36d7e1235f6
--- /dev/null
+++ b/databases/jrobin/distinfo
@@ -0,0 +1,2 @@
+MD5 (JRobin-1.4.0.tar.gz) = 861b1fcc9d5554014120cd45be8a21d6
+SIZE (JRobin-1.4.0.tar.gz) = 1945845
diff --git a/databases/jrobin/pkg-descr b/databases/jrobin/pkg-descr
new file mode 100644
index 000000000000..3d699b201a9d
--- /dev/null
+++ b/databases/jrobin/pkg-descr
@@ -0,0 +1,14 @@
+JRobin is a 100% pure java implementation of RRDTool's functionality. It
+follows the same logic and uses the same data sources, archive types and
+definitions as RRDTool does. JRobin supports all standard operations on
+Round Robin Database (RRD) files: CREATE, UPDATE, FETCH, LAST, DUMP, XPORT
+and GRAPH. JRobin's API is made for those who are familiar with RRDTool's
+concepts and logic, but prefer to work with pure java. If you provide the
+same data to RRDTool and JRobin, you will get exactly the same results and
+graphs. JRobin is made from the scratch and it uses very limited portions
+of RRDTool's original source code. JRobin does not use native functions and
+libraries, has no Runtime.exec() calls and does not require RRDTool to be
+present. JRobin is distributed as a software library (jar files) and comes
+with full java source code (LGPL licence).
+
+WWW: http://www.jrobin.org/