aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-06-20 22:42:30 +0800
committerwg <wg@FreeBSD.org>2013-06-20 22:42:30 +0800
commit72a2c8f876f60dc70630e23bf8dde9026bce6bc1 (patch)
tree2a1b79f4946d2b45d9676215a263fa8f878517f2 /databases
parente9a472f840a350b0885a51874f4325a91a9e863f (diff)
downloadfreebsd-ports-gnome-72a2c8f876f60dc70630e23bf8dde9026bce6bc1.tar.gz
freebsd-ports-gnome-72a2c8f876f60dc70630e23bf8dde9026bce6bc1.tar.zst
freebsd-ports-gnome-72a2c8f876f60dc70630e23bf8dde9026bce6bc1.zip
The Doctrine DBAL package is the database abstraction layer used to
power the ORM package. WWW: http://www.doctrine-project.org/
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pear-DoctrineDBAL/Makefile54
-rw-r--r--databases/pear-DoctrineDBAL/distinfo2
-rw-r--r--databases/pear-DoctrineDBAL/pkg-descr4
4 files changed, 61 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 5bbc99e4b1e7..cc59e764e2dd 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -508,6 +508,7 @@
SUBDIR += pear-DB_ldap2
SUBDIR += pear-Doctrine12
SUBDIR += pear-DoctrineCommon
+ SUBDIR += pear-DoctrineDBAL
SUBDIR += pear-Horde_Db
SUBDIR += pear-Horde_HashTable
SUBDIR += pear-Horde_Imsp
diff --git a/databases/pear-DoctrineDBAL/Makefile b/databases/pear-DoctrineDBAL/Makefile
new file mode 100644
index 000000000000..77fb01bd4dc5
--- /dev/null
+++ b/databases/pear-DoctrineDBAL/Makefile
@@ -0,0 +1,54 @@
+# Created by: William Grzybowski <wg@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= DoctrineDBAL
+PORTVERSION= 2.3.0
+CATEGORIES= databases pear
+MASTER_SITES= http://pear.doctrine-project.org/get/
+
+MAINTAINER= wg@FreeBSD.org
+COMMENT= Database abstraction layer used to power the ORM package
+
+LICENSE= LGPL21
+
+BUILD_DEPENDS= ${PEARDIR}/.channels/pear.doctrine-project.org.reg:${PORTSDIR}/devel/pear-channel-doctrine
+RUN_DEPENDS= ${PEARDIR}/.channels/pear.doctrine-project.org.reg:${PORTSDIR}/devel/pear-channel-doctrine \
+ ${PEARDIR}/Doctrine/Common/Version.php:${PORTSDIR}/databases/pear-DoctrineCommon \
+ ${PEARDIR}/Symfony/Component/Console/Application.php:${PORTSDIR}/devel/pear-Symfony_Component_Console
+
+OPTIONSFILE?= ${PORT_DBDIR}/pear-${PORTNAME}/options
+OPTIONS_DEFINE= DBLIB MYSQL ODBC PGSQL SQLITE
+OPTIONS_DEFAULT=MYSQL
+
+DBLIB_DESC= Install PHP DBO driver for DBLIB
+MYSQL_DESC= Install PHP DBO driver for MySQL
+ODBC_DESC= Install PHP DBO driver for ODBC
+PGSQL_DESC= Install PHP DBO driver for PostgreSQL
+SQLITE_DESC= Install PHP DBO driver for SQLite
+
+PEAR_CHANNEL= doctrine
+PEAR_AUTOINSTALL= yes
+
+USE_PHP= pdo
+WANT_PHP_CLI= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MDBLIB}
+RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/pdo_dblib.so:${PORTSDIR}/databases/php${PHP_VER}-pdo_dblib
+.endif
+.if ${PORT_OPTIONS:MMYSQL}
+USE_PHP+= pdo_mysql
+.endif
+.if ${PORT_OPTIONS:MODBC}
+RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/pdo_odbc.so:${PORTSDIR}/databases/php${PHP_VER}-pdo_odbc
+.endif
+.if ${PORT_OPTIONS:MPGSQL}
+USE_PHP+= pdo_pgsql
+.endif
+.if ${PORT_OPTIONS:MSQLITE}
+USE_PHP+= pdo_sqlite
+.endif
+
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/databases/pear-DoctrineDBAL/distinfo b/databases/pear-DoctrineDBAL/distinfo
new file mode 100644
index 000000000000..4441733e61a3
--- /dev/null
+++ b/databases/pear-DoctrineDBAL/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PEAR/DoctrineDBAL-2.3.0.tgz) = 417ea5a3d646ea5400ff29a47a2f38afcf0dcafe149767f85b7fdc61240c419a
+SIZE (PEAR/DoctrineDBAL-2.3.0.tgz) = 143996
diff --git a/databases/pear-DoctrineDBAL/pkg-descr b/databases/pear-DoctrineDBAL/pkg-descr
new file mode 100644
index 000000000000..1504bc74c265
--- /dev/null
+++ b/databases/pear-DoctrineDBAL/pkg-descr
@@ -0,0 +1,4 @@
+The Doctrine DBAL package is the database abstraction layer used to
+power the ORM package.
+
+WWW: http://www.doctrine-project.org/