aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorgirgen <girgen@FreeBSD.org>2006-12-08 18:41:40 +0800
committergirgen <girgen@FreeBSD.org>2006-12-08 18:41:40 +0800
commit7420cdcd45867350d25a9120c6fc7574f7be20ea (patch)
tree7a4bdf1ef0639f296d7e97ae0d49e55ca1ae6864 /databases
parentb51746072ac7159ef8430f8f8a0c041300417baf (diff)
downloadfreebsd-ports-gnome-7420cdcd45867350d25a9120c6fc7574f7be20ea.tar.gz
freebsd-ports-gnome-7420cdcd45867350d25a9120c6fc7574f7be20ea.tar.zst
freebsd-ports-gnome-7420cdcd45867350d25a9120c6fc7574f7be20ea.zip
More rubust regex to determine which version of postgresql that is
already installed. Reported by: Kostik Belousov PR: 106472
Diffstat (limited to 'databases')
-rw-r--r--databases/postgresql-pltcl/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/databases/postgresql-pltcl/Makefile b/databases/postgresql-pltcl/Makefile
index 6da2bd8a9ff7..e2441f92e965 100644
--- a/databases/postgresql-pltcl/Makefile
+++ b/databases/postgresql-pltcl/Makefile
@@ -27,7 +27,7 @@ SED?= /usr/bin/sed
# Setting/finding PostgreSQL version we want.
.if exists(${LOCALBASE}/bin/postmaster)
-PGSQL_VER!= ${LOCALBASE}/bin/postmaster -V | ${SED} -n 's/postmaster.*PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\2/p'
+PGSQL_VER!= ${LOCALBASE}/bin/postmaster -V | ${SED} -n 's/.*PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\2/p'
.elif exists(${LOCALBASE}/bin/pg_config)
PGSQL_VER!= ${LOCALBASE}/bin/pg_config --version | ${SED} -n 's/PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\2/p'
.else