aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2016-09-14 04:06:28 +0800
committertcberner <tcberner@FreeBSD.org>2016-09-14 04:06:28 +0800
commit83ade2c21e3af9113b39ed3480b7ee24eccc7da5 (patch)
treea7e52fda4f8d97d1a3ac45ab7596932f1a8ec37e /databases
parent1db8b401879704ada1237a35a7b7a4ea49497bd2 (diff)
downloadfreebsd-ports-gnome-83ade2c21e3af9113b39ed3480b7ee24eccc7da5.tar.gz
freebsd-ports-gnome-83ade2c21e3af9113b39ed3480b7ee24eccc7da5.tar.zst
freebsd-ports-gnome-83ade2c21e3af9113b39ed3480b7ee24eccc7da5.zip
Add new port databases/sqlitebrowser-qt5 as slaveport of databases/sqlitebrowser
Add a new port databases/sqlitebrowser-qt5 as slaveport of the existing databases/sqlitebrowser. PR: 211217 Reviewed by: mat Approved by: rakuco (mentor) Differential Revision: https://reviews.freebsd.org/D7253
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/sqlitebrowser-qt5/Makefile12
-rw-r--r--databases/sqlitebrowser/Makefile14
3 files changed, 24 insertions, 3 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 0f0a741e86be..bf143de7b59e 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -964,6 +964,7 @@
SUBDIR += sqlite2
SUBDIR += sqlite3
SUBDIR += sqlitebrowser
+ SUBDIR += sqlitebrowser-qt5
SUBDIR += sqliteman
SUBDIR += sqlitemanager
SUBDIR += sqliteodbc
diff --git a/databases/sqlitebrowser-qt5/Makefile b/databases/sqlitebrowser-qt5/Makefile
new file mode 100644
index 000000000000..82cbf89e70a6
--- /dev/null
+++ b/databases/sqlitebrowser-qt5/Makefile
@@ -0,0 +1,12 @@
+# Created by: Tobias C. Berner <tcberner@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= sqlitebrowser
+PORTREVERSION= 0
+PKGNAMESUFFIX= -qt5
+
+CONFLICTS_INSTALL= ${PORTNAME}-3.*
+
+MASTERDIR= ${.CURDIR:H}/sqlitebrowser
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/sqlitebrowser/Makefile b/databases/sqlitebrowser/Makefile
index d85a7cf1987a..72e0f3b608ff 100644
--- a/databases/sqlitebrowser/Makefile
+++ b/databases/sqlitebrowser/Makefile
@@ -4,24 +4,32 @@
PORTNAME= sqlitebrowser
PORTVERSION= 3.8.0
DISTVERSIONPREFIX= v
+PORTREVISION?= 1
CATEGORIES= databases
MAINTAINER= coder@tuxfamily.org
COMMENT= DB Browser for SQLite is a visual tool to manage SQLite databases
+CONFLICTS_INSTALL?= ${PORTNAME}-qt5-*
+
LICENSE= MPL GPLv3
LICENSE_COMB= dual
USE_GITHUB= yes
USES= cmake desktop-file-utils sqlite
+
+.if empty(PKGNAMESUFFIX)
USE_QT4= corelib network gui qmake_build linguisttools_build \
moc_build uic_build rcc_build
-
-INSTALLS_ICONS= yes
+CMAKE_ARGS+= -DUSE_QT5:BOOL=FALSE
+.else
+USE_QT5= core gui network printsupport testlib widgets \
+ buildtools_build linguisttools_build qmake_build
+CMAKE_ARGS+= -DUSE_QT5:BOOL=TRUE
+.endif
post-patch:
- @${ECHO} ${DATADIR}
@${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' \
${WRKSRC}/src/PreferencesDialog.cpp
@${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' \