aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-05-28 03:42:13 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-05-28 03:42:13 +0800
commit86162f4965b18f11e615a35ae475197cecb7d0f5 (patch)
tree1d418c86a9919305f43c1f57d1deb76e4d123fba /databases
parentb67ae8ed7de0d485cc4e20fbc40c64d834a6095e (diff)
downloadfreebsd-ports-gnome-86162f4965b18f11e615a35ae475197cecb7d0f5.tar.gz
freebsd-ports-gnome-86162f4965b18f11e615a35ae475197cecb7d0f5.tar.zst
freebsd-ports-gnome-86162f4965b18f11e615a35ae475197cecb7d0f5.zip
Fix CONFLICTS_INSTALL
PR: 219388 Submitted by: pawel
Diffstat (limited to 'databases')
-rw-r--r--databases/lua-xapian/Makefile2
-rw-r--r--databases/p5-Search-Xapian10/Makefile2
-rw-r--r--databases/postgis20/Makefile2
-rw-r--r--databases/py-sqlalchemy11/Makefile2
-rw-r--r--databases/py-xapian/Makefile2
-rw-r--r--databases/rocksdb/Makefile2
-rw-r--r--databases/xapian-bindings12/Makefile2
-rw-r--r--databases/xapian-core/Makefile2
-rw-r--r--databases/xapian-core10/Makefile2
-rw-r--r--databases/xapian-core12/Makefile2
10 files changed, 10 insertions, 10 deletions
diff --git a/databases/lua-xapian/Makefile b/databases/lua-xapian/Makefile
index 880b78d428b8..ee9bfd2f9a8b 100644
--- a/databases/lua-xapian/Makefile
+++ b/databases/lua-xapian/Makefile
@@ -18,7 +18,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= xapian-core>=${PORTVERSION}:databases/xapian-core
LIB_DEPENDS= libxapian.so:databases/xapian-core
-CONFLICTS_INSTALL= xapian-bindings12-
+CONFLICTS_INSTALL= xapian-bindings12
OPTIONS_DEFINE= DOCS
diff --git a/databases/p5-Search-Xapian10/Makefile b/databases/p5-Search-Xapian10/Makefile
index 5e6fa264aa3e..bdb3737f11bf 100644
--- a/databases/p5-Search-Xapian10/Makefile
+++ b/databases/p5-Search-Xapian10/Makefile
@@ -18,7 +18,7 @@ LICENSE_COMB= dual
BUILD_DEPENDS= xapian-core10>=1.0.22:databases/xapian-core10
RUN_DEPENDS:= ${BUILD_DEPENDS}
-CONFLICTS_INSTALL= p5-Search-Xapian12-
+CONFLICTS_INSTALL= p5-Search-Xapian12
USES= perl5
USE_PERL5= configure
diff --git a/databases/postgis20/Makefile b/databases/postgis20/Makefile
index 79afb6b564e7..cb99024dd805 100644
--- a/databases/postgis20/Makefile
+++ b/databases/postgis20/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libgeos.so:graphics/geos \
libjson-c.so:devel/json-c \
libproj.so:graphics/proj
-CONFLICTS_INSTALL= postgis- postgis22- postgis23-
+CONFLICTS_INSTALL= postgis postgis22 postgis23
OPTIONS_DEFINE= LOADERGUI NLS RASTER TOPOLOGY
OPTIONS_DEFAULT=RASTER TOPOLOGY
diff --git a/databases/py-sqlalchemy11/Makefile b/databases/py-sqlalchemy11/Makefile
index 727a40d36fda..59026070e82e 100644
--- a/databases/py-sqlalchemy11/Makefile
+++ b/databases/py-sqlalchemy11/Makefile
@@ -18,7 +18,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock \
${PYTHON_PKGNAMEPREFIX}pytest>=2.5.2:devel/py-pytest \
${PYTHON_PKGNAMEPREFIX}pytest-xdist>=0:devel/py-pytest-xdist
-CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}sqlalchemy0 ${PYTHON_PKGNAMEPREFIX}sqlalchemy10-
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}sqlalchemy0 ${PYTHON_PKGNAMEPREFIX}sqlalchemy10
OPTIONS_DEFINE= DOCS EXAMPLES
OPTIONS_MULTI= BACKEND
diff --git a/databases/py-xapian/Makefile b/databases/py-xapian/Makefile
index f514d1ea9d5f..bfb637059260 100644
--- a/databases/py-xapian/Makefile
+++ b/databases/py-xapian/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libxapian.so:databases/xapian-core
BROKEN_aarch64= fails to build: Fatal Python error: swig_pythreadstate set in XapianSWIG_Python_Thread_Allow ctor
-CONFLICTS_INSTALL= xapian-bindings12-
+CONFLICTS_INSTALL= xapian-bindings12
OPTIONS_DEFINE= DOCS
diff --git a/databases/rocksdb/Makefile b/databases/rocksdb/Makefile
index 26eceea32bf6..736ff6795308 100644
--- a/databases/rocksdb/Makefile
+++ b/databases/rocksdb/Makefile
@@ -53,7 +53,7 @@ LZ4_LIB_DEPENDS= liblz4.so:archivers/liblz4
ZSTD_LIB_DEPENDS= libzstd.so:archivers/zstd
.if !defined(LITE)
-CONFLICTS_INSTALL= rocksdb-lite-
+CONFLICTS_INSTALL= rocksdb-lite
PLIST_SUB+= LITE=""
.else
PKGNAMESUFFIX= -lite
diff --git a/databases/xapian-bindings12/Makefile b/databases/xapian-bindings12/Makefile
index 18966929c8f3..1c104b94fcba 100644
--- a/databases/xapian-bindings12/Makefile
+++ b/databases/xapian-bindings12/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libxapian.so:databases/xapian-core12
-CONFLICTS_INSTALL= xapian-bindings-
+CONFLICTS= xapian-bindings
OPTIONS_DEFINE= DOCS LUA PHP PYTHON RUBY
OPTIONS_DEFAULT=PHP PYTHON RUBY
diff --git a/databases/xapian-core/Makefile b/databases/xapian-core/Makefile
index 5dcab17f06c4..7591100cf095 100644
--- a/databases/xapian-core/Makefile
+++ b/databases/xapian-core/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_powerpc64= fails to configure: A compiler with support for C++11 language features is required
-CONFLICTS_INSTALL= xapian-core10- xapian-core12-
+CONFLICTS_INSTALL= xapian-core10 xapian-core12
OPTIONS_DEFINE= DOCS SSE2
SSE2_DESC= Use SSE2 for floating point
diff --git a/databases/xapian-core10/Makefile b/databases/xapian-core10/Makefile
index d2765a5086e0..2832b63abc3d 100644
--- a/databases/xapian-core10/Makefile
+++ b/databases/xapian-core10/Makefile
@@ -17,7 +17,7 @@ BROKEN_armv6= fails to install: quartz_log.cc:: error: call to 'om_tostring' is
BROKEN_mips= fails to install: quartz_log.cc:: error: call to 'om_tostring' is ambiguous
BROKEN_mips64= fails to install: quartz_log.cc:: error: call to 'om_tostring' is ambiguous
-CONFLICTS_INSTALL= xapian-core- xapian-core12-
+CONFLICTS_INSTALL= xapian-core xapian-core12
USES= libtool
GNU_CONFIGURE= yes
diff --git a/databases/xapian-core12/Makefile b/databases/xapian-core12/Makefile
index bc82dea8be94..258766e2bc14 100644
--- a/databases/xapian-core12/Makefile
+++ b/databases/xapian-core12/Makefile
@@ -15,7 +15,7 @@ COMMENT= Probabilistic text search database engine
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-CONFLICTS_INSTALL= xapian-core- xapian-core10-
+CONFLICTS_INSTALL= xapian-core xapian-core10
OPTIONS_DEFINE= DOCS SSE2
SSE2_DESC= Use SSE2 for floating point