aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2016-01-11 21:27:05 +0800
committerFrederic Culot <culot@FreeBSD.org>2016-01-11 21:27:05 +0800
commit8c27d1cc4957b03ac8358d319172636c8440f5d0 (patch)
tree5dd1cee350df73cad71930133eb6b0b6cc565d93 /databases
parent58ac3a503045aeda58caca3d902eec8764a64323 (diff)
downloadfreebsd-ports-gnome-8c27d1cc4957b03ac8358d319172636c8440f5d0.tar.gz
freebsd-ports-gnome-8c27d1cc4957b03ac8358d319172636c8440f5d0.tar.zst
freebsd-ports-gnome-8c27d1cc4957b03ac8358d319172636c8440f5d0.zip
- Update to 3.10.0
- Add options to choose the command line library used by shell tools - Add option for static linking - Add option to compile sqlite with SQLITE_LIKE_DOESNT_MATCH_BLOBS option - Remove option TEMP_CACHE_SIZE - Cosmetic changes Changes: http://www.sqlite.org/releaselog/3_10_0.html PR: 206062 Submitted by: Pavel Volkov <pavelivolkov@gmail.com> (maintainer)
Diffstat (limited to 'databases')
-rw-r--r--databases/sqlite3/Makefile70
-rw-r--r--databases/sqlite3/distinfo4
-rw-r--r--databases/sqlite3/pkg-descr2
3 files changed, 45 insertions, 31 deletions
diff --git a/databases/sqlite3/Makefile b/databases/sqlite3/Makefile
index 0326980df772..361cd6cae993 100644
--- a/databases/sqlite3/Makefile
+++ b/databases/sqlite3/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= sqlite3
-PORTVERSION= 3.9.2
+PORTVERSION= 3.10.0
CATEGORIES= databases
-MASTER_SITES= https://www.sqlite.org/2015/ http://www2.sqlite.org/2015/ http://www3.sqlite.org/2015/
+MASTER_SITES= https://www.sqlite.org/2016/ http://www2.sqlite.org/2016/ http://www3.sqlite.org/2016/
DISTNAME= sqlite-autoconf-${PORTVERSION:C/\.([[:digit:]])[[:>:]]/0\1/g:S/.//g}00
MAINTAINER= pavelivolkov@gmail.com
@@ -12,7 +12,7 @@ COMMENT= SQL database engine in a C library
LICENSE= public
LICENSE_NAME= Public Domain
-LICENSE_TEXT= Description of the license can be obtained from the following URL: http://www.sqlite.org/copyright.html
+LICENSE_TEXT= Description of the license can be obtained from the following URL: https://www.sqlite.org/copyright.html
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
CONFLICTS= sqlcipher-[0-9]*
@@ -25,12 +25,13 @@ CFLAGS+= -Os
MAKE_JOBS_UNSAFE= yes
-# Compilation Options For SQLite http://www.sqlite.org/compile.html
+# Compilation Options For SQLite https://www.sqlite.org/compile.html
OPTIONS_DEFINE= FTS4 UPD_DEL_LIMIT URI URI_AUTHORITY SOUNDEX METADATA \
DIRECT_READ MEMMAN SECURE_DELETE UNLOCK_NOTIFY THREADS \
- EXTENSION READLINE ARMOR STMT DBSTAT FTS5 JSON1 RBU
+ EXTENSION ARMOR STMT DBSTAT FTS5 JSON1 RBU \
+ LIKENOTBLOB STSHELL
OPTIONS_SINGLE= RAMT
-OPTIONS_RADIO= STAT
+OPTIONS_RADIO= STAT RL
OPTIONS_GROUP= UNICODE RTREEG
UPD_DEL_LIMIT_DESC= ORDER BY and LIMIT on UPDATE and DELETE
@@ -43,26 +44,31 @@ MEMMAN_DESC= Allows it to release unused memory
SECURE_DELETE_DESC= Overwrite deleted information with zeros
UNLOCK_NOTIFY_DESC= Enable notification on unlocking
EXTENSION_DESC= Allow loadable extensions
+STSHELL_DESC= Statically link libsqlite3 into shell
-# http://www.sqlite.org/compile.html#enable_api_armor
+# https://sqlite.org/compile.html#like_doesnt_match_blobs
+LIKENOTBLOB_DESC= LIKE does not match blobs
+
+# https://www.sqlite.org/compile.html#enable_api_armor
ARMOR_DESC= Detect misuse of the API
-# http://www.sqlite.org/fts3.html
+# https://www.sqlite.org/fts3.html
+# https://www.sqlite.org/compile.html#enable_fts3_parenthesis
FTS4_DESC= Enable FTS3/4 (Full Text Search) module
-# http://www.sqlite.org/fts5.html
+# https://www.sqlite.org/fts5.html
FTS5_DESC= Enable version 5 full-text search engine
-# http://www.sqlite.org/json1.html
+# https://www.sqlite.org/json1.html
JSON1_DESC= Enable the JSON1 extension
-# http://www.sqlite.org/rbu.html
+# https://www.sqlite.org/rbu.html
RBU_DESC= Enable the Resumable Bulk Update
-# http://www.sqlite.org/c3ref/stmt_scanstatus.html
+# https://www.sqlite.org/c3ref/stmt_scanstatus.html
STMT_DESC= Prepared Statement Scan Status
-# http://www.sqlite.org/tempfiles.html#tempstore
+# https://www.sqlite.org/tempfiles.html#tempstore
OPTIONS_SINGLE_RAMT= TS0 TS1 TS2 TS3
RAMT_DESC= Where to store temporary file
TS0_DESC= Always use temporary file
@@ -70,28 +76,34 @@ TS1_DESC= File by default, change allowed PRAGMA
TS2_DESC= Memory by default, change allowed PRAGMA
TS3_DESC= Always use memory
-# http://www.sqlite.org/queryplanner-ng.html#qpstab
+# https://www.sqlite.org/queryplanner-ng.html#qpstab
OPTIONS_RADIO_STAT= STAT3 STAT4
-STAT_DESC= Which query planner to use
+STAT_DESC= Which query planner to use, Stability or ...
STAT3_DESC= collect histogram data from leftmost column
STAT4_DESC= collect histogram data from all columns
-# http://www.sqlite.org/dbstat.html
+# https://www.sqlite.org/dbstat.html
DBSTAT_DESC= Enable DBSTAT Virtual Table
-# http://www.sqlite.org/fts3.html#tokenizer
+# https://www.sqlite.org/fts3.html#tokenizer
OPTIONS_GROUP_UNICODE= ICU UNICODE61
UNICODE_DESC= Unicode support
UNICODE61_DESC= Unicode Version 6.1 tokenizer
-# http://www.sqlite.org/rtree.html
+# https://www.sqlite.org/rtree.html
OPTIONS_GROUP_RTREEG= RTREE RTREE_INT
RTREEG_DESC= Index type for range queries
RTREE_DESC= Enable R*Tree module
RTREE_INT_DESC= Store 32-bit sig int (no float) coordinates
+OPTIONS_RADIO_RL= READLINES READLINEP EDITLINE
+RL_DESC= Which command line editing library to use:
+READLINES_DESC= the libreadline from system
+READLINEP_DESC= the GNU libreadline from ports
+EDITLINE_DESC= the BSD libedit from ports
+
OPTIONS_DEFAULT= FTS4 URI METADATA SECURE_DELETE UNLOCK_NOTIFY THREADS \
- EXTENSION TS1 UNICODE61 RTREE READLINE DBSTAT
+ EXTENSION TS1 UNICODE61 RTREE DBSTAT STSHELL
# SECURE_DELETE, UNLOCK_NOTIFY, DBSTAT (since 41.0) used by www/firefox et al.
# RTREE used by graphics/mapnik, databases/spatialite
@@ -107,12 +119,6 @@ PLIST_FILES= bin/sqlite3 include/sqlite3.h include/sqlite3ext.h \
CPPFLAGS+= -DSQLITE_DEFAULT_FILE_PERMISSIONS=${DEFAULT_FILE_PERMISSIONS}
.endif
-# This macro sets the default size of the page-cache for temporary files
-# created by SQLite to store intermediate results, in pages.
-.ifdef TEMP_CACHE_SIZE
-CPPFLAGS+= -DSQLITE_DEFAULT_TEMP_CACHE_SIZE=${TEMP_CACHE_SIZE}
-.endif
-
# Use an in-ram database for temporary tables (never,no,yes,always),
TS0_CPPFLAGS= -DSQLITE_TEMP_STORE=0
TS1_CPPFLAGS= -DSQLITE_TEMP_STORE=1
@@ -122,7 +128,7 @@ TS3_CPPFLAGS= -DSQLITE_TEMP_STORE=3
RTREE_CPPFLAGS= -DSQLITE_ENABLE_RTREE=1
RTREE_INT_CPPFLAGS= -DSQLITE_RTREE_INT_ONLY=1
-FTS4_CPPFLAGS= -DSQLITE_ENABLE_FTS3=1 -DSQLITE_ENABLE_FTS3_PARENTHESIS=1 -DSQLITE_ENABLE_FTS4=1
+FTS4_CPPFLAGS= -DSQLITE_ENABLE_FTS3_PARENTHESIS=1 -DSQLITE_ENABLE_FTS4=1
SOUNDEX_CPPFLAGS= -DSQLITE_SOUNDEX=1
MEMMAN_CPPFLAGS= -DSQLITE_ENABLE_MEMORY_MANAGEMENT=1
UPD_DEL_LIMIT_CPPFLAGS= -DSQLITE_ENABLE_UPDATE_DELETE_LIMIT=1
@@ -150,8 +156,12 @@ ICU_LDFLAGS= `${LOCALBASE}/bin/icu-config --ldflags`
UNICODE61_CPPFLAGS_OFF= -DSQLITE_DISABLE_FTS3_UNICODE=1
-READLINE_CONFIGURE_ENABLE= readline
-READLINE_USES= readline
+READLINES_CONFIGURE_ON= --enable-readline
+READLINES_USES= readline
+READLINEP_CONFIGURE_ON= --enable-readline
+READLINEP_USES= readline:port
+EDITLINE_CONFIGURE_ENABLE= editline
+EDITLINE_USES= libedit
FTS5_CONFIGURE_ENABLE= fts5
@@ -159,6 +169,10 @@ JSON1_CONFIGURE_ENABLE= json1
RBU_CPPFLAGS= -DSQLITE_ENABLE_RBU=1
+LIKENOTBLOB_CPPFLAGS= -DSQLITE_LIKE_DOESNT_MATCH_BLOBS=1
+
+STSHELL_CONFIGURE_ENABLE= static-shell
+
.include <bsd.port.options.mk>
post-configure:
diff --git a/databases/sqlite3/distinfo b/databases/sqlite3/distinfo
index bd5c68aa6802..94a1e9707537 100644
--- a/databases/sqlite3/distinfo
+++ b/databases/sqlite3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sqlite-autoconf-3090200.tar.gz) = 064c0abe9c9177534d4c770bca7a5902f9924b629ac886b4c08956be6dfbc36b
-SIZE (sqlite-autoconf-3090200.tar.gz) = 2284431
+SHA256 (sqlite-autoconf-3100000.tar.gz) = 43cc292d70711fa7580250c8a1cd7c64813a4a0a479dbd502cce5f10b5d91042
+SIZE (sqlite-autoconf-3100000.tar.gz) = 2331542
diff --git a/databases/sqlite3/pkg-descr b/databases/sqlite3/pkg-descr
index 88d2ce80737e..6fb7bc338cc0 100644
--- a/databases/sqlite3/pkg-descr
+++ b/databases/sqlite3/pkg-descr
@@ -1,6 +1,6 @@
SQLite is an SQL database engine in a C library. Programs that link the SQLite
library can have SQL database access without running a separate RDBMS process.
-The distribution comes with a standalone command-line access program (sqlite)
+The distribution comes with a standalone command-line access program (sqlite3)
that can be used to administer an SQLite database and which serves as an
example of how to use the SQLite library.