aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-16 07:11:12 +0800
committeradamw <adamw@FreeBSD.org>2014-07-16 07:11:12 +0800
commit9343eeba7783ac2ce4c8f5c88ab322647d489c19 (patch)
tree37076f8661cc0a667d6e54eab2728ecc665430a0 /databases
parentd5dd4663dfc459a5aa6a241eff9b72f253fbc4e8 (diff)
downloadfreebsd-ports-gnome-9343eeba7783ac2ce4c8f5c88ab322647d489c19.tar.gz
freebsd-ports-gnome-9343eeba7783ac2ce4c8f5c88ab322647d489c19.tar.zst
freebsd-ports-gnome-9343eeba7783ac2ce4c8f5c88ab322647d489c19.zip
Add OPTIONS_DEFINE=DOCS for ports with %%PORTDOCS%% in the plist.
Where possible, correct a few instances where PORTDOCS was being used to flag stuff in EXAMPLESDIR. For some ports, mostly those owned by ruby@, PORTDOCS is applied to pretty much everything whether it's documentation or example.
Diffstat (limited to 'databases')
-rw-r--r--databases/adodb5/Makefile2
-rw-r--r--databases/c3p0/Makefile2
-rw-r--r--databases/gtksql/Makefile2
-rw-r--r--databases/libdbi/Makefile2
-rw-r--r--databases/pg_filedump/Makefile2
-rw-r--r--databases/py-sqlkit/Makefile2
-rw-r--r--databases/ruby-cdb/Makefile2
-rw-r--r--databases/ruby-dbi/Makefile2
-rw-r--r--databases/ruby-o_dbm/Makefile2
-rw-r--r--databases/ruby-sybct/Makefile2
-rw-r--r--databases/ruby-tokyocabinet/Makefile2
11 files changed, 19 insertions, 3 deletions
diff --git a/databases/adodb5/Makefile b/databases/adodb5/Makefile
index 43b169579c90..959dffd06d56 100644
--- a/databases/adodb5/Makefile
+++ b/databases/adodb5/Makefile
@@ -24,7 +24,7 @@ NO_BUILD= YES
ADODB_SUBDIRS= contrib datadict drivers lang pear perf session xsl
-OPTIONS_DEFINE= TESTS
+OPTIONS_DEFINE= TESTS DOCS
TESTS_DESC= Install tests
.include <bsd.port.options.mk>
diff --git a/databases/c3p0/Makefile b/databases/c3p0/Makefile
index 1340793939b7..60745ea7b54f 100644
--- a/databases/c3p0/Makefile
+++ b/databases/c3p0/Makefile
@@ -15,6 +15,8 @@ NO_BUILD= yes
JAVA_VERSION= 1.6+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+OPTIONS_DEFINE= DOCS
+
do-install:
${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME}-${PORTVERSION}.jar ${STAGEDIR}${JAVAJARDIR}/${PORTNAME}.jar
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/databases/gtksql/Makefile b/databases/gtksql/Makefile
index 69147acf2d4e..d67cb27f8bd1 100644
--- a/databases/gtksql/Makefile
+++ b/databases/gtksql/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2 # (or later)
LIB_DEPENDS= libscintilla.so:${PORTSDIR}/x11-toolkits/scintilla
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
-OPTIONS_DEFINE= AVAHI
+OPTIONS_DEFINE= AVAHI DOCS
OPTIONS_MULTI= DB
OPTIONS_MULTI_DB= MYSQL PGSQL SQLITE
OPTIONS_DEFAULT= SQLITE
diff --git a/databases/libdbi/Makefile b/databases/libdbi/Makefile
index 334ca7817383..fd0c31d1e889 100644
--- a/databases/libdbi/Makefile
+++ b/databases/libdbi/Makefile
@@ -15,6 +15,8 @@ USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e "s|-O20|${CFLAGS}|g" -e "s|-std=gnu99||g" \
${WRKSRC}/configure
diff --git a/databases/pg_filedump/Makefile b/databases/pg_filedump/Makefile
index 46290c073019..5a7d8c34e26e 100644
--- a/databases/pg_filedump/Makefile
+++ b/databases/pg_filedump/Makefile
@@ -14,6 +14,8 @@ BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/databases/postgresql84-client:patch
WRKSRC= ${WRKDIR}/${PORTNAME}-8.4.0
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
BROKEN= Does not compile
diff --git a/databases/py-sqlkit/Makefile b/databases/py-sqlkit/Makefile
index 627343d5411c..d890b852394e 100644
--- a/databases/py-sqlkit/Makefile
+++ b/databases/py-sqlkit/Makefile
@@ -22,7 +22,7 @@ USE_PYDISTUTILS=yes
USE_GNOME= pygtk2
USES= gettext
-OPTIONS_DEFINE= FIREBIRD MSSQL MYSQL PGSQL SQLITE SYBASE
+OPTIONS_DEFINE= FIREBIRD MSSQL MYSQL PGSQL SQLITE SYBASE DOCS
OPTIONS_DEFAULT=MYSQL PGSQL SQLITE
SYBASE_DESC= Sybase support
diff --git a/databases/ruby-cdb/Makefile b/databases/ruby-cdb/Makefile
index f9a41f7348c7..0bcd0418e36b 100644
--- a/databases/ruby-cdb/Makefile
+++ b/databases/ruby-cdb/Makefile
@@ -22,6 +22,8 @@ CDB_PORTDIR= ${PORTSDIR}/databases/cdb
INSTALL_TARGET= site-install
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
post-patch:
diff --git a/databases/ruby-dbi/Makefile b/databases/ruby-dbi/Makefile
index 4e5d0af8947f..cacdcfd1ac60 100644
--- a/databases/ruby-dbi/Makefile
+++ b/databases/ruby-dbi/Makefile
@@ -19,6 +19,8 @@ RUN_DEPENDS= ${RUBY_SITELIBDIR}/aspectr.rb:${PORTSDIR}/devel/ruby-aspectr \
USE_RUBY= yes
USE_RUBY_SETUP= yes
+OPTIONS_DEFINE= DOCS
+
post-install:
${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${RUBY_MODEXAMPLESDIR}/
diff --git a/databases/ruby-o_dbm/Makefile b/databases/ruby-o_dbm/Makefile
index 976e3acc6455..cfa7d0e80c04 100644
--- a/databases/ruby-o_dbm/Makefile
+++ b/databases/ruby-o_dbm/Makefile
@@ -16,6 +16,8 @@ USE_RUBY= yes
NO_BUILD= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
${MKDIR} ${STAGEDIR}${RUBY_SITELIBDIR}
${INSTALL_DATA} ${WRKSRC}/o_dbm.rb ${STAGEDIR}${RUBY_SITELIBDIR}/
diff --git a/databases/ruby-sybct/Makefile b/databases/ruby-sybct/Makefile
index 78f6e57af2de..1846ac96cc94 100644
--- a/databases/ruby-sybct/Makefile
+++ b/databases/ruby-sybct/Makefile
@@ -18,6 +18,8 @@ USE_RUBY= yes
USE_RUBY_EXTCONF= yes
USES= iconv
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
-e 's|%%ICONV_LIB%%|${ICONV_LIB}|' \
diff --git a/databases/ruby-tokyocabinet/Makefile b/databases/ruby-tokyocabinet/Makefile
index 9578dfacf243..220de65e3150 100644
--- a/databases/ruby-tokyocabinet/Makefile
+++ b/databases/ruby-tokyocabinet/Makefile
@@ -21,6 +21,8 @@ INSTALL_TARGET= site-install
DOCS= doc/*
+OPTIONS_DEFINE= DOCS
+
post-install:
${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}
.for f in ${DOCS}