aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2017-08-24 17:02:01 +0800
committertz <tz@FreeBSD.org>2017-08-24 17:02:01 +0800
commita1caf1d2e5e977522689679b0d3e5466ffc9c3f3 (patch)
tree1cea72da30ad1fe49650f739e9caf58861cee54e /databases
parente5725be25d7226455e71a706d83d777a9ffeceb7 (diff)
downloadfreebsd-ports-gnome-a1caf1d2e5e977522689679b0d3e5466ffc9c3f3.tar.gz
freebsd-ports-gnome-a1caf1d2e5e977522689679b0d3e5466ffc9c3f3.tar.zst
freebsd-ports-gnome-a1caf1d2e5e977522689679b0d3e5466ffc9c3f3.zip
New port: databases/rubygem-peek-mysql2
Take a peek into the MySQL queries made during your application's requests. Things this peek view provides: - Total number of MySQL queries called during the request - The duration of the queries made during the request WWW: https://github.com/peek/peek-mysql2
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/rubygem-peek-mysql2/Makefile23
-rw-r--r--databases/rubygem-peek-mysql2/distinfo3
-rw-r--r--databases/rubygem-peek-mysql2/pkg-descr7
4 files changed, 34 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index f19f1fa89312..23b426848126 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -961,6 +961,7 @@
SUBDIR += rubygem-mysql2
SUBDIR += rubygem-openid-redis-store
SUBDIR += rubygem-paranoia
+ SUBDIR += rubygem-peek-mysql2
SUBDIR += rubygem-pg
SUBDIR += rubygem-pg_array_parser
SUBDIR += rubygem-pghero
diff --git a/databases/rubygem-peek-mysql2/Makefile b/databases/rubygem-peek-mysql2/Makefile
new file mode 100644
index 000000000000..6e6f060eb136
--- /dev/null
+++ b/databases/rubygem-peek-mysql2/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= peek-mysql2
+PORTVERSION= 1.2.0
+CATEGORIES= databases rubygems
+MASTER_SITES= RG
+
+MAINTAINER= tz@FreeBSD.org
+COMMENT= Take a peek into the MySQL queries made
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-concurrent-ruby>=0:devel/rubygem-concurrent-ruby \
+ rubygem-concurrent-ruby-ext>=0:devel/rubygem-concurrent-ruby-ext \
+ rubygem-mysql2>=0:databases/rubygem-mysql2 \
+ rubygem-peek>=0.1.0:devel/rubygem-peek
+
+NO_ARCH= yes
+USES= gem
+USE_RUBY= yes
+
+.include <bsd.port.mk>
diff --git a/databases/rubygem-peek-mysql2/distinfo b/databases/rubygem-peek-mysql2/distinfo
new file mode 100644
index 000000000000..cf420fad65b0
--- /dev/null
+++ b/databases/rubygem-peek-mysql2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1503565014
+SHA256 (rubygem/peek-mysql2-1.2.0.gem) = 3fcd004dd193ffeb1acbdf0f081a8baa2c998ec49711f8d0077d02ee47e5752b
+SIZE (rubygem/peek-mysql2-1.2.0.gem) = 7168
diff --git a/databases/rubygem-peek-mysql2/pkg-descr b/databases/rubygem-peek-mysql2/pkg-descr
new file mode 100644
index 000000000000..a1b0233be7d3
--- /dev/null
+++ b/databases/rubygem-peek-mysql2/pkg-descr
@@ -0,0 +1,7 @@
+Take a peek into the MySQL queries made during your application's requests.
+
+Things this peek view provides:
+- Total number of MySQL queries called during the request
+- The duration of the queries made during the request
+
+WWW: https://github.com/peek/peek-mysql2