aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-06-24 02:04:12 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-06-24 02:04:12 +0800
commitafad66935378b8e8d760700686eb5a3330839209 (patch)
tree25738879c8782d6273b5ce972570ec1112d6086e /databases
parentf753e3c483d25a129d165bca640f3120349644f3 (diff)
downloadfreebsd-ports-gnome-afad66935378b8e8d760700686eb5a3330839209.tar.gz
freebsd-ports-gnome-afad66935378b8e8d760700686eb5a3330839209.tar.zst
freebsd-ports-gnome-afad66935378b8e8d760700686eb5a3330839209.zip
PgDBF is a program for converting XBase databases - particularly FoxPro
tables with memo files - into a format that PostgreSQL can directly import. It's a compact C project with no dependencies other than standard Unix libraries. While the project is relatively tiny and simple, it's also heavily optimized via profiling - routine benchmark were many times faster than with other Open Source programs. In fact, even on slower systems, conversions are typically limited by hard drive speed. WWW: http://pgdbf.sourceforge.net/ PR: ports/135969 Submitted by: kirk at daycos.com
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pgdbf/Makefile25
-rw-r--r--databases/pgdbf/distinfo3
-rw-r--r--databases/pgdbf/pkg-descr9
4 files changed, 38 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 56b77819a539..bd60b44d281e 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -438,6 +438,7 @@
SUBDIR += pgadmin3-12
SUBDIR += pgbouncer
SUBDIR += pgcluster
+ SUBDIR += pgdbf
SUBDIR += pgfouine
SUBDIR += pgloader
SUBDIR += pgpool
diff --git a/databases/pgdbf/Makefile b/databases/pgdbf/Makefile
new file mode 100644
index 000000000000..0537c16d4f72
--- /dev/null
+++ b/databases/pgdbf/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: pgdbf
+# Date created: 23 June 2009
+# Whom: kirk@daycos.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= pgdbf
+PORTVERSION= 0.4.6
+CATEGORIES= databases
+MASTER_SITES= SF
+
+MAINTAINER= kirk@daycos.com
+COMMENT= Convert XBase / FoxPro tables to PostgreSQL
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+MAN1= pgdbf.1
+
+PLIST_FILES= bin/pgdbf \
+ share/doc/pgdbf/README
+PLIST_DIRS= %%DOCSDIR%%
+
+.include <bsd.port.mk>
diff --git a/databases/pgdbf/distinfo b/databases/pgdbf/distinfo
new file mode 100644
index 000000000000..d25feb32bd0f
--- /dev/null
+++ b/databases/pgdbf/distinfo
@@ -0,0 +1,3 @@
+MD5 (pgdbf-0.4.6.tar.gz) = 3b50364b44accefcaf68b85fb66f3750
+SHA256 (pgdbf-0.4.6.tar.gz) = 39d6f78f52487eeb0741f483e373447777d2341a656991eec419f40e0bc05d8e
+SIZE (pgdbf-0.4.6.tar.gz) = 102835
diff --git a/databases/pgdbf/pkg-descr b/databases/pgdbf/pkg-descr
new file mode 100644
index 000000000000..1c3f645f4d24
--- /dev/null
+++ b/databases/pgdbf/pkg-descr
@@ -0,0 +1,9 @@
+PgDBF is a program for converting XBase databases - particularly FoxPro
+tables with memo files - into a format that PostgreSQL can directly
+import. It's a compact C project with no dependencies other than standard
+Unix libraries. While the project is relatively tiny and simple, it's also
+heavily optimized via profiling - routine benchmark were many times faster
+than with other Open Source programs. In fact, even on slower systems,
+conversions are typically limited by hard drive speed.
+
+WWW: http://pgdbf.sourceforge.net/