aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-09-14 06:54:36 +0800
committerpav <pav@FreeBSD.org>2005-09-14 06:54:36 +0800
commitaff7624ced761fcc509d6f8f04fd24757dcb484d (patch)
tree8b3b9899e7f917f9b3825bcd384b1556364fb787 /databases
parent05132bb7e28eedd86e2aba2b5105e40ae8c92a80 (diff)
downloadfreebsd-ports-gnome-aff7624ced761fcc509d6f8f04fd24757dcb484d.tar.gz
freebsd-ports-gnome-aff7624ced761fcc509d6f8f04fd24757dcb484d.tar.zst
freebsd-ports-gnome-aff7624ced761fcc509d6f8f04fd24757dcb484d.zip
This is PHP extension which provides a Mysql 3.x/4.x driver for PDO.
PR: ports/86034 Submitted by: Alexander Zhuravlev <zaa@zaa.pp.ru>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pecl-PDO_MYSQL/Makefile32
-rw-r--r--databases/pecl-PDO_MYSQL/distinfo2
-rw-r--r--databases/pecl-PDO_MYSQL/pkg-descr3
4 files changed, 38 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 4f178983e890..bb547a7b9ee8 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -247,6 +247,7 @@
SUBDIR += pear-MDB2
SUBDIR += pear-MDB_QueryTool
SUBDIR += pecl-PDO
+ SUBDIR += pecl-PDO_MYSQL
SUBDIR += pecl-memcache
SUBDIR += pecl-sqlite
SUBDIR += pgaccess
diff --git a/databases/pecl-PDO_MYSQL/Makefile b/databases/pecl-PDO_MYSQL/Makefile
new file mode 100644
index 000000000000..f572af68ec43
--- /dev/null
+++ b/databases/pecl-PDO_MYSQL/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: pecl-PDO_MYSQL
+# Date created: 2005-09-10
+# Whom: Alexander Zhuravlev <zaa@zaa.pp.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PDO_MYSQL
+DISTVERSION= 1.0RC1
+CATEGORIES= databases www
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= zaa@zaa.pp.ru
+COMMENT= MySQL 3.x/4.0 driver for PDO
+
+BUILD_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo.so:${PORTSDIR}/databases/pecl-PDO
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+USE_PHP= yes
+USE_PHPIZE= yes
+USE_PHPEXT= yes
+DEFAULT_PHP_VER=5
+PHP_MODNAME= pdo_mysql
+
+CONFIGURE_ARGS+=--with-pdo-mysql=${LOCALBASE}
+
+USE_MYSQL= yes
+
+.include <bsd.port.mk>
diff --git a/databases/pecl-PDO_MYSQL/distinfo b/databases/pecl-PDO_MYSQL/distinfo
new file mode 100644
index 000000000000..57bad2953ebb
--- /dev/null
+++ b/databases/pecl-PDO_MYSQL/distinfo
@@ -0,0 +1,2 @@
+MD5 (PECL/PDO_MYSQL-1.0RC1.tgz) = fe5e1b03e124922d942046ded19a3303
+SIZE (PECL/PDO_MYSQL-1.0RC1.tgz) = 11553
diff --git a/databases/pecl-PDO_MYSQL/pkg-descr b/databases/pecl-PDO_MYSQL/pkg-descr
new file mode 100644
index 000000000000..ee0ecf623784
--- /dev/null
+++ b/databases/pecl-PDO_MYSQL/pkg-descr
@@ -0,0 +1,3 @@
+This is PHP extension which provides a Mysql 3.x/4.x driver for PDO.
+
+WWW: http://pecl.php.net/package/PDO_MYSQL