aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2002-11-27 09:00:57 +0800
committermi <mi@FreeBSD.org>2002-11-27 09:00:57 +0800
commitb19f817e034b2e21e9261ab4a261b9f06fbc6ed5 (patch)
treed57df6915cc544236629067e265f6eb2bae1979d /databases
parent8ea058c0ab69378156229097cd935cee1839933f (diff)
downloadfreebsd-ports-gnome-b19f817e034b2e21e9261ab4a261b9f06fbc6ed5.tar.gz
freebsd-ports-gnome-b19f817e034b2e21e9261ab4a261b9f06fbc6ed5.tar.zst
freebsd-ports-gnome-b19f817e034b2e21e9261ab4a261b9f06fbc6ed5.zip
This library should always have been linked with c++, rather than
cc, but we were able to get away with it previously. Not any more. Set CC to ${CXX} (something bsd.lib.mk should be doing for us!) to avoid unresolved __gxx_personality_v0 when trying to load the package into the Tcl interpreter at run-time. No PORTREVISION bump, since the port did not build on -current until 5 minutes ago, and the problem does not affect -stable. Not Approved by: portmgr (Linnex would too cruel and too unusual anyway)
Diffstat (limited to 'databases')
-rw-r--r--databases/tcl-Mysql/files/Makefile.bsd1
1 files changed, 1 insertions, 0 deletions
diff --git a/databases/tcl-Mysql/files/Makefile.bsd b/databases/tcl-Mysql/files/Makefile.bsd
index eb19e914f869..482163b333b5 100644
--- a/databases/tcl-Mysql/files/Makefile.bsd
+++ b/databases/tcl-Mysql/files/Makefile.bsd
@@ -2,6 +2,7 @@ TCL_VERSION?= tcl8.3
TCL_NODOT?= ${TCL_VERSION:S/.//}
SHLIB_NAME= libTclMySQL.so.1
+CC = ${CXX} # a hack to force linking with c++
SRCS = sql-mysql.cc sql.cc sql-manager.cc
CXXFLAGS+= -I${LOCALBASE}/include/${TCL_VERSION}
CXXFLAGS+= -I${LOCALBASE}/include/mysql