aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-06-21 14:27:10 +0800
committerjgh <jgh@FreeBSD.org>2013-06-21 14:27:10 +0800
commitb34148d7dad0fef1041552086f161d71d267aa46 (patch)
treef86e9e3c64bb41c9d80dc94e6fff7e1c1418642a /databases
parent3303f38d9734e5b1269fa0c30737c6d97b5cc614 (diff)
downloadfreebsd-ports-gnome-b34148d7dad0fef1041552086f161d71d267aa46.tar.gz
freebsd-ports-gnome-b34148d7dad0fef1041552086f161d71d267aa46.tar.zst
freebsd-ports-gnome-b34148d7dad0fef1041552086f161d71d267aa46.zip
- add validated support for headless systems to use openjdk7
- default remains with openjdk6 Reported by: mfournier@openstudent.ca
Diffstat (limited to 'databases')
-rw-r--r--databases/jasperserver/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/databases/jasperserver/Makefile b/databases/jasperserver/Makefile
index ac8af15320bc..5fbd6174f57b 100644
--- a/databases/jasperserver/Makefile
+++ b/databases/jasperserver/Makefile
@@ -34,12 +34,13 @@ JSUPDATE= 5.0.0-${PORTVERSION}
NO_WRKSUBDIR= yes
USE_JAVA= yes
-JAVA_VERSION= 1.6
USE_ZIP= yes
# use own DOS2UNIX in pre-patch, not the one from bsd.port.mk!
DOS2UNIX_REGEX= .*(css|dtd|java|js|txt|wsdd|xml|xsl)$$
+OPTIONS_DEFINE= HEADLESS
+HEADLESS_DESC= Optimize for Headless Systems
OPTIONS_SINGLE= AS DB
OPTIONS_SINGLE_AS= TOMCAT6 TOMCAT7
OPTIONS_SINGLE_DB= MYSQL PGSQL
@@ -69,6 +70,12 @@ PORTDOCS= *
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MHEADLESS}
+JAVA_VERSION= 1.7
+.else
+JAVA_VERSION= 1.6
+.endif
+
.if ${PORT_OPTIONS:MMYSQL}
WANT_MYSQL_VER= 55
DBUSER?= root