aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-03-12 04:40:28 +0800
committerpav <pav@FreeBSD.org>2005-03-12 04:40:28 +0800
commitb63726809c90ca9282af7071ae93b599167ec2e8 (patch)
tree01cf9923d90a1743100250470bce84cbf59cf767 /databases
parent466e17f9e6aeadfa111d896e2d38b23ada3b8506 (diff)
downloadfreebsd-ports-gnome-b63726809c90ca9282af7071ae93b599167ec2e8.tar.gz
freebsd-ports-gnome-b63726809c90ca9282af7071ae93b599167ec2e8.tar.zst
freebsd-ports-gnome-b63726809c90ca9282af7071ae93b599167ec2e8.zip
PEAR::DBA is a wrapper for the php DBA functions. It includes a file-based
emulator and provides a uniform, object-based interface for the Berkeley-style database systems. PR: ports/78600 Submitted by: Antonio Carlos Venancio Junior <antonio@php.net>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pear-DBA/Makefile24
-rw-r--r--databases/pear-DBA/distinfo2
-rw-r--r--databases/pear-DBA/pkg-descr5
4 files changed, 32 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 426be3b50e03..b9a671f1ec8b 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -216,6 +216,7 @@
SUBDIR += pear-DB_Pager
SUBDIR += pear-DB_QueryTool
SUBDIR += pear-DB_ldap
+ SUBDIR += pear-DBA
SUBDIR += pear-MDB
SUBDIR += pear-MDB2
SUBDIR += pear-MDB_QueryTool
diff --git a/databases/pear-DBA/Makefile b/databases/pear-DBA/Makefile
new file mode 100644
index 000000000000..0d201d0757cb
--- /dev/null
+++ b/databases/pear-DBA/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: pear-DBA
+# Date created: 08 March 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBA
+PORTVERSION= 1.1
+CATEGORIES= databases www pear
+
+MAINTAINER= antonio@php.net
+COMMENT= Berkely-style database abstraction class
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+FILES= DBA.php DBA/Compatibility.php DBA/Driver/File.php DBA/Driver/Builtin.php
+TESTS= benchmark_drivers.php test_drivers.php test_compatibility.php
+DOCS= README.txt
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/databases/pear-DBA/distinfo b/databases/pear-DBA/distinfo
new file mode 100644
index 000000000000..e2cb1f4b61fd
--- /dev/null
+++ b/databases/pear-DBA/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/DBA-1.1.tgz) = 55bf3ff111e3ceea9fd985e975ac4d09
+SIZE (PEAR/DBA-1.1.tgz) = 12578
diff --git a/databases/pear-DBA/pkg-descr b/databases/pear-DBA/pkg-descr
new file mode 100644
index 000000000000..3b10e46ca52a
--- /dev/null
+++ b/databases/pear-DBA/pkg-descr
@@ -0,0 +1,5 @@
+PEAR::DBA is a wrapper for the php DBA functions. It includes a file-based
+emulator and provides a uniform, object-based interface for the
+Berkeley-style database systems.
+
+WWW: http://pear.php.net/package/DBA/