aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-01-27 02:11:12 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-01-27 02:11:12 +0800
commitb641703a70559e6a4427cd51526b6532def4c570 (patch)
treeb03c740f2504acc3dae84191e18d1e6834307ed0 /databases
parente794e2315c56582dbd521732d045fb55282e9e39 (diff)
downloadfreebsd-ports-gnome-b641703a70559e6a4427cd51526b6532def4c570.tar.gz
freebsd-ports-gnome-b641703a70559e6a4427cd51526b6532def4c570.tar.zst
freebsd-ports-gnome-b641703a70559e6a4427cd51526b6532def4c570.zip
Fix packaging with PHP 7.x
- Sort PLIST Reported by: Oliver Schonrock <oliver@schonrocks.com>
Diffstat (limited to 'databases')
-rw-r--r--databases/php-xapian/Makefile2
-rw-r--r--databases/php-xapian/pkg-plist3
2 files changed, 4 insertions, 1 deletions
diff --git a/databases/php-xapian/Makefile b/databases/php-xapian/Makefile
index adf417d1fc06..2ce91f1bce3e 100644
--- a/databases/php-xapian/Makefile
+++ b/databases/php-xapian/Makefile
@@ -40,8 +40,10 @@ PLIST_SUB= PHP_EXT_DIR=${PHP_EXT_DIR} PHP_MAJOR_VER=${PHP_VER:C|.$||}
.if ${PHP_VER} >= 70
CONFIGURE_ARGS+=--with-php7 --without-php
+PLIST_SUB+= PHP5="@comment " PHP7=""
.else
CONFIGURE_ARGS+=--with-php --without-php7
+PLIST_SUB+= PHP5="" PHP7="@comment "
.endif
post-patch:
diff --git a/databases/php-xapian/pkg-plist b/databases/php-xapian/pkg-plist
index e36cc528f620..474983f869fe 100644
--- a/databases/php-xapian/pkg-plist
+++ b/databases/php-xapian/pkg-plist
@@ -1,8 +1,9 @@
lib/php/%%PHP_EXT_DIR%%/xapian.a
lib/php/%%PHP_EXT_DIR%%/xapian.so
-%%DATADIR%%/php%%PHP_MAJOR_VER%%/xapian.php
%%PORTDOCS%%%%DOCSDIR%%/php/examples/simpleexpand.php%%PHP_MAJOR_VER%%
%%PORTDOCS%%%%DOCSDIR%%/php/examples/simpleindex.php%%PHP_MAJOR_VER%%
%%PORTDOCS%%%%DOCSDIR%%/php/examples/simplematchdecider.php%%PHP_MAJOR_VER%%
%%PORTDOCS%%%%DOCSDIR%%/php/examples/simplesearch.php%%PHP_MAJOR_VER%%
%%PORTDOCS%%%%DOCSDIR%%/php/index.html
+%%PHP7%%%%DATADIR%%/php/xapian.php
+%%PHP5%%%%DATADIR%%/php%%PHP_MAJOR_VER%%/xapian.php