aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2020-02-06 02:40:02 +0800
committersunpoet <sunpoet@FreeBSD.org>2020-02-06 02:40:02 +0800
commitb68c10b9c058a61e138813431d5262f73dc6194f (patch)
tree70fa0e599c8ff846617eb2e1f79bfc09ce72652f /databases
parent49df28c65023e490f6f4cdb920e10ea8b8e604f2 (diff)
downloadfreebsd-ports-gnome-b68c10b9c058a61e138813431d5262f73dc6194f.tar.gz
freebsd-ports-gnome-b68c10b9c058a61e138813431d5262f73dc6194f.tar.zst
freebsd-ports-gnome-b68c10b9c058a61e138813431d5262f73dc6194f.zip
Add rubygem-activerecord60 6.0.2.1 (copied from rubygem-activerecord52)
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/rubygem-activerecord60/Makefile28
-rw-r--r--databases/rubygem-activerecord60/distinfo3
-rw-r--r--databases/rubygem-activerecord60/pkg-descr14
4 files changed, 46 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 8fb6b369d13d..3e7e933cf0f2 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -905,6 +905,7 @@
SUBDIR += rubygem-activerecord5
SUBDIR += rubygem-activerecord50
SUBDIR += rubygem-activerecord52
+ SUBDIR += rubygem-activerecord60
SUBDIR += rubygem-after_commit_queue
SUBDIR += rubygem-amalgalite
SUBDIR += rubygem-arel
diff --git a/databases/rubygem-activerecord60/Makefile b/databases/rubygem-activerecord60/Makefile
new file mode 100644
index 000000000000..54d65ee6d656
--- /dev/null
+++ b/databases/rubygem-activerecord60/Makefile
@@ -0,0 +1,28 @@
+# Created by: Johannes Meixner <johannes@perceivon.net>
+# $FreeBSD$
+
+PORTNAME= activerecord
+PORTVERSION= 6.0.2.1
+CATEGORIES= databases rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 60
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Object-relational mapping layer for Rails MVC Framework
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+BROKEN_RUBY24= yes
+
+RUN_DEPENDS= rubygem-activemodel60>=${PORTVERSION}:databases/rubygem-activemodel60 \
+ rubygem-activesupport60>=${PORTVERSION}:devel/rubygem-activesupport60
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^6\.0\.
+
+.include <bsd.port.mk>
diff --git a/databases/rubygem-activerecord60/distinfo b/databases/rubygem-activerecord60/distinfo
new file mode 100644
index 000000000000..c4d7e750973f
--- /dev/null
+++ b/databases/rubygem-activerecord60/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1577687162
+SHA256 (rubygem/activerecord-6.0.2.1.gem) = 083928e6fda8b886f24c198d37a6e9e0a077c1bf178ae76668a973175b6b578b
+SIZE (rubygem/activerecord-6.0.2.1.gem) = 406528
diff --git a/databases/rubygem-activerecord60/pkg-descr b/databases/rubygem-activerecord60/pkg-descr
new file mode 100644
index 000000000000..29c7987b2296
--- /dev/null
+++ b/databases/rubygem-activerecord60/pkg-descr
@@ -0,0 +1,14 @@
+Active Record connects classes to relational database tables to establish an
+almost zero-configuration persistence layer for applications. The library
+provides a base class that, when subclassed, sets up a mapping between the new
+class and an existing table in the database. In the context of an application,
+these classes are commonly referred to as models. Models can also be connected
+to other models; this is done by defining associations.
+
+Active Record relies heavily on naming in that it uses class and association
+names to establish mappings between respective database tables and foreign key
+columns. Although these mappings can be defined explicitly, it's recommended to
+follow naming conventions, especially when getting started with the library.
+
+WWW: https://rubyonrails.org/
+WWW: https://github.com/rails/rails/tree/master/activerecord