aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2012-02-01 02:21:33 +0800
committercrees <crees@FreeBSD.org>2012-02-01 02:21:33 +0800
commitc114d133441087e23ae60bf9917558676d37b775 (patch)
treef3dcb1502177b6ac13308ea14178ddb0e723d9ef /databases
parent9b4999ee5a06432b7effc9ccce67558a508b735d (diff)
downloadfreebsd-ports-gnome-c114d133441087e23ae60bf9917558676d37b775.tar.gz
freebsd-ports-gnome-c114d133441087e23ae60bf9917558676d37b775.tar.zst
freebsd-ports-gnome-c114d133441087e23ae60bf9917558676d37b775.zip
- Stop clobbering postgresql-server/-client OPTIONS with -contrib OPTIONS
- Minor optimisation (stop testing for !SLAVE_ONLY twice) PR: ports/164662
Diffstat (limited to 'databases')
-rw-r--r--databases/postgresql91-contrib/Makefile2
-rw-r--r--databases/postgresql91-server/Makefile9
-rw-r--r--databases/postgresql92-server/Makefile9
3 files changed, 10 insertions, 10 deletions
diff --git a/databases/postgresql91-contrib/Makefile b/databases/postgresql91-contrib/Makefile
index 4687e2d343f7..dc67d9948c5e 100644
--- a/databases/postgresql91-contrib/Makefile
+++ b/databases/postgresql91-contrib/Makefile
@@ -28,8 +28,6 @@ SLAVE_ONLY= yes
CONFIGURE_ARGS+=--with-libxslt --with-libxml
LDFLAGS+= ${PTHREAD_LIBS} -L${PREFIX}/lib
-OPTIONS= OSSP_UUID "Enable / disable ossp-uuid support" on
-
post-install:
@- ${INSTALL_DATA} ${WRKSRC}/contrib/README ${DOCSDIR}/extension/README
diff --git a/databases/postgresql91-server/Makefile b/databases/postgresql91-server/Makefile
index 3e0d07251047..8d5a421a7ff1 100644
--- a/databases/postgresql91-server/Makefile
+++ b/databases/postgresql91-server/Makefile
@@ -26,7 +26,11 @@ DIST_SUBDIR= postgresql
ICU_PATCHFILE?= pg-910-icu-2011-09-22.diff.gz
+.if !defined(SLAVE_ONLY)
UNIQUENAME?= ${PORTNAME}${DISTVERSION:R:S/.//}
+.else # Contrib has different options from -client/-server
+UNIQUENAME?= ${PORTNAME}${DISTVERSION:R:S/.//}-${PKGNAMESUFFIX}
+.endif
LATEST_LINK?= ${PKGNAMEPREFIX}${UNIQUENAME}${PKGNAMESUFFIX}
PKGINSTALL?= ${PKGDIR}/pkg-install${PKGNAMESUFFIX}
@@ -75,16 +79,13 @@ GROUPS?= ${PG_GROUP}
SUB_FILES+= 502.pgsql
.endif
-.if !defined(SLAVE_ONLY)
-OPTIONS+= NLS "Use internationalized messages" on
-.endif
-
.if !defined(CLIENT_ONLY)
MAKE_ENV= PATH=${PREFIX}/bin:${PATH}
CONFIGURE_ENV+= PATH=${PREFIX}/bin:${PATH}
.endif
.if !defined(SLAVE_ONLY)
+OPTIONS+= NLS "Use internationalized messages" on
OPTIONS+= DTRACE "Build with DTrace probes (server only)" off
OPTIONS+= PAM "Build with PAM support (server only)" off
OPTIONS+= LDAP "Build with LDAP authentication support" off
diff --git a/databases/postgresql92-server/Makefile b/databases/postgresql92-server/Makefile
index 3e0d07251047..8d5a421a7ff1 100644
--- a/databases/postgresql92-server/Makefile
+++ b/databases/postgresql92-server/Makefile
@@ -26,7 +26,11 @@ DIST_SUBDIR= postgresql
ICU_PATCHFILE?= pg-910-icu-2011-09-22.diff.gz
+.if !defined(SLAVE_ONLY)
UNIQUENAME?= ${PORTNAME}${DISTVERSION:R:S/.//}
+.else # Contrib has different options from -client/-server
+UNIQUENAME?= ${PORTNAME}${DISTVERSION:R:S/.//}-${PKGNAMESUFFIX}
+.endif
LATEST_LINK?= ${PKGNAMEPREFIX}${UNIQUENAME}${PKGNAMESUFFIX}
PKGINSTALL?= ${PKGDIR}/pkg-install${PKGNAMESUFFIX}
@@ -75,16 +79,13 @@ GROUPS?= ${PG_GROUP}
SUB_FILES+= 502.pgsql
.endif
-.if !defined(SLAVE_ONLY)
-OPTIONS+= NLS "Use internationalized messages" on
-.endif
-
.if !defined(CLIENT_ONLY)
MAKE_ENV= PATH=${PREFIX}/bin:${PATH}
CONFIGURE_ENV+= PATH=${PREFIX}/bin:${PATH}
.endif
.if !defined(SLAVE_ONLY)
+OPTIONS+= NLS "Use internationalized messages" on
OPTIONS+= DTRACE "Build with DTrace probes (server only)" off
OPTIONS+= PAM "Build with PAM support (server only)" off
OPTIONS+= LDAP "Build with LDAP authentication support" off