aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-07-02 22:28:50 +0800
committermat <mat@FreeBSD.org>2018-07-02 22:28:50 +0800
commitd520592de9d4c776c583479030f9c27b583c7e86 (patch)
treefc064d9a181ac2d727c4d23043c25f2ae7b16be5 /databases
parente6213a564bc4f586fe9c8ab485e16ac935098ca0 (diff)
downloadfreebsd-ports-gnome-d520592de9d4c776c583479030f9c27b583c7e86.tar.gz
freebsd-ports-gnome-d520592de9d4c776c583479030f9c27b583c7e86.tar.zst
freebsd-ports-gnome-d520592de9d4c776c583479030f9c27b583c7e86.zip
Add databases/py-pgdbconn, Object-oriented layer over Psycopg2 to
connect and interact with Postgres databases. Sponsored by: Absolight
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-pgdbconn/Makefile20
-rw-r--r--databases/py-pgdbconn/distinfo3
-rw-r--r--databases/py-pgdbconn/pkg-descr6
4 files changed, 30 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 07aba618a6eb..429c81cd423f 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -815,6 +815,7 @@
SUBDIR += py-pg8000
SUBDIR += py-pg_pqueue
SUBDIR += py-pgcli
+ SUBDIR += py-pgdbconn
SUBDIR += py-pglite
SUBDIR += py-pgspecial
SUBDIR += py-pgxnclient
diff --git a/databases/py-pgdbconn/Makefile b/databases/py-pgdbconn/Makefile
new file mode 100644
index 000000000000..1719b298f52e
--- /dev/null
+++ b/databases/py-pgdbconn/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= pgdbconn
+PORTVERSION= 0.8.0
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= Object-oriented layer to connect and interact with PostgreSQL databases
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>=2.5:databases/py-psycopg2@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/databases/py-pgdbconn/distinfo b/databases/py-pgdbconn/distinfo
new file mode 100644
index 000000000000..56a77cfcea92
--- /dev/null
+++ b/databases/py-pgdbconn/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1530540909
+SHA256 (pgdbconn-0.8.0.tar.gz) = 1552f86523940f7cb36719de827574a0744728f8647a0649a758a2974b093ef8
+SIZE (pgdbconn-0.8.0.tar.gz) = 11866
diff --git a/databases/py-pgdbconn/pkg-descr b/databases/py-pgdbconn/pkg-descr
new file mode 100644
index 000000000000..6b663f2b0432
--- /dev/null
+++ b/databases/py-pgdbconn/pkg-descr
@@ -0,0 +1,6 @@
+PgDbConn is an offshoot from the Perseas project (started as Pyrseas) to
+isolate and generalize the Postgres database connection code so that it can be
+used in other Perseas products, such as a web application to update Postgres
+tables.
+
+WWW: https://pypi.org/project/pgdbconn/