aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-06-27 16:32:38 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-06-27 16:32:38 +0800
commitd64c1120f12977b024098e185620998e1fd83283 (patch)
tree176eae72ee21ff026fddbfd255563473aa9e11ca /databases
parent86b1e9cedb19fa80c59cca6a8569b839a6b60660 (diff)
downloadfreebsd-ports-gnome-d64c1120f12977b024098e185620998e1fd83283.tar.gz
freebsd-ports-gnome-d64c1120f12977b024098e185620998e1fd83283.tar.zst
freebsd-ports-gnome-d64c1120f12977b024098e185620998e1fd83283.zip
- Update to 1.2.11
- Pet portlint: remove ABI version number from LIB_DEPENDS - Convert to new options framework Changes: http://trac.xapian.org/wiki/ReleaseOverview/1.2.11
Diffstat (limited to 'databases')
-rw-r--r--databases/xapian-bindings/Makefile45
-rw-r--r--databases/xapian-bindings/distinfo4
2 files changed, 24 insertions, 25 deletions
diff --git a/databases/xapian-bindings/Makefile b/databases/xapian-bindings/Makefile
index 4cd8a5e8096f..27c12a3224ab 100644
--- a/databases/xapian-bindings/Makefile
+++ b/databases/xapian-bindings/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xapian-bindings
-PORTVERSION= 1.2.10
+PORTVERSION= 1.2.11
CATEGORIES= databases
MASTER_SITES= http://oligarchy.co.uk/xapian/${PORTVERSION}/ \
LOCAL/sunpoet
@@ -16,57 +16,56 @@ COMMENT= Bindings allowing Xapian to be used from various programming languages
LICENSE= GPLv2
-LIB_DEPENDS= xapian.26:${PORTSDIR}/databases/xapian-core
+LIB_DEPENDS= xapian:${PORTSDIR}/databases/xapian-core
-OPTIONS= PHP "Build PHP binding" on \
- PYTHON "Build Python binding" on \
- RUBY "Build Ruby binding" on
+OPTIONS_DEFINE= DOCS PHP PYTHON RUBY
+OPTIONS_DEFAULT=PHP PYTHON RUBY
PORTSCOUT= limitw:1,even
-CONFIGURE_ARGS= --datarootdir="${DATADIR}" --docdir="${DOCSDIR}" \
+CONFIGURE_ARGS= --datarootdir=${DATADIR} --docdir=${DOCSDIR} \
--without-csharp --without-java --without-tcl
GNU_CONFIGURE= yes
.include <bsd.port.options.mk>
-.if defined(WITHOUT_PHP)
-CONFIGURE_ARGS+=--without-php
-PLIST_SUB+= BINDING_PHP="@comment "
-.else
+.if ${PORT_OPTIONS:MPHP}
CONFIGURE_ARGS+=--with-php
CONFIGURE_ENV+= PHP_CONFIG="${LOCALBASE}/bin/php-config"
-PLIST_SUB+= BINDING_PHP=""
USE_PHP= yes
USE_PHP_BUILD= yes
+PLIST_SUB+= BINDING_PHP=""
+.else
+CONFIGURE_ARGS+=--without-php
+PLIST_SUB+= BINDING_PHP="@comment "
.endif
-.if defined(WITHOUT_PYTHON)
-CONFIGURE_ARGS+=--without-python
-PLIST_SUB+= BINDING_PYTHON="@comment "
-.else
+.if ${PORT_OPTIONS:MPYTHON}
CONFIGURE_ARGS+=--with-python
CONFIGURE_ENV+= PYTHON_LIB="${PYTHON_SITELIBDIR}"
-PLIST_SUB+= BINDING_PYTHON=""
USE_PYTHON= yes
+PLIST_SUB+= BINDING_PYTHON=""
+.else
+CONFIGURE_ARGS+=--without-python
+PLIST_SUB+= BINDING_PYTHON="@comment "
.endif
-.if defined(WITHOUT_RUBY)
-CONFIGURE_ARGS+=--without-ruby
-PLIST_SUB+= BINDING_RUBY="@comment "
-.else
+.if ${PORT_OPTIONS:MRUBY}
CONFIGURE_ARGS+=--with-ruby
-PLIST_SUB+= BINDING_RUBY=""
USE_RUBY= yes
USE_RUBY_RDOC= no
+PLIST_SUB+= BINDING_RUBY=""
+.else
+CONFIGURE_ARGS+=--without-ruby
+PLIST_SUB+= BINDING_RUBY="@comment "
.endif
post-patch:
# do not install rdoc
@${REINPLACE_CMD} -e '/^install-data-am:/ s|install-data-local||' ${WRKSRC}/ruby/Makefile.in
-.if defined(NOPORTDOCS)
+.if empty(PORT_OPTIONS:MDOCS)
@${REINPLACE_CMD} -e '/^install-data-am:/ s|install-dist_docdataDATA install-dist_exampledataDATA ||' ${WRKSRC}/php/Makefile.in ${WRKSRC}/python/Makefile.in
- @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-dist_docdataDATA||; 759 s|install-dist_exampledataDATA ||' ${WRKSRC}/ruby/Makefile.in
+ @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-dist_docdataDATA||; 760 s|install-dist_exampledataDATA ||' ${WRKSRC}/ruby/Makefile.in
.endif
.include <bsd.port.mk>
diff --git a/databases/xapian-bindings/distinfo b/databases/xapian-bindings/distinfo
index 511a05957582..880f219c4daa 100644
--- a/databases/xapian-bindings/distinfo
+++ b/databases/xapian-bindings/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xapian-bindings-1.2.10.tar.gz) = dd191ad2e1134b7008b3b71c7cab41d2d80df2fe82ecdb9ad68c11209ba19382
-SIZE (xapian-bindings-1.2.10.tar.gz) = 1467592
+SHA256 (xapian-bindings-1.2.11.tar.gz) = 02caf5b56866174d09d76658300251c649c3692ae48e5a2536df58b014c0c117
+SIZE (xapian-bindings-1.2.11.tar.gz) = 1471891