aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-01-17 12:43:17 +0800
committeredwin <edwin@FreeBSD.org>2003-01-17 12:43:17 +0800
commitd7e24c2599c391c32b0ae4f12633bc9f55e6bc68 (patch)
treeb1bd2bf4d08bd5141c6abc0a05bf7d96922f2f7c /databases
parent8d80aa3d720ee16c8ff565aea21655ea6b35d8df (diff)
downloadfreebsd-ports-gnome-d7e24c2599c391c32b0ae4f12633bc9f55e6bc68.tar.gz
freebsd-ports-gnome-d7e24c2599c391c32b0ae4f12633bc9f55e6bc68.tar.zst
freebsd-ports-gnome-d7e24c2599c391c32b0ae4f12633bc9f55e6bc68.zip
Note that databases/firebird doesn't compile properly on NFS mounts.
Removed "does not work on -current" notice. Submitted by: Chris Knight <chris@aims.com.au>
Diffstat (limited to 'databases')
-rw-r--r--databases/firebird-client/Makefile11
-rw-r--r--databases/firebird-server/Makefile11
-rw-r--r--databases/firebird/Makefile11
-rw-r--r--databases/firebird2-server/Makefile11
-rw-r--r--databases/firebird20-server/Makefile11
5 files changed, 40 insertions, 15 deletions
diff --git a/databases/firebird-client/Makefile b/databases/firebird-client/Makefile
index b158cc63226a..ddce478ccd20 100644
--- a/databases/firebird-client/Makefile
+++ b/databases/firebird-client/Makefile
@@ -28,8 +28,13 @@ ONLY_FOR_ARCHS= i386
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500000
-MANUAL_PACKAGE_BUILD= "Doesn't compile on NFS on -current"
+pre-everything:
+ @${ECHO_MSG} "NOTE: If the work directory is on an NFS mount, you will"
+ @${ECHO_MSG} "require NFS client locking support for the build to"
+ @${ECHO_MSG} "succeed. Currently this is only available on FreeBSD 5.0"
+ @${ECHO_MSG} "or greater."
+.if !defined(BATCH)
+ @sleep 5
.endif
do-extract:
@@ -84,7 +89,7 @@ do-install:
cd ${WRKDIR}/firebird-1.0.2.908; \
${RM} ${WRKDIR}/firebird-1.0.2.908/interbase/isc4_tmp.gdb || ${TRUE}; \
${RM} ${WRKDIR}/firebird-1.0.2.908/interbase/lib/gds.so.1 || ${TRUE}; \
- ${CP} /dev/null interbase/interbase.log; \
+ ${TOUCH} interbase/interbase.log; \
${CP} -Rp interbase ${PREFIX}/firebird; \
${RM} ${PREFIX}/firebird/install; \
${RM} ${PREFIX}/firebird/lib/libgds.so.1.0; \
diff --git a/databases/firebird-server/Makefile b/databases/firebird-server/Makefile
index b158cc63226a..ddce478ccd20 100644
--- a/databases/firebird-server/Makefile
+++ b/databases/firebird-server/Makefile
@@ -28,8 +28,13 @@ ONLY_FOR_ARCHS= i386
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500000
-MANUAL_PACKAGE_BUILD= "Doesn't compile on NFS on -current"
+pre-everything:
+ @${ECHO_MSG} "NOTE: If the work directory is on an NFS mount, you will"
+ @${ECHO_MSG} "require NFS client locking support for the build to"
+ @${ECHO_MSG} "succeed. Currently this is only available on FreeBSD 5.0"
+ @${ECHO_MSG} "or greater."
+.if !defined(BATCH)
+ @sleep 5
.endif
do-extract:
@@ -84,7 +89,7 @@ do-install:
cd ${WRKDIR}/firebird-1.0.2.908; \
${RM} ${WRKDIR}/firebird-1.0.2.908/interbase/isc4_tmp.gdb || ${TRUE}; \
${RM} ${WRKDIR}/firebird-1.0.2.908/interbase/lib/gds.so.1 || ${TRUE}; \
- ${CP} /dev/null interbase/interbase.log; \
+ ${TOUCH} interbase/interbase.log; \
${CP} -Rp interbase ${PREFIX}/firebird; \
${RM} ${PREFIX}/firebird/install; \
${RM} ${PREFIX}/firebird/lib/libgds.so.1.0; \
diff --git a/databases/firebird/Makefile b/databases/firebird/Makefile
index b158cc63226a..ddce478ccd20 100644
--- a/databases/firebird/Makefile
+++ b/databases/firebird/Makefile
@@ -28,8 +28,13 @@ ONLY_FOR_ARCHS= i386
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500000
-MANUAL_PACKAGE_BUILD= "Doesn't compile on NFS on -current"
+pre-everything:
+ @${ECHO_MSG} "NOTE: If the work directory is on an NFS mount, you will"
+ @${ECHO_MSG} "require NFS client locking support for the build to"
+ @${ECHO_MSG} "succeed. Currently this is only available on FreeBSD 5.0"
+ @${ECHO_MSG} "or greater."
+.if !defined(BATCH)
+ @sleep 5
.endif
do-extract:
@@ -84,7 +89,7 @@ do-install:
cd ${WRKDIR}/firebird-1.0.2.908; \
${RM} ${WRKDIR}/firebird-1.0.2.908/interbase/isc4_tmp.gdb || ${TRUE}; \
${RM} ${WRKDIR}/firebird-1.0.2.908/interbase/lib/gds.so.1 || ${TRUE}; \
- ${CP} /dev/null interbase/interbase.log; \
+ ${TOUCH} interbase/interbase.log; \
${CP} -Rp interbase ${PREFIX}/firebird; \
${RM} ${PREFIX}/firebird/install; \
${RM} ${PREFIX}/firebird/lib/libgds.so.1.0; \
diff --git a/databases/firebird2-server/Makefile b/databases/firebird2-server/Makefile
index b158cc63226a..ddce478ccd20 100644
--- a/databases/firebird2-server/Makefile
+++ b/databases/firebird2-server/Makefile
@@ -28,8 +28,13 @@ ONLY_FOR_ARCHS= i386
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500000
-MANUAL_PACKAGE_BUILD= "Doesn't compile on NFS on -current"
+pre-everything:
+ @${ECHO_MSG} "NOTE: If the work directory is on an NFS mount, you will"
+ @${ECHO_MSG} "require NFS client locking support for the build to"
+ @${ECHO_MSG} "succeed. Currently this is only available on FreeBSD 5.0"
+ @${ECHO_MSG} "or greater."
+.if !defined(BATCH)
+ @sleep 5
.endif
do-extract:
@@ -84,7 +89,7 @@ do-install:
cd ${WRKDIR}/firebird-1.0.2.908; \
${RM} ${WRKDIR}/firebird-1.0.2.908/interbase/isc4_tmp.gdb || ${TRUE}; \
${RM} ${WRKDIR}/firebird-1.0.2.908/interbase/lib/gds.so.1 || ${TRUE}; \
- ${CP} /dev/null interbase/interbase.log; \
+ ${TOUCH} interbase/interbase.log; \
${CP} -Rp interbase ${PREFIX}/firebird; \
${RM} ${PREFIX}/firebird/install; \
${RM} ${PREFIX}/firebird/lib/libgds.so.1.0; \
diff --git a/databases/firebird20-server/Makefile b/databases/firebird20-server/Makefile
index b158cc63226a..ddce478ccd20 100644
--- a/databases/firebird20-server/Makefile
+++ b/databases/firebird20-server/Makefile
@@ -28,8 +28,13 @@ ONLY_FOR_ARCHS= i386
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500000
-MANUAL_PACKAGE_BUILD= "Doesn't compile on NFS on -current"
+pre-everything:
+ @${ECHO_MSG} "NOTE: If the work directory is on an NFS mount, you will"
+ @${ECHO_MSG} "require NFS client locking support for the build to"
+ @${ECHO_MSG} "succeed. Currently this is only available on FreeBSD 5.0"
+ @${ECHO_MSG} "or greater."
+.if !defined(BATCH)
+ @sleep 5
.endif
do-extract:
@@ -84,7 +89,7 @@ do-install:
cd ${WRKDIR}/firebird-1.0.2.908; \
${RM} ${WRKDIR}/firebird-1.0.2.908/interbase/isc4_tmp.gdb || ${TRUE}; \
${RM} ${WRKDIR}/firebird-1.0.2.908/interbase/lib/gds.so.1 || ${TRUE}; \
- ${CP} /dev/null interbase/interbase.log; \
+ ${TOUCH} interbase/interbase.log; \
${CP} -Rp interbase ${PREFIX}/firebird; \
${RM} ${PREFIX}/firebird/install; \
${RM} ${PREFIX}/firebird/lib/libgds.so.1.0; \