aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2007-01-13 11:57:25 +0800
committerDirk Meyer <dinoex@FreeBSD.org>2007-01-13 11:57:25 +0800
commitd7f59ea8de230bb289b02649cd575560e4c71e0d (patch)
treeeae797f7211f5c20b5be446f4fa649681b374597 /databases
parent3aa9b484131b5835a7875ba57cac901593286b35 (diff)
downloadfreebsd-ports-gnome-d7f59ea8de230bb289b02649cd575560e4c71e0d.tar.gz
freebsd-ports-gnome-d7f59ea8de230bb289b02649cd575560e4c71e0d.tar.zst
freebsd-ports-gnome-d7f59ea8de230bb289b02649cd575560e4c71e0d.zip
- update to use new bsd.gnustep.mk
Approved by: gurkan@linuks.mine.nu
Diffstat (limited to 'databases')
-rw-r--r--databases/gdl2/Makefile14
-rw-r--r--databases/mylibrary/Makefile6
-rw-r--r--databases/sqlclient/Makefile13
3 files changed, 10 insertions, 23 deletions
diff --git a/databases/gdl2/Makefile b/databases/gdl2/Makefile
index b34750aaebcd..fb84bedf582f 100644
--- a/databases/gdl2/Makefile
+++ b/databases/gdl2/Makefile
@@ -15,9 +15,6 @@ DISTNAME= gnustep-dl2-${PORTVERSION}
MAINTAINER= gurkan@linuks.mine.nu
COMMENT= GNUstep Database Library 2 (Enterprise Objects Framework)
-WRKSRC= ${WRKDIR}/${DISTNAME}
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BASE= yes
@@ -25,11 +22,12 @@ USE_GNUSTEP_CONFIGURE= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
USE_GNUSTEP_SYSTEM_LIBS+= Gorm:${GORM_PORT}
-# broken
-# USE_LDCONFIG= yes
-INSTALL_SHLIBS= yes
-MAKEFILE= GNUmakefile
-GORM_PORT?= devel/gorm
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
USE_PGSQL= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}
+GNU_CONFIGURE= yes
+
+GORM_PORT?= devel/gorm
+
.include <bsd.port.mk>
diff --git a/databases/mylibrary/Makefile b/databases/mylibrary/Makefile
index c9f2c95cdaf2..b48313abfb71 100644
--- a/databases/mylibrary/Makefile
+++ b/databases/mylibrary/Makefile
@@ -15,14 +15,12 @@ DISTNAME= MyLibrary-${PORTVERSION}g
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Wiki-style data management application for GNUstep
-WRKSRC= ${WRKDIR}/ML
-USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-MAKEFILE=
-ALL_TARGET=
+
+WRKSRC= ${WRKDIR}/ML
.include <bsd.port.mk>
diff --git a/databases/sqlclient/Makefile b/databases/sqlclient/Makefile
index d760eec57d87..acdec10e3d12 100644
--- a/databases/sqlclient/Makefile
+++ b/databases/sqlclient/Makefile
@@ -15,20 +15,15 @@ DISTNAME= SQLClient-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Lightweight database abstraction layer
-USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BASE= yes
USE_GNUSTEP_CONFIGURE= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-MAKEFILE= GNUmakefile
-ALL_TARGET=
-LDCONFIG_DIRS= ${LOCALLIBDIR}
-INSTALLS_SHLIB= yes
-NO_FILTER_SHLIBS= yes
-
USE_GNUSTEP_LOCAL_LIBS+= Performance:${PERFORMANCE_PORT}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
+
PERFORMANCE_PORT?= devel/performance
USE_PGSQL=yes
@@ -38,8 +33,4 @@ USE_SQLITE=yes
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
-#CONFIGURE_ARGS+= --with-additional-lib="${PHREAD_LIBS}"
-#ADDITIONAL_LDFLAGS+= -L${LOCALBASE}/lib
-#MAKE_ENV+= ADDITIONAL_LDFLAGS="${ADDITIONAL_LDFLAGS}"
-
.include <bsd.port.mk>