aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-11-06 05:43:48 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-11-06 05:43:48 +0800
commite2d56037f564f4f4f7b934291da22bb25d47813a (patch)
tree071f379eb81d2d9ea35b4843145c10a8662b369e /databases
parent3148604c73a51018c20f84c6d9c9a352e59f6e8e (diff)
downloadfreebsd-ports-gnome-e2d56037f564f4f4f7b934291da22bb25d47813a.tar.gz
freebsd-ports-gnome-e2d56037f564f4f4f7b934291da22bb25d47813a.tar.zst
freebsd-ports-gnome-e2d56037f564f4f4f7b934291da22bb25d47813a.zip
Update to 1.4.9
Changes: https://trac.xapian.org/wiki/ReleaseOverview/1.4.9
Diffstat (limited to 'databases')
-rw-r--r--databases/php-xapian/Makefile2
-rw-r--r--databases/php-xapian/distinfo6
-rw-r--r--databases/php-xapian/files/patch-php7-php.i30
-rw-r--r--databases/php-xapian/files/patch-php7-php7-xapian_wrap.cc30
4 files changed, 4 insertions, 64 deletions
diff --git a/databases/php-xapian/Makefile b/databases/php-xapian/Makefile
index 690fe2e10c89..42c76f0f599b 100644
--- a/databases/php-xapian/Makefile
+++ b/databases/php-xapian/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xapian
-PORTVERSION= 1.4.8
+PORTVERSION= 1.4.9
DISTVERSIONPREFIX= bindings-
CATEGORIES= databases
MASTER_SITES= https://oligarchy.co.uk/xapian/${PORTVERSION}/ \
diff --git a/databases/php-xapian/distinfo b/databases/php-xapian/distinfo
index 431fac0c0d66..fcfdfc6ca3f4 100644
--- a/databases/php-xapian/distinfo
+++ b/databases/php-xapian/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1540657348
-SHA256 (xapian-bindings-1.4.8.tar.xz) = a62377e54764bae444ee7feff517ab23ce314e92b94c4c03193a42884aa8de4b
-SIZE (xapian-bindings-1.4.8.tar.xz) = 1123812
+TIMESTAMP = 1541430516
+SHA256 (xapian-bindings-1.4.9.tar.xz) = 9f2d53a6225b6884bae783325d22a2bd44b6988836fa4974ffeb6414c8f88352
+SIZE (xapian-bindings-1.4.9.tar.xz) = 1123628
diff --git a/databases/php-xapian/files/patch-php7-php.i b/databases/php-xapian/files/patch-php7-php.i
deleted file mode 100644
index 3f7922835c17..000000000000
--- a/databases/php-xapian/files/patch-php7-php.i
+++ /dev/null
@@ -1,30 +0,0 @@
---- php7/php.i.orig 2018-10-26 05:08:02 UTC
-+++ php7/php.i
-@@ -177,9 +177,13 @@ fail: // Label which SWIG_PHP_Error need
- %typemap(out) std::pair<Xapian::TermIterator, Xapian::TermIterator> {
-
- ZVAL_NEW_ARR($result);
-+#if PHP_VERSION_ID >= 70300
-+ array_init($result);
-+#else
- if (array_init($result) == FAILURE) {
- SWIG_PHP_Error(E_ERROR, "array_init failed");
- }
-+#endif
-
- for (Xapian::TermIterator i = $1.first; i != $1.second; ++i) {
- /* We have to cast away const here because the PHP API is rather
-@@ -198,9 +202,13 @@ fail: // Label which SWIG_PHP_Error need
-
- %typemap(directorin) (size_t num_tags, const std::string tags[]) {
- ZVAL_NEW_ARR($input);
-+#if PHP_VERSION_ID >= 70300
-+ array_init($input);
-+#else
- if (array_init($input) == FAILURE) {
- SWIG_PHP_Error(E_ERROR, "array_init failed");
- }
-+#endif
-
- for (size_t i = 0; i != num_tags; ++i) {
- const string & term = tags[i];
diff --git a/databases/php-xapian/files/patch-php7-php7-xapian_wrap.cc b/databases/php-xapian/files/patch-php7-php7-xapian_wrap.cc
deleted file mode 100644
index c4d981e6a2a0..000000000000
--- a/databases/php-xapian/files/patch-php7-php7-xapian_wrap.cc
+++ /dev/null
@@ -1,30 +0,0 @@
---- php7/php7/xapian_wrap.cc.orig 2018-10-26 05:12:41 UTC
-+++ php7/php7/xapian_wrap.cc
-@@ -2533,9 +2533,13 @@ std::string SwigDirector_Compactor::reso
-
- {
- ZVAL_NEW_ARR(&args[1]);
-+#if PHP_VERSION_ID >= 70300
-+ array_init(&args[1]);
-+#else
- if (array_init(&args[1]) == FAILURE) {
- SWIG_PHP_Error(E_ERROR, "array_init failed");
- }
-+#endif
-
- for (size_t i = 0; i != num_tags; ++i) {
- const string & term = tags[i];
-@@ -16756,9 +16760,13 @@ ZEND_NAMED_FUNCTION(_wrap_Enquire_get_ma
- }
- {
- ZVAL_NEW_ARR(return_value);
-+#if PHP_VERSION_ID >= 70300
-+ array_init(return_value);
-+#else
- if (array_init(return_value) == FAILURE) {
- SWIG_PHP_Error(E_ERROR, "array_init failed");
- }
-+#endif
-
- for (Xapian::TermIterator i = (&result)->first; i != (&result)->second; ++i) {
- /* We have to cast away const here because the PHP API is rather