aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-08-28 22:05:51 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-08-28 22:05:51 +0800
commiteaedf56ae95fded96b60306dd9e40b6922b7be6d (patch)
tree115d48f301713c727ab5a0358b96f7e07e3945d0 /databases
parentd990e2f2b8ef9f2d509c512d815ce3fc8a6d6ecd (diff)
downloadfreebsd-ports-gnome-eaedf56ae95fded96b60306dd9e40b6922b7be6d.tar.gz
freebsd-ports-gnome-eaedf56ae95fded96b60306dd9e40b6922b7be6d.tar.zst
freebsd-ports-gnome-eaedf56ae95fded96b60306dd9e40b6922b7be6d.zip
- Add py-kyotocabinet 1.20
Python binding of kyotocabinet. WWW: http://fallabs.com/kyotocabinet/
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-kyotocabinet/Makefile27
-rw-r--r--databases/py-kyotocabinet/distinfo2
-rw-r--r--databases/py-kyotocabinet/pkg-descr3
4 files changed, 33 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 1288691e225b..04b4bbef75ff 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -662,6 +662,7 @@
SUBDIR += py-forgetsql
SUBDIR += py-gdbm
SUBDIR += py-htsql
+ SUBDIR += py-kyotocabinet
SUBDIR += py-memcached
SUBDIR += py-migrate
SUBDIR += py-mssql
diff --git a/databases/py-kyotocabinet/Makefile b/databases/py-kyotocabinet/Makefile
new file mode 100644
index 000000000000..6e6aa1089681
--- /dev/null
+++ b/databases/py-kyotocabinet/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: py-kyotocabinet
+# Date created: 2011-08-25
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kyotocabinet
+PORTVERSION= 1.20
+CATEGORIES= databases python
+MASTER_SITES= http://fallabs.com/${PORTNAME}/pythonpkg/ \
+ LOCAL/sunpoet
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-python-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python binding of kyotocabinet
+
+LIB_DEPENDS= kyotocabinet:${PORTSDIR}/databases/kyotocabinet
+
+USE_PYTHON= 3.1+
+USE_PYDISTUTILS= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/${PORTNAME}.so
+PYDISTUTILS_EGGINFO= Kyoto_Cabinet-1.5-py${PYTHON_VER}.egg-info
+
+.include <bsd.port.mk>
diff --git a/databases/py-kyotocabinet/distinfo b/databases/py-kyotocabinet/distinfo
new file mode 100644
index 000000000000..5130aea7469a
--- /dev/null
+++ b/databases/py-kyotocabinet/distinfo
@@ -0,0 +1,2 @@
+SHA256 (kyotocabinet-python-1.20.tar.gz) = bccfd2ab2b909cd4d68b6386b6f2013170510a695b8ba6c9982d42b89ab426be
+SIZE (kyotocabinet-python-1.20.tar.gz) = 63457
diff --git a/databases/py-kyotocabinet/pkg-descr b/databases/py-kyotocabinet/pkg-descr
new file mode 100644
index 000000000000..43272037a526
--- /dev/null
+++ b/databases/py-kyotocabinet/pkg-descr
@@ -0,0 +1,3 @@
+Python binding of kyotocabinet.
+
+WWW: http://fallabs.com/kyotocabinet/