aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorKevin Bowling <kbowling@FreeBSD.org>2019-02-14 12:12:44 +0800
committerKevin Bowling <kbowling@FreeBSD.org>2019-02-14 12:12:44 +0800
commitebceab382f34590130e0ff0619542111398912e4 (patch)
treef4b097c7c084af2c84af931f07f710e29adcd7fd /databases
parent0e185babc2d881eaaaa6e8388717b85240cce5c6 (diff)
downloadfreebsd-ports-gnome-ebceab382f34590130e0ff0619542111398912e4.tar.gz
freebsd-ports-gnome-ebceab382f34590130e0ff0619542111398912e4.tar.zst
freebsd-ports-gnome-ebceab382f34590130e0ff0619542111398912e4.zip
databases/timescaledb: invert TSL/APACHE_ONLY option
Invert the APACHEONLY negative option to TSL positive option per mat. Fix pkg-message replacement issue reported by Giacomo Olgeni. Reported by: mat (option inversion), Giacomo Olgeni (pkg-message) Approved by: timur (mentor) Sponsored by: BBOX.io Differential Revision: https://reviews.freebsd.org/D19079
Diffstat (limited to 'databases')
-rw-r--r--databases/timescaledb/Makefile15
-rw-r--r--databases/timescaledb/pkg-plist2
2 files changed, 10 insertions, 7 deletions
diff --git a/databases/timescaledb/Makefile b/databases/timescaledb/Makefile
index 51fb14a6ce65..00dcfef8e344 100644
--- a/databases/timescaledb/Makefile
+++ b/databases/timescaledb/Makefile
@@ -3,6 +3,7 @@
PORTNAME= timescaledb
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= databases
MAINTAINER= kbowling@FreeBSD.org
@@ -20,15 +21,17 @@ USES= compiler:c11 cmake pgsql:9.6,10,11 ssl
USE_GITHUB= YES
GH_ACCOUNT= timescale
-OPTIONS_DEFINE= APACHEONLY
-OPTIONS_SUB= yes
-
-APACHEONLY_CMAKE_BOOL= APACHE_ONLY
-APACHEONLY_DESC= Only build Apache licensed code
-
PLIST_SUB= PORTVERSION=${PORTVERSION}
SUB_FILES= pkg-message
+SUB_LIST= PORTVERSION=${PORTVERSION}
WANT_PGSQL= server
+OPTIONS_DEFINE= TSL
+OPTIONS_DEFAULT= TSL
+OPTIONS_SUB= yes
+
+TSL_DESC= Enables TSL licensed code in additon to Apache license code
+TSL_CMAKE_BOOL_OFF= APACHE_ONLY
+
.include <bsd.port.mk>
diff --git a/databases/timescaledb/pkg-plist b/databases/timescaledb/pkg-plist
index 394f8b1849ef..18bb842bb391 100644
--- a/databases/timescaledb/pkg-plist
+++ b/databases/timescaledb/pkg-plist
@@ -1,5 +1,5 @@
lib/postgresql/timescaledb-%%PORTVERSION%%.so
-%%NO_APACHEONLY%%lib/postgresql/timescaledb-tsl-%%PORTVERSION%%.so
+%%TSL%%lib/postgresql/timescaledb-tsl-%%PORTVERSION%%.so
lib/postgresql/timescaledb.so
share/postgresql/extension/timescaledb--0.1.0--%%PORTVERSION%%.sql
share/postgresql/extension/timescaledb--0.10.0--%%PORTVERSION%%.sql