aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-09-22 08:15:16 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-09-22 08:15:16 +0800
commitecc3a4df8616f19ceb5480a877445034a8cd0fb9 (patch)
treea92fb5f64eec7114259765d79462ca6f9c74efb3 /databases
parent61a0b5257226a417ed10d966f89bbc07f7bfb21a (diff)
downloadfreebsd-ports-gnome-ecc3a4df8616f19ceb5480a877445034a8cd0fb9.tar.gz
freebsd-ports-gnome-ecc3a4df8616f19ceb5480a877445034a8cd0fb9.tar.zst
freebsd-ports-gnome-ecc3a4df8616f19ceb5480a877445034a8cd0fb9.zip
- Fix dependency versions based on rubygems.org
With Hat: ruby@ Sponsored by: RideCharge Inc. / TaxiMagic
Diffstat (limited to 'databases')
-rw-r--r--databases/rubygem-datamapper/Makefile15
-rw-r--r--databases/rubygem-dm-aggregates/Makefile3
-rw-r--r--databases/rubygem-dm-constraints/Makefile3
-rw-r--r--databases/rubygem-dm-core/Makefile3
-rw-r--r--databases/rubygem-dm-migrations/Makefile3
-rw-r--r--databases/rubygem-dm-serializer/Makefile5
-rw-r--r--databases/rubygem-dm-timestamps/Makefile3
-rw-r--r--databases/rubygem-dm-transactions/Makefile3
-rw-r--r--databases/rubygem-dm-types/Makefile5
-rw-r--r--databases/rubygem-dm-validations/Makefile3
10 files changed, 28 insertions, 18 deletions
diff --git a/databases/rubygem-datamapper/Makefile b/databases/rubygem-datamapper/Makefile
index 1f458d509971..9381e6d9b31b 100644
--- a/databases/rubygem-datamapper/Makefile
+++ b/databases/rubygem-datamapper/Makefile
@@ -7,19 +7,20 @@
PORTNAME= datamapper
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= databases rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= Fast, thread-safe, object-relational mapper
-RUN_DEPENDS= rubygem-dm-aggregates>=1.0.1:${PORTSDIR}/databases/rubygem-dm-aggregates \
- rubygem-dm-constraints>=1.0.1:${PORTSDIR}/databases/rubygem-dm-constraints \
- rubygem-dm-transactions>=1.0.1:${PORTSDIR}/databases/rubygem-dm-transactions \
- rubygem-dm-serializer>=1.0.1:${PORTSDIR}/databases/rubygem-dm-serializer \
- rubygem-dm-timestamps>=1.0.1:${PORTSDIR}/databases/rubygem-dm-timestamps \
- rubygem-dm-validations>=1.0.1:${PORTSDIR}/databases/rubygem-dm-validations \
- rubygem-dm-types>=1.0.1:${PORTSDIR}/databases/rubygem-dm-types
+RUN_DEPENDS= rubygem-dm-aggregates>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-aggregates \
+ rubygem-dm-constraints>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-constraints \
+ rubygem-dm-transactions>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-transactions \
+ rubygem-dm-serializer>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-serializer \
+ rubygem-dm-timestamps>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-timestamps \
+ rubygem-dm-validations>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-validations \
+ rubygem-dm-types>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-types
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/databases/rubygem-dm-aggregates/Makefile b/databases/rubygem-dm-aggregates/Makefile
index 61d2871a6459..f3aa55c269a3 100644
--- a/databases/rubygem-dm-aggregates/Makefile
+++ b/databases/rubygem-dm-aggregates/Makefile
@@ -7,13 +7,14 @@
PORTNAME= dm-aggregates
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= databases rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= DataMapper plugin providing support for aggregates
-RUN_DEPENDS= rubygem-dm-core>=1.0.1:${PORTSDIR}/databases/rubygem-dm-core
+RUN_DEPENDS= rubygem-dm-core>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-core
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/databases/rubygem-dm-constraints/Makefile b/databases/rubygem-dm-constraints/Makefile
index 2c0e7179e9b8..0df1a869b4bb 100644
--- a/databases/rubygem-dm-constraints/Makefile
+++ b/databases/rubygem-dm-constraints/Makefile
@@ -7,13 +7,14 @@
PORTNAME= dm-constraints
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= databases rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= DataMapper plugin constraining relationships
-RUN_DEPENDS= rubygem-dm-migrations>=1.0.1:${PORTSDIR}/databases/rubygem-dm-migrations
+RUN_DEPENDS= rubygem-dm-migrations>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-migrations
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/databases/rubygem-dm-core/Makefile b/databases/rubygem-dm-core/Makefile
index 7b0268685799..1b5e96765385 100644
--- a/databases/rubygem-dm-core/Makefile
+++ b/databases/rubygem-dm-core/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dm-core
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= databases rubygems
MASTER_SITES= RG
@@ -14,7 +15,7 @@ MAINTAINER= ruby@FreeBSD.org
COMMENT= An Object/Relational Mapper for Ruby
RUN_DEPENDS= rubygem-extlib>=0.9.15:${PORTSDIR}/devel/rubygem-extlib \
- rubygem-addressable>=2.1:${PORTSDIR}/www/rubygem-addressable
+ rubygem-addressable>=2.2:${PORTSDIR}/www/rubygem-addressable
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/databases/rubygem-dm-migrations/Makefile b/databases/rubygem-dm-migrations/Makefile
index 3836e10ac1dc..a6cb3fa0dcd4 100644
--- a/databases/rubygem-dm-migrations/Makefile
+++ b/databases/rubygem-dm-migrations/Makefile
@@ -7,13 +7,14 @@
PORTNAME= dm-migrations
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= databases rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= DataMapper plugin for writing and speccing migrations
-RUN_DEPENDS= rubygem-dm-core>=1.0.1:${PORTSDIR}/databases/rubygem-dm-core
+RUN_DEPENDS= rubygem-dm-core>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-core
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/databases/rubygem-dm-serializer/Makefile b/databases/rubygem-dm-serializer/Makefile
index c71eae3bc4f1..09e4585f24b2 100644
--- a/databases/rubygem-dm-serializer/Makefile
+++ b/databases/rubygem-dm-serializer/Makefile
@@ -7,14 +7,15 @@
PORTNAME= dm-serializer
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= databases rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= DataMapper plugin for serializing Resources and Collections
-RUN_DEPENDS= rubygem-dm-core>=1.0.1:${PORTSDIR}/databases/rubygem-dm-core \
- rubygem-json_pure>=1.4.3:${PORTSDIR}/devel/rubygem-json_pure \
+RUN_DEPENDS= rubygem-dm-core>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-core \
+ rubygem-json_pure>=1.4:${PORTSDIR}/devel/rubygem-json_pure \
rubygem-fastercsv>=1.5.3:${PORTSDIR}/devel/rubygem-fastercsv
USE_RUBY= yes
diff --git a/databases/rubygem-dm-timestamps/Makefile b/databases/rubygem-dm-timestamps/Makefile
index 013bb66f786f..a802b2ae4b20 100644
--- a/databases/rubygem-dm-timestamps/Makefile
+++ b/databases/rubygem-dm-timestamps/Makefile
@@ -7,13 +7,14 @@
PORTNAME= dm-timestamps
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= databases rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= DataMapper plugin for magical timestamps
-RUN_DEPENDS= rubygem-dm-core>=1.0.1:${PORTSDIR}/databases/rubygem-dm-core
+RUN_DEPENDS= rubygem-dm-core>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-core
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/databases/rubygem-dm-transactions/Makefile b/databases/rubygem-dm-transactions/Makefile
index e3f5b69532b9..e3d95a7316fa 100644
--- a/databases/rubygem-dm-transactions/Makefile
+++ b/databases/rubygem-dm-transactions/Makefile
@@ -7,13 +7,14 @@
PORTNAME= dm-transactions
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= databases rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= Makes transaction support available for adapters that support them
-RUN_DEPENDS= rubygem-dm-core>=1.0.1:${PORTSDIR}/databases/rubygem-dm-core
+RUN_DEPENDS= rubygem-dm-core>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-core
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/databases/rubygem-dm-types/Makefile b/databases/rubygem-dm-types/Makefile
index 421409c6f713..4edc09b6b4da 100644
--- a/databases/rubygem-dm-types/Makefile
+++ b/databases/rubygem-dm-types/Makefile
@@ -7,16 +7,17 @@
PORTNAME= dm-types
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= databases rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= DataMapper plugin providing extra data types
-RUN_DEPENDS= rubygem-dm-core>=1.0.1:${PORTSDIR}/databases/rubygem-dm-core \
+RUN_DEPENDS= rubygem-dm-core>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-core \
rubygem-stringex>=1.1.0:${PORTSDIR}/devel/rubygem-stringex \
rubygem-uuidtools>=2.1.1:${PORTSDIR}/devel/rubygem-uuidtools \
- rubygem-json_pure>=1.4.3:${PORTSDIR}/devel/rubygem-json_pure \
+ rubygem-json_pure>=1.4:${PORTSDIR}/devel/rubygem-json_pure \
rubygem-fastercsv>=1.5.3:${PORTSDIR}/devel/rubygem-fastercsv
USE_RUBY= yes
diff --git a/databases/rubygem-dm-validations/Makefile b/databases/rubygem-dm-validations/Makefile
index 348dadbfee36..a3d8a8545b39 100644
--- a/databases/rubygem-dm-validations/Makefile
+++ b/databases/rubygem-dm-validations/Makefile
@@ -7,13 +7,14 @@
PORTNAME= dm-validations
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= databases rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= Library for performing validations on DM models and pure Ruby object
-RUN_DEPENDS= rubygem-dm-core>=1.0.1:${PORTSDIR}/databases/rubygem-dm-core
+RUN_DEPENDS= rubygem-dm-core>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-core
USE_RUBY= yes
USE_RUBYGEMS= yes