aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-19 05:15:30 +0800
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-19 05:15:30 +0800
commitee6369fc3ccd4401dd405c66c07f2b87f7c58b1f (patch)
tree4a8e5d9f98d4736fe8d11147203d4d2481240681 /databases
parent9200d02e75c761504710879bba8964dca9e16c63 (diff)
downloadfreebsd-ports-gnome-ee6369fc3ccd4401dd405c66c07f2b87f7c58b1f.tar.gz
freebsd-ports-gnome-ee6369fc3ccd4401dd405c66c07f2b87f7c58b1f.tar.zst
freebsd-ports-gnome-ee6369fc3ccd4401dd405c66c07f2b87f7c58b1f.zip
Restore a patch that was lost in the GNOME 2.16 update and re-fix the
problem where Evolution would run out of memory on 64-bit platforms. Reported by: cokane Approved by: portmgr (implicit)
Diffstat (limited to 'databases')
-rw-r--r--databases/evolution-data-server/Makefile1
-rw-r--r--databases/evolution-data-server/files/patch-camel_camel-object.c22
2 files changed, 23 insertions, 0 deletions
diff --git a/databases/evolution-data-server/Makefile b/databases/evolution-data-server/Makefile
index f58505bc9690..88a534c266d5 100644
--- a/databases/evolution-data-server/Makefile
+++ b/databases/evolution-data-server/Makefile
@@ -8,6 +8,7 @@
PORTNAME= evolution-data-server
PORTVERSION= 1.8.1
+PORTREVISION= 1
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
diff --git a/databases/evolution-data-server/files/patch-camel_camel-object.c b/databases/evolution-data-server/files/patch-camel_camel-object.c
new file mode 100644
index 000000000000..09b0cab7b6f4
--- /dev/null
+++ b/databases/evolution-data-server/files/patch-camel_camel-object.c
@@ -0,0 +1,22 @@
+--- camel-object.c.orig Wed Oct 18 15:53:34 2006
++++ camel-object.c Wed Oct 18 15:55:01 2006
+@@ -457,7 +457,7 @@
+ }
+
+ /* we batch up the properties and set them in one go */
+- if (!(argv = g_try_malloc ((gulong)(sizeof (*argv) + (count - CAMEL_ARGV_MAX) * sizeof (argv->argv[0])))))
++ if (!(argv = g_try_malloc ((guint32)(sizeof (*argv) + (count - CAMEL_ARGV_MAX) * sizeof (argv->argv[0])))))
+ return -1;
+
+ argv->argc = 0;
+@@ -537,8 +537,8 @@
+
+ count = g_slist_length(props);
+
+- arggetv = g_malloc0(sizeof(*arggetv) + (count - CAMEL_ARGV_MAX) * sizeof(arggetv->argv[0]));
+- argv = g_malloc0(sizeof(*argv) + (count - CAMEL_ARGV_MAX) * sizeof(argv->argv[0]));
++ arggetv = g_malloc0((guint32)(sizeof(*arggetv) + (count - CAMEL_ARGV_MAX) * sizeof(arggetv->argv[0])));
++ argv = g_malloc0((guint32)(sizeof(*argv) + (count - CAMEL_ARGV_MAX) * sizeof(argv->argv[0])));
+ l = props;
+ i = 0;
+ while (l) {