aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authortheraven <theraven@FreeBSD.org>2015-09-19 18:33:34 +0800
committertheraven <theraven@FreeBSD.org>2015-09-19 18:33:34 +0800
commitf410eb77efeec7636a0a08f7330d4821a1bcd4d0 (patch)
treeda5a3eeed8b9041e9805decaee1098282defef37 /databases
parent1659ce0cba407df928696251d75c6308bec3077b (diff)
downloadfreebsd-ports-gnome-f410eb77efeec7636a0a08f7330d4821a1bcd4d0.tar.gz
freebsd-ports-gnome-f410eb77efeec7636a0a08f7330d4821a1bcd4d0.tar.zst
freebsd-ports-gnome-f410eb77efeec7636a0a08f7330d4821a1bcd4d0.zip
Make all GNUstep ports install into the System domain so that the Local domain is available for stuff built from source.
Some ports were already installing in the System domain, for these just remove the Makefile lines explicitly specifying the install domain. The rest are installed in the Local domain, remove any overrides, update their pkg-plists and any explicit paths in the Makefiles and then bump port revision. Approved by: bapt (mentor) Differential Revision: https://reviews.freebsd.org/D2977
Diffstat (limited to 'databases')
-rw-r--r--databases/fortytwo-bdb/Makefile4
-rw-r--r--databases/fortytwo-bdb/pkg-plist64
-rw-r--r--databases/sqlclient/Makefile2
-rw-r--r--databases/sqlclient/pkg-plist66
4 files changed, 68 insertions, 68 deletions
diff --git a/databases/fortytwo-bdb/Makefile b/databases/fortytwo-bdb/Makefile
index 4feb2316a543..c05904e76771 100644
--- a/databases/fortytwo-bdb/Makefile
+++ b/databases/fortytwo-bdb/Makefile
@@ -2,7 +2,7 @@
PORTNAME= bdb
PORTVERSION= 0.2.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= databases gnustep
MASTER_SITES= SF/fortytwo/Berkeley%20DB%20Wrapper%20%28BDB%29/${PORTVERSION}
PKGNAMEPREFIX= fortytwo-
@@ -30,7 +30,7 @@ ADDITIONAL_LDFLAGS+= -L${BDB_LIB_DIR}
OPTIONS_DEFINE= DOCS
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Frameworks/BDB.framework/Versions/0/libBDB.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Frameworks/BDB.framework/Versions/0/libBDB.so
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKDIR}/BDB-0.2.0-api-ref && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
diff --git a/databases/fortytwo-bdb/pkg-plist b/databases/fortytwo-bdb/pkg-plist
index 17e48274ee6b..4376fcad379d 100644
--- a/databases/fortytwo-bdb/pkg-plist
+++ b/databases/fortytwo-bdb/pkg-plist
@@ -1,35 +1,35 @@
-GNUstep/Local/Library/Frameworks/BDB.framework/BDB
-GNUstep/Local/Library/Frameworks/BDB.framework/Headers
-GNUstep/Local/Library/Frameworks/BDB.framework/Resources
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/BDB
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDB.h
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBConfig.h
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBConstants.h
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBCursor.h
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBCursorConfig.h
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBDatabase.h
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBDatabaseConfig.h
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBDatabaseEntry.h
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBDatabaseEntryData.h
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBDatabaseRecordNumber.h
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBErrorHandling.h
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBExceptions.h
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBLockMode.h
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBObject.h
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBOperationStatus.h
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBSerializer.h
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBTransaction.h
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/NSArchiver-BDBExtensions.h
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Resources/Info-gnustep.plist
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/libBDB.so
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/libBDB.so.%%MAJORLIBVERSION%%
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/libBDB.so.%%LIBVERSION%%
-GNUstep/Local/Library/Frameworks/BDB.framework/Versions/Current
-GNUstep/Local/Library/Frameworks/BDB.framework/libBDB.so
-GNUstep/Local/Library/Headers/BDB
-GNUstep/Local/Library/Libraries/libBDB.so
-GNUstep/Local/Library/Libraries/libBDB.so.%%MAJORLIBVERSION%%
-GNUstep/Local/Library/Libraries/libBDB.so.%%LIBVERSION%%
+GNUstep/System/Library/Frameworks/BDB.framework/BDB
+GNUstep/System/Library/Frameworks/BDB.framework/Headers
+GNUstep/System/Library/Frameworks/BDB.framework/Resources
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/BDB
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDB.h
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBConfig.h
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBConstants.h
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBCursor.h
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBCursorConfig.h
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBDatabase.h
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBDatabaseConfig.h
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBDatabaseEntry.h
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBDatabaseEntryData.h
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBDatabaseRecordNumber.h
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBErrorHandling.h
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBExceptions.h
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBLockMode.h
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBObject.h
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBOperationStatus.h
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBSerializer.h
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/BDBTransaction.h
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Headers/NSArchiver-BDBExtensions.h
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/Resources/Info-gnustep.plist
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/libBDB.so
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/libBDB.so.%%MAJORLIBVERSION%%
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/%%MAJORVERSION%%/libBDB.so.%%LIBVERSION%%
+GNUstep/System/Library/Frameworks/BDB.framework/Versions/Current
+GNUstep/System/Library/Frameworks/BDB.framework/libBDB.so
+GNUstep/System/Library/Headers/BDB
+GNUstep/System/Library/Libraries/libBDB.so
+GNUstep/System/Library/Libraries/libBDB.so.%%MAJORLIBVERSION%%
+GNUstep/System/Library/Libraries/libBDB.so.%%LIBVERSION%%
%%PORTDOCS%%%%DOCSDIR%%/BDB/BDB.html
%%PORTDOCS%%%%DOCSDIR%%/BDB/CompositePage.html
%%PORTDOCS%%%%DOCSDIR%%/BDB/index.html
diff --git a/databases/sqlclient/Makefile b/databases/sqlclient/Makefile
index 93d013be54f9..9ff40883948b 100644
--- a/databases/sqlclient/Makefile
+++ b/databases/sqlclient/Makefile
@@ -2,6 +2,7 @@
PORTNAME= sqlclient
PORTVERSION= 1.8.1
+PORTREVISION= 2
CATEGORIES= databases gnustep
MASTER_SITES= GNUSTEP/libs
DISTNAME= SQLClient-${PORTVERSION}
@@ -21,7 +22,6 @@ USE_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
USE_MYSQL=yes
LDFLAGS+= -pthread
-MAKE_ENV+= GNUSTEP_INSTALLATION_DIR=${GNUSTEP_LOCAL_ROOT}
DEFAULT_LIBVERSION= 1.5
DEFAULT_LIBVERSION2= 1.5.0
PLIST_SUB+= LIBVERSION2=${DEFAULT_LIBVERSION2}
diff --git a/databases/sqlclient/pkg-plist b/databases/sqlclient/pkg-plist
index cc85726f8e38..999df2e4a4aa 100644
--- a/databases/sqlclient/pkg-plist
+++ b/databases/sqlclient/pkg-plist
@@ -1,33 +1,33 @@
-GNUstep/Local/Library/Bundles/SQLClient1.8/ECPG.bundle/ECPG
-GNUstep/Local/Library/Bundles/SQLClient1.8/ECPG.bundle/Resources/Info-gnustep.plist
-GNUstep/Local/Library/Bundles/SQLClient1.8/ECPG.bundle/stamp.make
-GNUstep/Local/Library/Bundles/SQLClient1.8/ECPG_libs.bundle/ECPG_libs
-GNUstep/Local/Library/Bundles/SQLClient1.8/ECPG_libs.bundle/Resources/Info-gnustep.plist
-GNUstep/Local/Library/Bundles/SQLClient1.8/ECPG_libs.bundle/stamp.make
-GNUstep/Local/Library/Bundles/SQLClient1.8/MySQL.bundle/MySQL
-GNUstep/Local/Library/Bundles/SQLClient1.8/MySQL.bundle/Resources/Info-gnustep.plist
-GNUstep/Local/Library/Bundles/SQLClient1.8/MySQL.bundle/stamp.make
-GNUstep/Local/Library/Bundles/SQLClient1.8/MySQL_libs.bundle/MySQL_libs
-GNUstep/Local/Library/Bundles/SQLClient1.8/MySQL_libs.bundle/Resources/Info-gnustep.plist
-GNUstep/Local/Library/Bundles/SQLClient1.8/MySQL_libs.bundle/stamp.make
-GNUstep/Local/Library/Bundles/SQLClient1.8/Postgres.bundle/Postgres
-GNUstep/Local/Library/Bundles/SQLClient1.8/Postgres.bundle/Resources/Info-gnustep.plist
-GNUstep/Local/Library/Bundles/SQLClient1.8/Postgres.bundle/stamp.make
-GNUstep/Local/Library/Bundles/SQLClient1.8/Postgres_libs.bundle/Postgres_libs
-GNUstep/Local/Library/Bundles/SQLClient1.8/Postgres_libs.bundle/Resources/Info-gnustep.plist
-GNUstep/Local/Library/Bundles/SQLClient1.8/Postgres_libs.bundle/stamp.make
-GNUstep/Local/Library/Bundles/SQLClient1.8/SQLite.bundle/Resources/Info-gnustep.plist
-GNUstep/Local/Library/Bundles/SQLClient1.8/SQLite.bundle/SQLite
-GNUstep/Local/Library/Bundles/SQLClient1.8/SQLite.bundle/stamp.make
-GNUstep/Local/Library/Bundles/SQLClient1.8/SQLite_libs.bundle/Resources/Info-gnustep.plist
-GNUstep/Local/Library/Bundles/SQLClient1.8/SQLite_libs.bundle/SQLite_libs
-GNUstep/Local/Library/Bundles/SQLClient1.8/SQLite_libs.bundle/stamp.make
-GNUstep/Local/Library/Libraries/libSQLClient.so.1.8
-GNUstep/Local/Library/Libraries/libSQLClient.so.1.8.0
-GNUstep/Local/Library/Documentation/SQLClient/OrderedSymbolDeclarations.plist
-GNUstep/Local/Library/Documentation/SQLClient/SQLClient.gsdoc
-GNUstep/Local/Library/Documentation/SQLClient/SQLClient.html
-GNUstep/Local/Library/Documentation/SQLClient/SQLClient.igsdoc
-GNUstep/Local/Library/Documentation/SQLClient/dependencies
-GNUstep/Local/Library/Headers/SQLClient/SQLClient.h
-GNUstep/Local/Library/Libraries/libSQLClient.so
+GNUstep/System/Library/Bundles/SQLClient1.8/ECPG.bundle/ECPG
+GNUstep/System/Library/Bundles/SQLClient1.8/ECPG.bundle/Resources/Info-gnustep.plist
+GNUstep/System/Library/Bundles/SQLClient1.8/ECPG.bundle/stamp.make
+GNUstep/System/Library/Bundles/SQLClient1.8/ECPG_libs.bundle/ECPG_libs
+GNUstep/System/Library/Bundles/SQLClient1.8/ECPG_libs.bundle/Resources/Info-gnustep.plist
+GNUstep/System/Library/Bundles/SQLClient1.8/ECPG_libs.bundle/stamp.make
+GNUstep/System/Library/Bundles/SQLClient1.8/MySQL.bundle/MySQL
+GNUstep/System/Library/Bundles/SQLClient1.8/MySQL.bundle/Resources/Info-gnustep.plist
+GNUstep/System/Library/Bundles/SQLClient1.8/MySQL.bundle/stamp.make
+GNUstep/System/Library/Bundles/SQLClient1.8/MySQL_libs.bundle/MySQL_libs
+GNUstep/System/Library/Bundles/SQLClient1.8/MySQL_libs.bundle/Resources/Info-gnustep.plist
+GNUstep/System/Library/Bundles/SQLClient1.8/MySQL_libs.bundle/stamp.make
+GNUstep/System/Library/Bundles/SQLClient1.8/Postgres.bundle/Postgres
+GNUstep/System/Library/Bundles/SQLClient1.8/Postgres.bundle/Resources/Info-gnustep.plist
+GNUstep/System/Library/Bundles/SQLClient1.8/Postgres.bundle/stamp.make
+GNUstep/System/Library/Bundles/SQLClient1.8/Postgres_libs.bundle/Postgres_libs
+GNUstep/System/Library/Bundles/SQLClient1.8/Postgres_libs.bundle/Resources/Info-gnustep.plist
+GNUstep/System/Library/Bundles/SQLClient1.8/Postgres_libs.bundle/stamp.make
+GNUstep/System/Library/Bundles/SQLClient1.8/SQLite.bundle/Resources/Info-gnustep.plist
+GNUstep/System/Library/Bundles/SQLClient1.8/SQLite.bundle/SQLite
+GNUstep/System/Library/Bundles/SQLClient1.8/SQLite.bundle/stamp.make
+GNUstep/System/Library/Bundles/SQLClient1.8/SQLite_libs.bundle/Resources/Info-gnustep.plist
+GNUstep/System/Library/Bundles/SQLClient1.8/SQLite_libs.bundle/SQLite_libs
+GNUstep/System/Library/Bundles/SQLClient1.8/SQLite_libs.bundle/stamp.make
+GNUstep/System/Library/Libraries/libSQLClient.so.1.8
+GNUstep/System/Library/Libraries/libSQLClient.so.1.8.0
+GNUstep/System/Library/Documentation/SQLClient/OrderedSymbolDeclarations.plist
+GNUstep/System/Library/Documentation/SQLClient/SQLClient.gsdoc
+GNUstep/System/Library/Documentation/SQLClient/SQLClient.html
+GNUstep/System/Library/Documentation/SQLClient/SQLClient.igsdoc
+GNUstep/System/Library/Documentation/SQLClient/dependencies
+GNUstep/System/Library/Headers/SQLClient/SQLClient.h
+GNUstep/System/Library/Libraries/libSQLClient.so