aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-05-27 23:07:11 +0800
committerlinimon <linimon@FreeBSD.org>2017-05-27 23:07:11 +0800
commitf427d85883d325fa56a13e2d34236051a61e2762 (patch)
tree63c89da74eed9e490571d2f4431a86387cc1eb81 /databases
parent616751b74e7581b43a094683d687f80b26d2a29b (diff)
downloadfreebsd-ports-gnome-f427d85883d325fa56a13e2d34236051a61e2762.tar.gz
freebsd-ports-gnome-f427d85883d325fa56a13e2d34236051a61e2762.tar.zst
freebsd-ports-gnome-f427d85883d325fa56a13e2d34236051a61e2762.zip
Mark some ports failing on armv6, for errors classified as "clang".
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'databases')
-rw-r--r--databases/sqliteodbc-sqlite2/Makefile3
-rw-r--r--databases/tarantool/Makefile6
-rw-r--r--databases/xtrabackup/Makefile4
3 files changed, 7 insertions, 6 deletions
diff --git a/databases/sqliteodbc-sqlite2/Makefile b/databases/sqliteodbc-sqlite2/Makefile
index 930e6fcb9f5f..1a96e6681c63 100644
--- a/databases/sqliteodbc-sqlite2/Makefile
+++ b/databases/sqliteodbc-sqlite2/Makefile
@@ -9,6 +9,7 @@ COMMENT= ODBC driver for SQLite 2
MASTERDIR= ${.CURDIR}/../sqliteodbc
-BROKEN_aarch64= Fails to compile: error: passing char * to parameter of incompatible type va_list
+BROKEN_aarch64= fails to compile: error: passing char * to parameter of incompatible type va_list
+BROKEN_armv6= fails to compile: error: passing char * to parameter of incompatible type va_list
.include "${MASTERDIR}/Makefile"
diff --git a/databases/tarantool/Makefile b/databases/tarantool/Makefile
index 2c1db2ce23f3..f09ad003a7c3 100644
--- a/databases/tarantool/Makefile
+++ b/databases/tarantool/Makefile
@@ -11,7 +11,8 @@ COMMENT= NoSQL database running in a Lua application server
LICENSE= BSD2CLAUSE
-BROKEN_powerpc64= Does not build: Unsupported architecture -- powerpc64
+NOT_FOR_ARCHS= armv6 powerpc64 sparc64
+NOT_FOR_ARCHS_REASON= fails to build: Unsupported architecture
MAKE_JOBS_UNSAFE=yes
USES= cmake compiler:c++11-lang gettext gmake perl5 readline
@@ -45,9 +46,6 @@ PLIST_SUB+= TT_USER=${USERS} \
OPTIONS_DEFINE= DEBUG
-NOT_FOR_ARCHS= sparc64
-NOT_FOR_ARCHS_REASON= not yet ported to this architecture
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDEBUG}
diff --git a/databases/xtrabackup/Makefile b/databases/xtrabackup/Makefile
index 7f4ebccddc81..4f0278477e07 100644
--- a/databases/xtrabackup/Makefile
+++ b/databases/xtrabackup/Makefile
@@ -24,7 +24,9 @@ LIB_DEPENDS= libev.so:devel/libev \
RUN_DEPENDS= p5-DBD-mysql>=0:databases/p5-DBD-mysql \
qpress:archivers/qpress
-BROKEN_powerpc64= Does not build: ld: final link failed: Bad value
+BROKEN_armv6= fails to compile: cannot combine with previous 'type-name' declaration specifier
+BROKEN_mips64= fails to compile: 'fpsetmask' was not declared in this scope
+BROKEN_powerpc64= fails to link: ld: final link failed: Bad value
# autotool is in use for 5.1 builds
USES= alias autoreconf:build cpe gettext cmake libtool perl5 shebangfix