aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-09-09 00:25:12 +0800
committerdanfe <danfe@FreeBSD.org>2015-09-09 00:25:12 +0800
commitf4362981131a3dbea11034d99cfe52df7cd067e0 (patch)
tree9043c69769af76cfb87e5577c74ec6505eacae51 /databases
parent273fe45f9a2dca06abd7e2708c9c3731f5b1d63c (diff)
downloadfreebsd-ports-gnome-f4362981131a3dbea11034d99cfe52df7cd067e0.tar.gz
freebsd-ports-gnome-f4362981131a3dbea11034d99cfe52df7cd067e0.tar.zst
freebsd-ports-gnome-f4362981131a3dbea11034d99cfe52df7cd067e0.zip
- Update to version 1.1.2: the only functional differences are correct
order of float4store() arguments which was breaking the build on big- endian architectures in version 1.1.1, and plugged resource leaks in void mysac_close(MYSAC *mysac) function - Define LICENSE (GPLv3) and simplify `do-install' target recipe - Cleanup COMMENT and port description text (remove EOL whitespace and double `uses uses` typo), update WWW address to avoid redirect
Diffstat (limited to 'databases')
-rw-r--r--databases/mysac/Makefile22
-rw-r--r--databases/mysac/distinfo4
-rw-r--r--databases/mysac/pkg-descr10
3 files changed, 14 insertions, 22 deletions
diff --git a/databases/mysac/Makefile b/databases/mysac/Makefile
index 4c738d5f10c5..8c82611fd38e 100644
--- a/databases/mysac/Makefile
+++ b/databases/mysac/Makefile
@@ -2,14 +2,15 @@
# $FreeBSD$
PORTNAME= mysac
-PORTVERSION= 1.1.1
-PORTREVISION= 1
+PORTVERSION= 1.1.2
CATEGORIES= databases
MASTER_SITES= http://www.arpalert.org/src/ \
http://xz.cx/downloads/mysac/
MAINTAINER= jake@xz.cx
-COMMENT= MySAC: MySQL Simple Asynchronous Client
+COMMENT= MySQL Simple Asynchronous Client
+
+LICENSE= GPLv3
USE_LDCONFIG= yes
USE_MYSQL= yes
@@ -26,16 +27,9 @@ pre-build:
${TOUCH} ${WRKSRC}/make.deps
do-install:
- ${INSTALL_LIB} ${WRKSRC}/libmysac.so \
- ${STAGEDIR}${PREFIX}/lib/libmysac.so
+ ${INSTALL_LIB} ${WRKSRC}/libmysac.so ${STAGEDIR}${PREFIX}/lib
${LN} -sf libmysac.so ${STAGEDIR}${PREFIX}/lib/libmysac.so.0
- ${INSTALL_DATA} ${WRKSRC}/libmysac-static.a ${STAGEDIR}${PREFIX}/lib/libmysac-static.a
- ${INSTALL_DATA} ${WRKSRC}/mysac.h ${STAGEDIR}${PREFIX}/include/mysac.h
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64
-.endif
+ ${INSTALL_DATA} ${WRKSRC}/libmysac-static.a ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/mysac.h ${STAGEDIR}${PREFIX}/include
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/mysac/distinfo b/databases/mysac/distinfo
index 2f394fece34f..82b93c9de6fd 100644
--- a/databases/mysac/distinfo
+++ b/databases/mysac/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mysac-1.1.1.tar.gz) = 63fb38ca6a6ee8d28bbad0552c7c7d240fbc6ed06ca886ad2ba31cf1ce8596d3
-SIZE (mysac-1.1.1.tar.gz) = 46060
+SHA256 (mysac-1.1.2.tar.gz) = 0150edee0df888f9c6fe884c07281242ee28d408023994834facff93db15d77b
+SIZE (mysac-1.1.2.tar.gz) = 45407
diff --git a/databases/mysac/pkg-descr b/databases/mysac/pkg-descr
index b2ea5dbbf58c..cc65fffd2dbd 100644
--- a/databases/mysac/pkg-descr
+++ b/databases/mysac/pkg-descr
@@ -1,8 +1,6 @@
-MySAC: MySQL Simple Asynchonous Client
-
-MySAC is a library that provides mechanisms for making asynchronous
-request to MySQL database. It uses uses the official MySQL client
-library for authentication and network functions. Memory allocation
+MySAC (Simple Asynchronous Client) is a library that provides mechanisms for
+making asynchronous requests to MySQL database. It uses the official MySQL
+client library for authentication and network functions. Memory allocation
must be done in user code, so any memory manager can be used.
-WWW: http://cv.arpalert.org/page.sh?mysac
+WWW: http://www.arpalert.org/mysac.html