aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2012-07-23 09:33:55 +0800
committerdougb <dougb@FreeBSD.org>2012-07-23 09:33:55 +0800
commitfcfde219d56f661cbbdb46077d166fdf2046d5f0 (patch)
tree6f6452717d480fc723cb34dac6821c9a57f49795 /databases
parentd62f44f24081b479732367e1a0a910179d98b16f (diff)
downloadfreebsd-ports-gnome-fcfde219d56f661cbbdb46077d166fdf2046d5f0.tar.gz
freebsd-ports-gnome-fcfde219d56f661cbbdb46077d166fdf2046d5f0.tar.zst
freebsd-ports-gnome-fcfde219d56f661cbbdb46077d166fdf2046d5f0.zip
For ports maintained by ports@ where pkgconfig is one of the USE_GNOME deps
convert it to BUILD_DEPENDS. This avoids the problem of the bogus run dep added by bsd.gnome.mk.
Diffstat (limited to 'databases')
-rw-r--r--databases/dbh10/Makefile4
-rw-r--r--databases/mysqlcppapi/Makefile4
2 files changed, 6 insertions, 2 deletions
diff --git a/databases/dbh10/Makefile b/databases/dbh10/Makefile
index e00c7c8ad919..4df6e1bcc7ec 100644
--- a/databases/dbh10/Makefile
+++ b/databases/dbh10/Makefile
@@ -17,8 +17,10 @@ COMMENT= Disk Based Hashtables
CONFLICTS= dbh-[2-9]*
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
+
USE_AUTOTOOLS= libtool
-USE_GNOME= gnomehack pkgconfig
+USE_GNOME= gnomehack
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/databases/mysqlcppapi/Makefile b/databases/mysqlcppapi/Makefile
index 7f25f1c41b3e..f5ea81d20756 100644
--- a/databases/mysqlcppapi/Makefile
+++ b/databases/mysqlcppapi/Makefile
@@ -14,9 +14,11 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%202/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A fork of mysql++ C++ API for MySQL
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
+
USE_AUTOTOOLS= libtool
USE_MYSQL= yes
-USE_GNOME= pkgconfig gnomehack
+USE_GNOME= gnomehack
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include