aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/easystroke
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-02-15 09:51:30 +0800
committermiwi <miwi@FreeBSD.org>2013-02-15 09:51:30 +0800
commitdeb06d82b464f7e78670b2eff771b4bd8daa6003 (patch)
tree1ece1b9e74ec43285cd0449ed7160ecbe21b1f35 /deskutils/easystroke
parentebe2baea88c8ac4277c0f4d09e488ef63c906fb8 (diff)
downloadfreebsd-ports-gnome-deb06d82b464f7e78670b2eff771b4bd8daa6003.tar.gz
freebsd-ports-gnome-deb06d82b464f7e78670b2eff771b4bd8daa6003.tar.zst
freebsd-ports-gnome-deb06d82b464f7e78670b2eff771b4bd8daa6003.zip
Easystroke is a gesture-recognition application for X11. Gestures or
strokes are movements that you make with your mouse (or your pen, finger etc.) while holding down a specific mouse button. Easystroke will execute certain actions if it recognizes the stroke; currently easystroke can emulate key presses, execute shell commands, hold down modifiers and emulate a scroll wheel. The program was designed with Tablet PCs in mind and can be used effectively even without access to a keyboard. WWW: http://easystroke.sourceforge.net/ PR: ports/176083 Submitted by: Tobias Kortkamp <tobias.kortkamp@gmail.com>
Diffstat (limited to 'deskutils/easystroke')
-rw-r--r--deskutils/easystroke/Makefile61
-rw-r--r--deskutils/easystroke/distinfo2
-rw-r--r--deskutils/easystroke/files/patch-Makefile14
-rw-r--r--deskutils/easystroke/files/patch-main.cc11
-rw-r--r--deskutils/easystroke/pkg-descr10
-rw-r--r--deskutils/easystroke/pkg-plist21
6 files changed, 119 insertions, 0 deletions
diff --git a/deskutils/easystroke/Makefile b/deskutils/easystroke/Makefile
new file mode 100644
index 000000000000..1d2bd8b55d36
--- /dev/null
+++ b/deskutils/easystroke/Makefile
@@ -0,0 +1,61 @@
+# Created by: Tobias Kortkamp <tobias.kortkamp@gmail.com>
+# $FreeBSD$
+
+PORTNAME= easystroke
+PORTVERSION= 0.5.6
+CATEGORIES= deskutils
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= tobias.kortkamp@gmail.com
+COMMENT= Easystroke is a gesture-recognition application for X11
+
+BUILD_DEPENDS= help2man:${PORTSDIR}/misc/help2man \
+ ${LOCALBASE}/include/xorg/xserver-properties.h:${PORTSDIR}/x11-servers/xorg-server
+LIB_DEPENDS= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
+ dbus-glib:${PORTSDIR}/devel/dbus-glib \
+ boost_serialization:${PORTSDIR}/devel/boost-libs
+
+MAN1= easystroke.1
+
+USE_GCC= any
+USE_XORG= x11 xtst
+USE_GMAKE= yes
+INSTALLS_ICONS= yes
+
+OPTIONS_DEFINE= NLS
+
+.include <bsd.port.options.mk>
+
+USE_GETTEXT= yes
+
+.if ${PORT_OPTIONS:MNLS}
+BUILD_DEPENDS+= intltool-merge:${PORTSDIR}/textproc/intltool
+PLIST_SUB+= NLS=""
+ALL_TARGET= easystroke.desktop all man
+.else
+# This builds easystroke without translations
+ALL_TARGET= man
+PLIST_SUB+= NLS="@comment "
+# Create a .desktop file without translations.
+# It's usually created by intltool-merge during the build.
+pre-build:
+ @${CP} ${WRKSRC}/${PORTNAME}.desktop.in ${WRKSRC}/${PORTNAME}.desktop
+.endif
+
+do-install:
+ @${MKDIR} ${PREFIX}/bin/
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ @${MKDIR} ${PREFIX}/share/applications/
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${PREFIX}/share/applications/
+ @${MKDIR} ${PREFIX}/share/pixmaps/
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.svg ${PREFIX}/share/pixmaps/
+ @${MKDIR} ${PREFIX}/man/man1/
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
+
+.if ${PORT_OPTIONS:MNLS}
+ @${MKDIR} ${PREFIX}/share/locale/
+ @(cd ${WRKSRC}/po/ && \
+ ${COPYTREE_SHARE} \* ${PREFIX}/share/locale/ "-name *.mo")
+.endif
+
+.include <bsd.port.mk>
diff --git a/deskutils/easystroke/distinfo b/deskutils/easystroke/distinfo
new file mode 100644
index 000000000000..73d60cd3b574
--- /dev/null
+++ b/deskutils/easystroke/distinfo
@@ -0,0 +1,2 @@
+SHA256 (easystroke-0.5.6.tar.gz) = aee0b9127610ea2b75d0d9ff056e804f059c2241e5e94eae49140268c7fc13ab
+SIZE (easystroke-0.5.6.tar.gz) = 111143
diff --git a/deskutils/easystroke/files/patch-Makefile b/deskutils/easystroke/files/patch-Makefile
new file mode 100644
index 000000000000..b3a0b083fd35
--- /dev/null
+++ b/deskutils/easystroke/files/patch-Makefile
@@ -0,0 +1,14 @@
+--- Makefile.orig 2013-02-14 11:04:30.880047783 +0100
++++ Makefile 2013-02-14 11:05:05.096047700 +0100
+@@ -78,9 +78,9 @@
+ easystroke.desktop: easystroke.desktop.in $(MOFILES)
+ intltool-merge po/ -d -u $< $@
+
+-desktop.c: easystroke.desktop
++desktop.c:
+ echo "const char *desktop_file = \"\\" > $@
+- sed 's/Exec=easystroke/Exec=%s/' $< | sed 's/"/\\"/g' | sed 's/.*/&\\n\\/' >> $@
++ sed 's/Exec=easystroke/Exec=%s/' easystroke.desktop | sed 's/"/\\"/g' | sed 's/.*/&\\n\\/' >> $@
+ echo "\";" >> $@
+
+ dbus-server.cc: dbus-server.h
diff --git a/deskutils/easystroke/files/patch-main.cc b/deskutils/easystroke/files/patch-main.cc
new file mode 100644
index 000000000000..443fb5665d92
--- /dev/null
+++ b/deskutils/easystroke/files/patch-main.cc
@@ -0,0 +1,11 @@
+--- main.cc~ 2012-10-06 08:07:11.000000000 +0200
++++ main.cc 2013-02-12 17:29:51.103190380 +0100
+@@ -1350,7 +1350,7 @@
+ config_dir += "/.easystroke";
+ }
+ struct stat st;
+- char *name = canonicalize_file_name(config_dir.c_str());
++ char *name = realpath(config_dir.c_str(), NULL);
+
+ // check if the directory does not exist
+ if (lstat(name, &st) == -1) {
diff --git a/deskutils/easystroke/pkg-descr b/deskutils/easystroke/pkg-descr
new file mode 100644
index 000000000000..b838823e377d
--- /dev/null
+++ b/deskutils/easystroke/pkg-descr
@@ -0,0 +1,10 @@
+Easystroke is a gesture-recognition application for X11. Gestures or
+strokes are movements that you make with your mouse (or your pen,
+finger etc.) while holding down a specific mouse button. Easystroke
+will execute certain actions if it recognizes the stroke; currently
+easystroke can emulate key presses, execute shell commands, hold down
+modifiers and emulate a scroll wheel. The program was designed with
+Tablet PCs in mind and can be used effectively even without access to
+a keyboard.
+
+WWW: http://easystroke.sourceforge.net/
diff --git a/deskutils/easystroke/pkg-plist b/deskutils/easystroke/pkg-plist
new file mode 100644
index 000000000000..7c077602d066
--- /dev/null
+++ b/deskutils/easystroke/pkg-plist
@@ -0,0 +1,21 @@
+share/pixmaps/easystroke.svg
+%%NLS%%share/locale/ru/LC_MESSAGES/easystroke.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/easystroke.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/easystroke.mo
+%%NLS%%share/locale/el/LC_MESSAGES/easystroke.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/easystroke.mo
+%%NLS%%share/locale/de/LC_MESSAGES/easystroke.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/easystroke.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/easystroke.mo
+%%NLS%%share/locale/it/LC_MESSAGES/easystroke.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/easystroke.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/easystroke.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/easystroke.mo
+%%NLS%%share/locale/es/LC_MESSAGES/easystroke.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/easystroke.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/easystroke.mo
+%%NLS%%share/locale/he/LC_MESSAGES/easystroke.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/easystroke.mo
+share/applications/easystroke.desktop
+bin/easystroke
+@dirrmtry share/applications