aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/fusenshi
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-08-26 22:06:08 +0800
committertijl <tijl@FreeBSD.org>2014-08-26 22:06:08 +0800
commitf8357b5cbaa160ccdf9943cac099f5e092c591da (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /deskutils/fusenshi
parent89a7d6ecbdde724b92ca6650493f56cf68855f35 (diff)
downloadfreebsd-ports-gnome-f8357b5cbaa160ccdf9943cac099f5e092c591da.tar.gz
freebsd-ports-gnome-f8357b5cbaa160ccdf9943cac099f5e092c591da.tar.zst
freebsd-ports-gnome-f8357b5cbaa160ccdf9943cac099f5e092c591da.zip
- Fix missing library problems when the linker enforces explicit linking
PR: 192062 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'deskutils/fusenshi')
-rw-r--r--deskutils/fusenshi/Makefile6
-rw-r--r--deskutils/fusenshi/files/patch-src-Makefile11
2 files changed, 12 insertions, 5 deletions
diff --git a/deskutils/fusenshi/Makefile b/deskutils/fusenshi/Makefile
index 83a35b41e5b0..af15a3aad567 100644
--- a/deskutils/fusenshi/Makefile
+++ b/deskutils/fusenshi/Makefile
@@ -10,11 +10,9 @@ MASTER_SITES= http://www.ongs.co.jp/projects/fusenshi/
MAINTAINER= ozawa@ongs.co.jp
COMMENT= Post-it(R) like application with network support
-LIB_DEPENDS= libgtkmm-2.4.so:${PORTSDIR}/x11-toolkits/gtkmm24 \
- libgtksourceview-1.0.so:${PORTSDIR}/x11-toolkits/gtksourceview
-
USES= pkgconfig tar:tgz
-USE_GNOME= libxml2
+USE_GNOME= gtkmm24 gtksourceview libxml2
+USE_XORG= x11
MAKE_JOBS_UNSAFE= yes
.ifdef WITHOUT_SSL
diff --git a/deskutils/fusenshi/files/patch-src-Makefile b/deskutils/fusenshi/files/patch-src-Makefile
index 982850d61d5e..8621cfaf4c58 100644
--- a/deskutils/fusenshi/files/patch-src-Makefile
+++ b/deskutils/fusenshi/files/patch-src-Makefile
@@ -1,6 +1,15 @@
--- src/Makefile.orig 2014-07-05 00:11:32.020240534 +0800
+++ src/Makefile 2014-07-05 00:12:26.524236990 +0800
-@@ -98,12 +98,12 @@ build: ${OBJ}
+@@ -34,7 +34,7 @@
+ .include "../Makefile.inc"
+
+ LIB_DEPS= gtkmm-2.4 gdkmm-2.4 atkmm-1.6 pangomm-1.4 gtksourceview-1.0 \
+- gthread-2.0 libxml-2.0
++ gthread-2.0 libxml-2.0 x11
+
+ #ifndef WITHOUT_SSL
+ LIB_DEPS+= gnutls
+@@ -98,12 +98,12 @@
${CXX} ${CXXFLAGS} -o ${<:.cpp=.o} -c $<
install: