aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/gdesklets
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-11-19 04:04:47 +0800
committermarcus <marcus@FreeBSD.org>2003-11-19 04:04:47 +0800
commitfa67054e8fbb729ed6f79a39e364c6b6df0811bd (patch)
treeced4f0718cfe2d3e1f5b004459a66d61e9babc38 /deskutils/gdesklets
parent6595a5ee8d6b260e572a2e3a1e131e6917f30225 (diff)
downloadfreebsd-ports-gnome-fa67054e8fbb729ed6f79a39e364c6b6df0811bd.tar.gz
freebsd-ports-gnome-fa67054e8fbb729ed6f79a39e364c6b6df0811bd.tar.zst
freebsd-ports-gnome-fa67054e8fbb729ed6f79a39e364c6b6df0811bd.zip
Add the official threads fix.
PR: 59432 Submitted by: maintainer Obtained from: gDesklets CVS
Diffstat (limited to 'deskutils/gdesklets')
-rw-r--r--deskutils/gdesklets/Makefile2
-rw-r--r--deskutils/gdesklets/files/patch-sensor::Sensor.py17
2 files changed, 9 insertions, 10 deletions
diff --git a/deskutils/gdesklets/Makefile b/deskutils/gdesklets/Makefile
index f1e02b915ad9..4499be9be0aa 100644
--- a/deskutils/gdesklets/Makefile
+++ b/deskutils/gdesklets/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gdesklets
PORTVERSION= 0.24.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils gnome
MASTER_SITES= http://www.pycage.de/download/${PORTNAME}/
DISTNAME= gDesklets-${PORTVERSION}
diff --git a/deskutils/gdesklets/files/patch-sensor::Sensor.py b/deskutils/gdesklets/files/patch-sensor::Sensor.py
index 21804656d3b1..c2c3430d51fb 100644
--- a/deskutils/gdesklets/files/patch-sensor::Sensor.py
+++ b/deskutils/gdesklets/files/patch-sensor::Sensor.py
@@ -1,14 +1,13 @@
# Yay! Many thanks to Franz Klammer <klammer@webonaut.com>,
# the theads is now work. That make a lot of desklets work now.
---- sensor/Sensor.py.orig Mon Nov 17 16:46:57 2003
-+++ sensor/Sensor.py Mon Nov 17 16:48:43 2003
-@@ -134,6 +134,8 @@
- #
- def _add_thread(self, threadfunction, *args):
+--- sensor/Sensor.py.orig Tue Nov 18 13:32:10 2003
++++ sensor/Sensor.py Tue Nov 18 13:33:39 2003
+@@ -346,3 +346,7 @@
+ def __on_quit(self, src):
-+ gtk.threads_init()
+ gtk.main_quit()
+
- # the thread should not start before setup is complete, therefore
- # we are using the GTK idle handler
- def run_thread(threadfunction, args):
++
++# FreeBSD needs this; Linux doesn't but it's cleaner to use it
++gtk.threads_init()