aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/google-gadgets
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-11-24 06:51:45 +0800
committermiwi <miwi@FreeBSD.org>2008-11-24 06:51:45 +0800
commitad03d67607bf83efdd3ef1825ea31c8c30873ec7 (patch)
treea85efcac7f70e2f1568f06e0be5359e93bc11494 /deskutils/google-gadgets
parent30274d6cbabd6c834b61c2fb0e2539452b1508ed (diff)
downloadfreebsd-ports-gnome-ad03d67607bf83efdd3ef1825ea31c8c30873ec7.tar.gz
freebsd-ports-gnome-ad03d67607bf83efdd3ef1825ea31c8c30873ec7.tar.zst
freebsd-ports-gnome-ad03d67607bf83efdd3ef1825ea31c8c30873ec7.zip
- Update to 0.10.3
Note: FreeBSD 6.X isn't longer supported PR: 129044 Submitted by: Ashish Shukla <wahjava@gmail.com> (maintainer)
Diffstat (limited to 'deskutils/google-gadgets')
-rw-r--r--deskutils/google-gadgets/Makefile9
-rw-r--r--deskutils/google-gadgets/distinfo6
-rw-r--r--deskutils/google-gadgets/files/patch-extensions_gst__video__element_gst__video__element.cc33
-rw-r--r--deskutils/google-gadgets/files/patch-extensions_gtkmoz__browser__element_Makefile.am15
-rw-r--r--deskutils/google-gadgets/files/patch-extensions_smjs__script__runtime_Makefile.am15
-rw-r--r--deskutils/google-gadgets/files/patch-extensions_smjs__script__runtime_tests_Makefile.am15
-rw-r--r--deskutils/google-gadgets/files/patch-ggadget_npapi_Makefile.am15
-rw-r--r--deskutils/google-gadgets/pkg-plist27
8 files changed, 109 insertions, 26 deletions
diff --git a/deskutils/google-gadgets/Makefile b/deskutils/google-gadgets/Makefile
index d5420b7d4c41..a8091471e284 100644
--- a/deskutils/google-gadgets/Makefile
+++ b/deskutils/google-gadgets/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= google-gadgets
-PORTVERSION= 0.10.2
+PORTVERSION= 0.10.3
CATEGORIES= deskutils
MASTER_SITES= http://google-gadgets-for-linux.googlecode.com/files/
DISTNAME= ${PORTNAME}-for-linux-${PORTVERSION}
@@ -49,6 +49,10 @@ OPTIONS= DEBUGGING "Enable debug output on runtime" on\
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 700000
+IGNORE=This port needs 7.X or higher
+.endif
+
.if defined(WITH_DEBUGGING)
CONFIGURE_ARGS+= --enable-debug
.endif
@@ -60,6 +64,8 @@ CONFIGURE_ARGS+= --disable-gtk-host --disable-libggadget-gtk --disable-gtkmoz-br
USE_GNOME= gtk20
PLIST_SUB+= GTK=""
CONFIGURE_ARGS+= --enable-gtk-host
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/libstartup-notification-1.0.pc:${PORTSDIR}/x11/startup-notification
+LIB_DEPENDS+= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
.endif
.if defined(WITHOUT_QT)
@@ -82,6 +88,7 @@ post-patch:
pre-configure:
@cd ${WRKSRC} && ${SH} autotools/bootstrap.sh && ${CP} ${AUTOMAKE_DIR}/mkinstalldirs libltdl/
+ @cd ${WRKSRC} && ${CHMOD} +x autotools/install-sh
post-install:
@-update-desktop-database
diff --git a/deskutils/google-gadgets/distinfo b/deskutils/google-gadgets/distinfo
index 871b8b52510c..336c062e231f 100644
--- a/deskutils/google-gadgets/distinfo
+++ b/deskutils/google-gadgets/distinfo
@@ -1,3 +1,3 @@
-MD5 (google-gadgets-for-linux-0.10.2.tar.bz2) = 0822bb6294cff0b8aa9830a13c2dd06d
-SHA256 (google-gadgets-for-linux-0.10.2.tar.bz2) = 0429408cd215dc8cb33c6fda31c65425366597426e3679004633b874f8fed164
-SIZE (google-gadgets-for-linux-0.10.2.tar.bz2) = 2188977
+MD5 (google-gadgets-for-linux-0.10.3.tar.bz2) = 16d2cc4fe05e4416d3b720090237520b
+SHA256 (google-gadgets-for-linux-0.10.3.tar.bz2) = fe63758aacb3842829c5a6d7698152b34becb44fe3e2d84d9706bf4ea9956c1e
+SIZE (google-gadgets-for-linux-0.10.3.tar.bz2) = 2310377
diff --git a/deskutils/google-gadgets/files/patch-extensions_gst__video__element_gst__video__element.cc b/deskutils/google-gadgets/files/patch-extensions_gst__video__element_gst__video__element.cc
index 1ead87bc2162..a6285e6323c2 100644
--- a/deskutils/google-gadgets/files/patch-extensions_gst__video__element_gst__video__element.cc
+++ b/deskutils/google-gadgets/files/patch-extensions_gst__video__element_gst__video__element.cc
@@ -3,7 +3,7 @@ $FreeBSD$
--- extensions/gst_video_element/gst_video_element.cc.orig
+++ extensions/gst_video_element/gst_video_element.cc
-@@ -127,7 +127,7 @@
+@@ -125,7 +125,7 @@
return;
} else {
g_object_get(G_OBJECT(videosink_),
@@ -12,7 +12,7 @@ $FreeBSD$
if (!receive_image_handler_) {
gst_object_unref(GST_OBJECT(playbin_));
gst_object_unref(GST_OBJECT(videosink_));
-@@ -137,7 +137,7 @@
+@@ -135,7 +135,7 @@
}
// Set videosink to receive video output.
@@ -21,7 +21,7 @@ $FreeBSD$
// Create new audio sink with panorama support if possible.
GstElement *audiosink = NULL;
-@@ -163,15 +163,15 @@
+@@ -161,15 +161,15 @@
GstElement *audiobin = gst_bin_new("audiobin");
GstPad *sinkpad;
if (volume_ && panorama_) {
@@ -41,7 +41,7 @@ $FreeBSD$
gst_element_link(panorama_, audiosink);
sinkpad = gst_element_get_pad(panorama_, "sink");
}
-@@ -181,7 +181,7 @@
+@@ -179,7 +179,7 @@
}
// Set audio-sink to our new audiosink.
@@ -50,17 +50,16 @@ $FreeBSD$
// Watch the message bus.
// The host using this class must use a g_main_loop to capture the
-@@ -361,7 +361,7 @@
+@@ -357,14 +357,14 @@
src_ = src;
media_changed_ = true;
- g_object_set(G_OBJECT(playbin_), "uri", src_.c_str(), NULL);
+ g_object_set(G_OBJECT(playbin_), "uri", src_.c_str(), (gchar*)0);
- if (GetAutoPlay())
- Play();
}
-@@ -370,7 +370,7 @@
- int GstVideoElement::GetVolume() {
+ }
+
+ int GstVideoElement::GetVolume() const {
if (playbin_) {
double volume;
- g_object_get(G_OBJECT(playbin_), "volume", &volume, NULL);
@@ -68,7 +67,7 @@ $FreeBSD$
int gg_volume = static_cast<int>((volume / kMaxGstVolume) *
(kMaxVolume - kMinVolume) + kMinVolume);
return Clamp(gg_volume, kMinVolume, kMaxVolume);
-@@ -387,7 +387,7 @@
+@@ -381,7 +381,7 @@
}
gdouble gg_volume = ((gdouble(volume - kMinVolume) /
(kMaxVolume - kMinVolume)) * kMaxGstVolume);
@@ -77,8 +76,8 @@ $FreeBSD$
} else {
DLOG("Playbin was not initialized correctly.");
}
-@@ -409,7 +409,7 @@
- int GstVideoElement::GetBalance() {
+@@ -403,7 +403,7 @@
+ int GstVideoElement::GetBalance() const {
if (playbin_ && panorama_) {
gfloat balance;
- g_object_get(G_OBJECT(panorama_), "panorama", &balance, NULL);
@@ -86,7 +85,7 @@ $FreeBSD$
int gg_balance = static_cast<int>(((balance + 1) / 2) *
(kMaxBalance - kMinBalance) +
kMinBalance);
-@@ -432,7 +432,7 @@
+@@ -426,7 +426,7 @@
}
gfloat gg_balance = (gfloat(balance - kMinBalance) /
(kMaxBalance - kMinBalance)) * 2 - 1;
@@ -95,8 +94,8 @@ $FreeBSD$
} else {
if (!playbin_)
DLOG("Playbin was not initialized correctly.");
-@@ -444,7 +444,7 @@
- bool GstVideoElement::GetMute() {
+@@ -438,7 +438,7 @@
+ bool GstVideoElement::IsMute() const {
if (playbin_ && volume_) {
gboolean mute;
- g_object_get(G_OBJECT(volume_), "mute", &mute, NULL);
@@ -104,7 +103,7 @@ $FreeBSD$
return static_cast<bool>(mute);
} else {
if (!playbin_)
-@@ -457,7 +457,7 @@
+@@ -451,7 +451,7 @@
void GstVideoElement::SetMute(bool mute) {
if (playbin_ && volume_) {
@@ -113,7 +112,7 @@ $FreeBSD$
} else {
if (!playbin_)
DLOG("Playbin was not initialized correctly.");
-@@ -470,7 +470,7 @@
+@@ -464,7 +464,7 @@
if (playbin_ && videosink_) {
g_object_set(G_OBJECT(videosink_),
"geometry-width", static_cast<int>(width),
diff --git a/deskutils/google-gadgets/files/patch-extensions_gtkmoz__browser__element_Makefile.am b/deskutils/google-gadgets/files/patch-extensions_gtkmoz__browser__element_Makefile.am
new file mode 100644
index 000000000000..945467a8b4eb
--- /dev/null
+++ b/deskutils/google-gadgets/files/patch-extensions_gtkmoz__browser__element_Makefile.am
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- extensions/gtkmoz_browser_element/Makefile.am.orig
++++ extensions/gtkmoz_browser_element/Makefile.am
+@@ -63,8 +63,7 @@
+ gtkmoz_browser_child_LDADD = @GTK2_LIBS@ \
+ @GTKMOZEMBED_LIBS@ \
+ $(top_builddir)/ggadget/js/libggadget-js@GGL_EPOCH@.la \
+- $(top_builddir)/ggadget/libggadget@GGL_EPOCH@.la \
+- -ldl
++ $(top_builddir)/ggadget/libggadget@GGL_EPOCH@.la
+
+ gtkmoz_browser_child_LDFLAGS = @GTKMOZEMBED_LDFLAGS@
+
diff --git a/deskutils/google-gadgets/files/patch-extensions_smjs__script__runtime_Makefile.am b/deskutils/google-gadgets/files/patch-extensions_smjs__script__runtime_Makefile.am
new file mode 100644
index 000000000000..5f1f78d70424
--- /dev/null
+++ b/deskutils/google-gadgets/files/patch-extensions_smjs__script__runtime_Makefile.am
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- extensions/smjs_script_runtime/Makefile.am.orig
++++ extensions/smjs_script_runtime/Makefile.am
+@@ -72,8 +72,7 @@
+ smjs_script_runtime_la_LIBADD = \
+ $(top_builddir)/ggadget/libggadget@GGL_EPOCH@.la \
+ libggadget-smjs.la \
+- $(LIBMOZJS_LIBS) \
+- -ldl
++ $(LIBMOZJS_LIBS)
+
+ smjs_script_runtime_la_LDFLAGS = \
+ -avoid-version \
diff --git a/deskutils/google-gadgets/files/patch-extensions_smjs__script__runtime_tests_Makefile.am b/deskutils/google-gadgets/files/patch-extensions_smjs__script__runtime_tests_Makefile.am
new file mode 100644
index 000000000000..4eb4a9c6ab85
--- /dev/null
+++ b/deskutils/google-gadgets/files/patch-extensions_smjs__script__runtime_tests_Makefile.am
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- extensions/smjs_script_runtime/tests/Makefile.am.orig
++++ extensions/smjs_script_runtime/tests/Makefile.am
+@@ -30,8 +30,7 @@
+ $(top_builddir)/ggadget/libggadget@GGL_EPOCH@.la \
+ $(top_builddir)/ggadget/js/libggadget-js@GGL_EPOCH@.la \
+ $(top_builddir)/third_party/editline/libeditline.la \
+- $(LIBMOZJS_LIBS) \
+- -ldl
++ $(LIBMOZJS_LIBS)
+
+ check_PROGRAMS = cross_context_test \
+ dom_test_shell \
diff --git a/deskutils/google-gadgets/files/patch-ggadget_npapi_Makefile.am b/deskutils/google-gadgets/files/patch-ggadget_npapi_Makefile.am
new file mode 100644
index 000000000000..fdf8bf2f96f2
--- /dev/null
+++ b/deskutils/google-gadgets/files/patch-ggadget_npapi_Makefile.am
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- ggadget/npapi/Makefile.am.orig
++++ ggadget/npapi/Makefile.am
+@@ -44,8 +44,7 @@
+
+ libggadget_npapi@GGL_EPOCH@_la_LIBADD = \
+ $(top_builddir)/ggadget/libggadget@GGL_EPOCH@.la \
+- $(X_LIBS) \
+- -ldl
++ $(X_LIBS)
+
+ libggadget_npapi@GGL_EPOCH@_la_LDFLAGS = \
+ -version-info $(LIBGGADGET_VERSION) \
diff --git a/deskutils/google-gadgets/pkg-plist b/deskutils/google-gadgets/pkg-plist
index dec41f450529..c156aacde1ed 100644
--- a/deskutils/google-gadgets/pkg-plist
+++ b/deskutils/google-gadgets/pkg-plist
@@ -48,6 +48,7 @@ include/google-gadgets/ggadget/graphics_interface.h
%%GTK%%include/google-gadgets/ggadget/gtk/key_convert.h
%%GTK%%include/google-gadgets/ggadget/gtk/main_loop.h
%%GTK%%include/google-gadgets/ggadget/gtk/menu_builder.h
+%%GTK%%include/google-gadgets/ggadget/gtk/npapi_plugin_element.h
%%GTK%%include/google-gadgets/ggadget/gtk/single_view_host.h
%%GTK%%include/google-gadgets/ggadget/gtk/tooltip.h
%%GTK%%include/google-gadgets/ggadget/gtk/utilities.h
@@ -72,6 +73,7 @@ include/google-gadgets/ggadget/memory_options.h
include/google-gadgets/ggadget/menu_interface.h
include/google-gadgets/ggadget/messages.h
include/google-gadgets/ggadget/module.h
+include/google-gadgets/ggadget/npapi/npapi_plugin.h
include/google-gadgets/ggadget/object_element.h
include/google-gadgets/ggadget/object_videoplayer.h
include/google-gadgets/ggadget/options_interface.h
@@ -96,6 +98,7 @@ include/google-gadgets/ggadget/scriptable_enumerator.h
include/google-gadgets/ggadget/scriptable_event.h
include/google-gadgets/ggadget/scriptable_file_system.h
include/google-gadgets/ggadget/scriptable_framework.h
+include/google-gadgets/ggadget/scriptable_function.h
include/google-gadgets/ggadget/scriptable_helper.h
include/google-gadgets/ggadget/scriptable_holder.h
include/google-gadgets/ggadget/scriptable_image.h
@@ -115,6 +118,7 @@ include/google-gadgets/ggadget/system_utils.h
include/google-gadgets/ggadget/text_frame.h
include/google-gadgets/ggadget/texture.h
include/google-gadgets/ggadget/unicode_utils.h
+include/google-gadgets/ggadget/usage_collector_interface.h
include/google-gadgets/ggadget/variant.h
include/google-gadgets/ggadget/video_element_base.h
include/google-gadgets/ggadget/view.h
@@ -127,11 +131,15 @@ include/google-gadgets/ggadget/xdg/utilities.h
include/google-gadgets/ggadget/xml_dom.h
include/google-gadgets/ggadget/xml_dom_interface.h
include/google-gadgets/ggadget/xml_http_request_interface.h
+include/google-gadgets/ggadget/xml_http_request_utils.h
include/google-gadgets/ggadget/xml_parser_interface.h
include/google-gadgets/ggadget/xml_utils.h
include/google-gadgets/ggadget/zip_file_manager.h
%%GTK%%lib/google-gadgets/gtkmoz-browser-child
lib/google-gadgets/include/ggadget/sysdeps.h
+lib/google-gadgets/modules/analytics-usage-collector.a
+lib/google-gadgets/modules/analytics-usage-collector.la
+lib/google-gadgets/modules/analytics-usage-collector.so
lib/google-gadgets/modules/curl-xml-http-request.a
lib/google-gadgets/modules/curl-xml-http-request.la
lib/google-gadgets/modules/curl-xml-http-request.so
@@ -156,6 +164,9 @@ lib/google-gadgets/modules/gst-video-element.so
%%GTK%%lib/google-gadgets/modules/gtk-edit-element.a
%%GTK%%lib/google-gadgets/modules/gtk-edit-element.la
%%GTK%%lib/google-gadgets/modules/gtk-edit-element.so
+%%GTK%%lib/google-gadgets/modules/gtk-flash-element.a
+%%GTK%%lib/google-gadgets/modules/gtk-flash-element.la
+%%GTK%%lib/google-gadgets/modules/gtk-flash-element.so
%%GTK%%lib/google-gadgets/modules/gtk-system-framework.a
%%GTK%%lib/google-gadgets/modules/gtk-system-framework.la
%%GTK%%lib/google-gadgets/modules/gtk-system-framework.so
@@ -199,6 +210,10 @@ lib/libggadget-js-1.0.a
lib/libggadget-js-1.0.la
lib/libggadget-js-1.0.so
lib/libggadget-js-1.0.so.0
+lib/libggadget-npapi-1.0.a
+lib/libggadget-npapi-1.0.la
+lib/libggadget-npapi-1.0.so
+lib/libggadget-npapi-1.0.so.0
%%QT%%lib/libggadget-qt-1.0.a
%%QT%%lib/libggadget-qt-1.0.la
%%QT%%lib/libggadget-qt-1.0.so
@@ -211,6 +226,7 @@ libdata/pkgconfig/libggadget-1.0.pc
libdata/pkgconfig/libggadget-dbus-1.0.pc
%%GTK%%libdata/pkgconfig/libggadget-gtk-1.0.pc
libdata/pkgconfig/libggadget-js-1.0.pc
+libdata/pkgconfig/libggadget-npapi-1.0.pc
%%QT%%libdata/pkgconfig/libggadget-qt-1.0.pc
libdata/pkgconfig/libggadget-xdg-1.0.pc
%%GTK%%share/applications/ggl-gtk.desktop
@@ -224,15 +240,15 @@ libdata/pkgconfig/libggadget-xdg-1.0.pc
%%DATADIR%%/resources.gg
%%DATADIR%%/rss.gg
share/icons/hicolor/128x128/apps/google-gadgets.png
-share/icons/hicolor/128x128/mimetypes/application-x-google-gadgets.png
+share/icons/hicolor/128x128/mimetypes/application-x-google-gadget.png
share/icons/hicolor/192x192/apps/google-gadgets.png
-share/icons/hicolor/192x192/mimetypes/application-x-google-gadgets.png
+share/icons/hicolor/192x192/mimetypes/application-x-google-gadget.png
share/icons/hicolor/32x32/apps/google-gadgets.png
-share/icons/hicolor/32x32/mimetypes/application-x-google-gadgets.png
+share/icons/hicolor/32x32/mimetypes/application-x-google-gadget.png
share/icons/hicolor/48x48/apps/google-gadgets.png
-share/icons/hicolor/48x48/mimetypes/application-x-google-gadgets.png
+share/icons/hicolor/48x48/mimetypes/application-x-google-gadget.png
share/icons/hicolor/64x64/apps/google-gadgets.png
-share/icons/hicolor/64x64/mimetypes/application-x-google-gadgets.png
+share/icons/hicolor/64x64/mimetypes/application-x-google-gadget.png
share/mime/packages/00-google-gadgets.xml
share/pixmaps/google-gadgets.png
@dirrm %%DATADIR%%
@@ -242,6 +258,7 @@ share/pixmaps/google-gadgets.png
@dirrm lib/google-gadgets
%%QT%%@dirrm include/google-gadgets/ggadget/qt
@dirrm include/google-gadgets/ggadget/js
+@dirrm include/google-gadgets/ggadget/npapi
@dirrm include/google-gadgets/ggadget/xdg
%%GTK%%@dirrm include/google-gadgets/ggadget/gtk
@dirrm include/google-gadgets/ggadget/dbus