aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/gtimer
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-01-01 02:03:28 +0800
committerpav <pav@FreeBSD.org>2006-01-01 02:03:28 +0800
commit1937ccf72196775694d45b59e7e9d0badb910a24 (patch)
tree146c559e87d2c3c4860fbc60a75e1310c79782d0 /deskutils/gtimer
parent7079f067695c717d6b479ba6610c4bfe5292a7af (diff)
downloadfreebsd-ports-gnome-1937ccf72196775694d45b59e7e9d0badb910a24.tar.gz
freebsd-ports-gnome-1937ccf72196775694d45b59e7e9d0badb910a24.tar.zst
freebsd-ports-gnome-1937ccf72196775694d45b59e7e9d0badb910a24.zip
- Switch to another tarball of 1.1.6 release on the author's new website
- Update WWW PR: ports/91108 Submitted by: Rainer Alves <rainer.alves@gmail.com>
Diffstat (limited to 'deskutils/gtimer')
-rw-r--r--deskutils/gtimer/Makefile5
-rw-r--r--deskutils/gtimer/distinfo6
-rw-r--r--deskutils/gtimer/files/patch-annotation14
-rw-r--r--deskutils/gtimer/files/patch-fix-version11
-rw-r--r--deskutils/gtimer/files/patch-gtk15
-rw-r--r--deskutils/gtimer/files/patch-malloc (renamed from deskutils/gtimer/files/patch-ab)0
-rw-r--r--deskutils/gtimer/pkg-descr4
7 files changed, 47 insertions, 8 deletions
diff --git a/deskutils/gtimer/Makefile b/deskutils/gtimer/Makefile
index 386de0ac3fa5..b0f6827174d7 100644
--- a/deskutils/gtimer/Makefile
+++ b/deskutils/gtimer/Makefile
@@ -9,13 +9,12 @@ PORTNAME= gtimer
PORTVERSION= 1.1.6
PORTREVISION= 1
CATEGORIES= deskutils
-MASTER_SITES= http://www.cknudsen.com/gtimer/
+MASTER_SITES= http://www.k5n.us/files/ \
+ http://www.cknudsen.com/gtimer/
MAINTAINER= ports@FreeBSD.org
COMMENT= A timer for your personal activities
-BROKEN= Size mismatch
-
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gtk12
diff --git a/deskutils/gtimer/distinfo b/deskutils/gtimer/distinfo
index 3b7c8fda23af..be95ae844a67 100644
--- a/deskutils/gtimer/distinfo
+++ b/deskutils/gtimer/distinfo
@@ -1,3 +1,3 @@
-MD5 (gtimer-1.1.6.tar.bz2) = 8acc1939abc5c3b25f400688f1d9b053
-SHA256 (gtimer-1.1.6.tar.bz2) = 24f41f3a2440aa375f87a770a1c32bbadcbabed80232af61d6c25086e2704f78
-SIZE (gtimer-1.1.6.tar.bz2) = 105135
+MD5 (gtimer-1.1.6.tar.bz2) = dd129daf0046ca4de05c67456989d226
+SHA256 (gtimer-1.1.6.tar.bz2) = 8e6738ddb02803a3af3af50ead427b7a08108fc3ff95cf8a4f8cf459a41e9727
+SIZE (gtimer-1.1.6.tar.bz2) = 98953
diff --git a/deskutils/gtimer/files/patch-annotation b/deskutils/gtimer/files/patch-annotation
new file mode 100644
index 000000000000..af29b538ea69
--- /dev/null
+++ b/deskutils/gtimer/files/patch-annotation
@@ -0,0 +1,14 @@
+--- annotate.c.orig Fri Dec 30 18:15:44 2005
++++ annotate.c Fri Dec 30 18:15:57 2005
+@@ -95,9 +95,9 @@
+ len = GTK_TEXT ( td->text )->gap_position;
+ str = (char *) malloc ( len + 1 );
+ #if GTK_VERSION < 10100
+- strncpy ( str, (char *) GTK_TEXT ( td->text )->text, len );
++ strncpy ( str, (char *) &GTK_TEXT ( td->text )->text, len );
+ #else
+- strncpy ( str, (char *) GTK_TEXT ( td->text )->text.wc, len );
++ strncpy ( str, (char *) &GTK_TEXT ( td->text )->text.wc, len );
+ #endif
+ str[len] = '\0';
+ if ( strlen ( str ) )
diff --git a/deskutils/gtimer/files/patch-fix-version b/deskutils/gtimer/files/patch-fix-version
new file mode 100644
index 000000000000..22e97ac67d4a
--- /dev/null
+++ b/deskutils/gtimer/files/patch-fix-version
@@ -0,0 +1,11 @@
+--- configure.orig Fri Dec 30 18:01:56 2005
++++ configure Fri Dec 30 18:02:16 2005
+@@ -701,7 +701,7 @@
+
+ PACKAGE=gtimer
+
+-VERSION=1.1.2
++VERSION=1.1.6
+
+ if test "`cd $srcdir && pwd`" != "`pwd`" && test -f $srcdir/config.status; then
+ { echo "configure: error: source directory already configured; run "make distclean" there first" 1>&2; exit 1; }
diff --git a/deskutils/gtimer/files/patch-gtk b/deskutils/gtimer/files/patch-gtk
new file mode 100644
index 000000000000..77ca4f1352a7
--- /dev/null
+++ b/deskutils/gtimer/files/patch-gtk
@@ -0,0 +1,15 @@
+--- main.c.orig Fri Dec 30 18:29:18 2005
++++ main.c Fri Dec 30 18:30:02 2005
+@@ -2455,10 +2455,12 @@
+ task_list = create_list_column_def ( 4, task_list_columns );
+ gtk_clist_set_selection_mode (GTK_CLIST (task_list), GTK_SELECTION_BROWSE);
+ gtk_widget_set_usize (GTK_WIDGET (task_list), 350, 150);
++/*
+ #if GTK_VERSION < 10100
+ gtk_clist_set_policy (GTK_CLIST (task_list),
+ GTK_POLICY_AUTOMATIC, GTK_POLICY_AUTOMATIC);
+ #endif
++*/
+ gtk_signal_connect (GTK_OBJECT (task_list), "click_column",
+ GTK_SIGNAL_FUNC (column_selected_callback), NULL);
+ gtk_signal_connect (GTK_OBJECT (task_list), "event",
diff --git a/deskutils/gtimer/files/patch-ab b/deskutils/gtimer/files/patch-malloc
index 0c9def9a13c0..0c9def9a13c0 100644
--- a/deskutils/gtimer/files/patch-ab
+++ b/deskutils/gtimer/files/patch-malloc
diff --git a/deskutils/gtimer/pkg-descr b/deskutils/gtimer/pkg-descr
index 0563eebe594d..508d5055ba74 100644
--- a/deskutils/gtimer/pkg-descr
+++ b/deskutils/gtimer/pkg-descr
@@ -1,6 +1,6 @@
gtimer is an application built with GTK that keeps track of all
your activities and the amount of time spent on those activities.
-Author: Craig Knudsen <cknudsen@radix.net>
+Author: Craig Knudsen <cknudsen@cknudsen.com>
-WWW: http://www.cknudsen.com/gtimer/
+WWW: http://www.k5n.us/gtimer.php