aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/horde-nag/Makefile
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-04-07 19:46:27 +0800
committersat <sat@FreeBSD.org>2007-04-07 19:46:27 +0800
commit1c02a5df7c3ae569cecd1184171bdabd55c5b757 (patch)
treeee689729ddc3232ad11924d2ab040d5b15cb278d /deskutils/horde-nag/Makefile
parentf713b0bd3fc4b89f54ad14577eade21e4a720fab (diff)
downloadfreebsd-ports-gnome-1c02a5df7c3ae569cecd1184171bdabd55c5b757.tar.gz
freebsd-ports-gnome-1c02a5df7c3ae569cecd1184171bdabd55c5b757.tar.zst
freebsd-ports-gnome-1c02a5df7c3ae569cecd1184171bdabd55c5b757.zip
- Remove apache cruft
- Assorted tweaks and updates - Bump portrevisions Submitted by: Beech Rintoul <beech@alaskaparadise.com> (maintainer)
Diffstat (limited to 'deskutils/horde-nag/Makefile')
-rw-r--r--deskutils/horde-nag/Makefile17
1 files changed, 6 insertions, 11 deletions
diff --git a/deskutils/horde-nag/Makefile b/deskutils/horde-nag/Makefile
index 79b6d2df37ed..8f0c055af8df 100644
--- a/deskutils/horde-nag/Makefile
+++ b/deskutils/horde-nag/Makefile
@@ -8,6 +8,7 @@
PORTNAME= nag
PORTVERSION= 2.1.3
DISTVERSIONPREFIX= h3-
+PORTREVISION= 1
CATEGORIES= deskutils www
MASTER_SITES= HORDE
@@ -17,7 +18,6 @@ COMMENT= Simple multiuser task list manager
RUN_DEPENDS= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde-base
NO_BUILD= yes
-USE_APACHE= 1.3+ # needed to test APACHE_VERSION
USE_GETTEXT= yes
PLIST_SUB= NAGDIR=${LNAGDIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
@@ -40,12 +40,6 @@ CONFDIR= ${NAGDIR}/config
.include <bsd.port.pre.mk>
-.if ${APACHE_VERSION} >= 20
-HORDE_INC= ${LOCALBASE}/etc/apache${APACHE_VERSION:S/20/2/}/Includes
-.else
-HORDE_INC= ${LOCALBASE}/etc/horde
-.endif
-
post-extract:
@${MV} ${WRKSRC}/README ${WRKSRC}/docs/
@@ -53,17 +47,18 @@ pre-configure:
@(cd ${WRKSRC}/scripts && \
${FIND} . -name "*.php" -exec \
${REINPLACE_CMD} -e "s:/usr/local/bin/php: ${LOCALBASE}/bin/php:;s:/usr/bin/php: ${LOCALBASE}/bin/php:" {} \; )
- @${SED} -e "s:/home/httpd/html/horde/nag:${NAGDIR}:g" \
- ${FILESDIR}/httpd.conf.nag > ${WRKDIR}/httpd-nag.conf
do-install:
@${INSTALL} -d ${NAGDIR}/
@${CP} -Rp ${SUB_DIRS:S|^|${WRKSRC}/|} ${NAGDIR}/
@${CP} -p ${WRKSRC}/*.php ${NAGDIR}/
@${INSTALL_DATA} ${WRKSRC}/config/conf.xml ${CONFDIR}/
- @${INSTALL_DATA} ${WRKDIR}/httpd-nag.conf ${HORDE_INC}/
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${NAGDIR}/
- @${CHMOD} -R o-rwx ${CONFDIR}/
+ @${CHMOD} -R o-rwx ${NAGDIR}/
+ ${ECHO_CMD} @exec ${CHOWN} -R ${WWWOWN}:${WWWGRP}\
+ %D/${NAGDIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
+ ${ECHO_CMD} @exec ${CHMOD} -R o-rwx\
+ %D/${NAGDIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
.if !defined(NOPORTDOCS)
@${INSTALL} -d ${DOCSDIR}/
@${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${DOCSDIR}/