aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/kbirthday
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2005-01-10 00:51:33 +0800
committerarved <arved@FreeBSD.org>2005-01-10 00:51:33 +0800
commitf4a6b785f3ebfc1d86f315214fb4de368b56dbf8 (patch)
treeda121c97a2e17e9cd64d56f0afa262d79fbce876 /deskutils/kbirthday
parentd2b4e98fb4db5497c834382562bd49ee0bb8d057 (diff)
downloadfreebsd-ports-gnome-f4a6b785f3ebfc1d86f315214fb4de368b56dbf8.tar.gz
freebsd-ports-gnome-f4a6b785f3ebfc1d86f315214fb4de368b56dbf8.tar.zst
freebsd-ports-gnome-f4a6b785f3ebfc1d86f315214fb4de368b56dbf8.zip
Fix build on amd64 by using -fPIC to build the applet.
PR: 75982 Reported by: Heiner Eichmann <h.eichmann@gmx.de>
Diffstat (limited to 'deskutils/kbirthday')
-rw-r--r--deskutils/kbirthday/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/deskutils/kbirthday/Makefile b/deskutils/kbirthday/Makefile
index 32ae2a684684..b7438e20d796 100644
--- a/deskutils/kbirthday/Makefile
+++ b/deskutils/kbirthday/Makefile
@@ -16,6 +16,7 @@ COMMENT= KDE kicker-applet that reminds you of birthdays and anniversaries
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_KDELIBS_VER=3
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_INC_LIBTOOL_VER= 13
# may or may not solve the alpha compilation issue....
@@ -24,4 +25,7 @@ CONFIGURE_ARGS= --with-pic
# necesary to access the second master site by getting rid of the default switch -A
FETCH_CMD ?=/usr/bin/fetch -Rr
+post-patch:
+ ${REINPLACE_CMD} -e "s,-Wmissing-prototypes,-fPIC," ${WRKSRC}/configure
+
.include <bsd.port.mk>