aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/kchmviewer
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-03-31 19:18:02 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2017-03-31 19:18:02 +0800
commitea0efaa5df12f958733c369c0951ed82170777a7 (patch)
tree21b8fa837805a986178562de7f0103138cccff4f /deskutils/kchmviewer
parentb9f3ab56bf6ca36247f4d50fde8f34dca6118c92 (diff)
downloadfreebsd-ports-gnome-ea0efaa5df12f958733c369c0951ed82170777a7.tar.gz
freebsd-ports-gnome-ea0efaa5df12f958733c369c0951ed82170777a7.tar.zst
freebsd-ports-gnome-ea0efaa5df12f958733c369c0951ed82170777a7.zip
Update deskutils/kchmviewer to 7.7 and take maintainership.
Reviewed by: mat, rakuco Approved by: rakuco (mentor), mat (mentor) Differential Revision: https://reviews.freebsd.org/D10190
Diffstat (limited to 'deskutils/kchmviewer')
-rw-r--r--deskutils/kchmviewer/Makefile20
-rw-r--r--deskutils/kchmviewer/distinfo3
-rw-r--r--deskutils/kchmviewer/files/patch-src_src.pro65
-rw-r--r--deskutils/kchmviewer/pkg-descr11
-rw-r--r--deskutils/kchmviewer/pkg-plist3
5 files changed, 102 insertions, 0 deletions
diff --git a/deskutils/kchmviewer/Makefile b/deskutils/kchmviewer/Makefile
new file mode 100644
index 000000000000..8cfeaa739491
--- /dev/null
+++ b/deskutils/kchmviewer/Makefile
@@ -0,0 +1,20 @@
+# Created by: Markus Brueffer <markus@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= kchmviewer
+PORTVERSION= 7.7
+CATEGORIES= deskutils kde
+MASTER_SITES= SF
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE viewer for CHM files
+
+LIB_DEPENDS= libchm.so:misc/chmlib \
+ libzip.so:archivers/libzip
+
+USES= dos2unix qmake:outsource
+USE_QT5= core dbus gui network printsupport webkit widgets xml \
+ buildtools_build qmake_build
+USE_XORG= x11
+
+.include <bsd.port.mk>
diff --git a/deskutils/kchmviewer/distinfo b/deskutils/kchmviewer/distinfo
new file mode 100644
index 000000000000..e3a6ccad7695
--- /dev/null
+++ b/deskutils/kchmviewer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1490818978
+SHA256 (kchmviewer-7.7.tar.gz) = 27cbac45c786b1718550a87e6f86010e161302b426c6396ff2a3091b913b17dd
+SIZE (kchmviewer-7.7.tar.gz) = 345952
diff --git a/deskutils/kchmviewer/files/patch-src_src.pro b/deskutils/kchmviewer/files/patch-src_src.pro
new file mode 100644
index 000000000000..168d09062aaa
--- /dev/null
+++ b/deskutils/kchmviewer/files/patch-src_src.pro
@@ -0,0 +1,65 @@
+This patch contains the following (by hunks)
+ 1) also link against libX11 on FreeBSD
+ 2) this is obtained from arch, to fix underlinking
+ and
+ remove the wrong Qt5 version check
+ 4) create installation targets
+
+--- src/src.pro.orig 2017-03-29 21:21:13 UTC
++++ src/src.pro
+@@ -67,7 +67,7 @@ QT += webkit \
+ webkitwidgets \
+ printsupport
+
+-linux-g++*:{
++unix:{
+ LIBS += -lX11
+ }
+
+@@ -108,26 +108,16 @@ unix:!macx: {
+ HEADERS += dbus_interface.h
+ SOURCES += dbus_interface.cpp
+ CONFIG += dbus
+- LIBS += ../lib/libebook/libebook.a
++ LIBS += ../lib/libebook/libebook.a -lchm -lzip
+ POST_TARGETDEPS += ../lib/libebook/libebook.a
+ }
+
+ greaterThan(QT_MAJOR_VERSION, 4) {
+ # Qt 5
+- greaterThan(QT_MINOR_VERSION, 5) {
+- # Qt 5.6+
+- error("You use Qt5.6+ - QWebEngine is not yet suitable for kchmviewer and is not supported")
+- QT += webengine webenginewidgets
+- DEFINES += USE_WEBENGINE
+- SOURCES += viewwindow_webengine.cpp dataprovider_qwebengine.cpp
+- HEADERS += dataprovider_qwebengine.h viewwindow_webengine.h
+- } else {
+- # Qt 5.0-5.5
+- QT += webkit webkitwidgets
+- DEFINES += USE_WEBKIT
+- SOURCES += viewwindow_webkit.cpp dataprovider_qwebkit.cpp
+- HEADERS += dataprovider_qwebkit.h viewwindow_webkit.h
+- }
++ QT += webkit webkitwidgets
++ DEFINES += USE_WEBKIT
++ SOURCES += viewwindow_webkit.cpp dataprovider_qwebkit.cpp
++ HEADERS += dataprovider_qwebkit.h viewwindow_webkit.h
+ } else {
+ message("Qt4 is not supported anymore, please do not report any errors")
+ QT += webkit webkitwidgets
+@@ -135,3 +125,14 @@ greaterThan(QT_MAJOR_VERSION, 4) {
+ SOURCES += viewwindow_webkit.cpp dataprovider_qwebkit.cpp
+ HEADERS += dataprovider_qwebkit.h viewwindow_webkit.h
+ }
++
++# Define installation target for the binary
++target.path = $$PREFIX/bin
++# ... and for the icon
++icons.files = ../packages/kchmviewer.png
++icons.path = $$PREFIX/share/pixmaps
++# ... and the desktop file
++desktop.files = ../packages/kchmviewer.desktop
++desktop.path = $$PREFIX/share/applications
++
++INSTALLS += desktop icons target
diff --git a/deskutils/kchmviewer/pkg-descr b/deskutils/kchmviewer/pkg-descr
new file mode 100644
index 000000000000..024ef4d9f03c
--- /dev/null
+++ b/deskutils/kchmviewer/pkg-descr
@@ -0,0 +1,11 @@
+KchmViewer is a chm (MS HTML help file format) viewer. Unlike most existing
+CHM viewers for Unix, it uses Trolltech's Qt widget library, and does not
+depend on KDE or Gnome. However, it may be compiled with full KDE support,
+including KDE widgets and KIO/KHTML.
+
+The main advantage of KchmViewer is non-english language support. Unlike
+others, KchmViewer in most cases correctly detects help file encoding,
+correctly shows tables of context of russian, korean, chinese and japanese
+help files, and correctly searches in non-english help files.
+
+WWW: http://www.kchmviewer.net/
diff --git a/deskutils/kchmviewer/pkg-plist b/deskutils/kchmviewer/pkg-plist
new file mode 100644
index 000000000000..37ff10dba463
--- /dev/null
+++ b/deskutils/kchmviewer/pkg-plist
@@ -0,0 +1,3 @@
+bin/kchmviewer
+share/applications/kchmviewer.desktop
+share/pixmaps/kchmviewer.png