aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/logjam/Makefile
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-12-12 02:28:10 +0800
committerbapt <bapt@FreeBSD.org>2013-12-12 02:28:10 +0800
commitc92a1d710a8c7b838b79efadc8de3afc045005df (patch)
treef84adaddc0b7a4395bdc34d83a623d5052d2e8b9 /deskutils/logjam/Makefile
parent1d82eadcbe5ef4af4b2dfc8ccc40afc52604f8fe (diff)
downloadfreebsd-ports-gnome-c92a1d710a8c7b838b79efadc8de3afc045005df.tar.gz
freebsd-ports-gnome-c92a1d710a8c7b838b79efadc8de3afc045005df.tar.zst
freebsd-ports-gnome-c92a1d710a8c7b838b79efadc8de3afc045005df.zip
In preparation for making libtool generate libraries with a sane name, fix all
LIB_DEPENDS in deskutils
Diffstat (limited to 'deskutils/logjam/Makefile')
-rw-r--r--deskutils/logjam/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/deskutils/logjam/Makefile b/deskutils/logjam/Makefile
index 8d47778ff12f..bdb7c83ce3d9 100644
--- a/deskutils/logjam/Makefile
+++ b/deskutils/logjam/Makefile
@@ -10,8 +10,8 @@ MASTER_SITES= http://andy-shev.github.com/LogJam/download/
MAINTAINER= novel@FreeBSD.org
COMMENT= A GTK2 interface to livejournals, ie www.livejournal.com
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
MAN1= logjam.1
@@ -26,18 +26,18 @@ CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CPPFLAGS+= -I${LOCALBASE}/include
.ifndef(WITHOUT_GTKSPELL)
-LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell
+LIB_DEPENDS+= libgtkspell.so:${PORTSDIR}/textproc/gtkspell
.else
CONFIGURE_ARGS+= --without-gtkspell
.endif
.if defined(WITH_SQLITE)
CONFIGURE_ARGS+= --with-sqlite3
-LIB_DEPENDS+= sqlite3.8:${PORTSDIR}/databases/sqlite3
+LIB_DEPENDS+= libsqlite3.so:${PORTSDIR}/databases/sqlite3
.endif
.if defined(WITH_XMMS)
-LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
+LIB_DEPENDS+= libxmms.so:${PORTSDIR}/multimedia/xmms
PLIST_SUB+= WITH_XMMS=""
.else
PLIST_SUB+= WITH_XMMS="@comment "