aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/lumina-fm/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-09-25 00:40:59 +0800
committerKurt Jaeger <pi@FreeBSD.org>2019-09-25 00:40:59 +0800
commitb19a38580a894f06ad087766e5d025f68f276ee2 (patch)
treeb303ac14e7dfc81d08f781e771042fbc2ef0e240 /deskutils/lumina-fm/Makefile
parent30c68d06d0e2ce469d261b0c6108f99f88496ab5 (diff)
downloadfreebsd-ports-gnome-b19a38580a894f06ad087766e5d025f68f276ee2.tar.gz
freebsd-ports-gnome-b19a38580a894f06ad087766e5d025f68f276ee2.tar.zst
freebsd-ports-gnome-b19a38580a894f06ad087766e5d025f68f276ee2.zip
x11/lumina: upgrade 1.4.1 -> 1.5.0
- Remove deskutils/lumina-notify (upstreamed) https://github.com/lumina-desktop/lumina/commit/89ad0095d7da09158778b5afae9beeaa0bd98d38 - Remove deskutils/lumina-xdg-entry (upstreamed) https://github.com/lumina-desktop/lumina/commit/0069a052e1cbef588e8f93a31314965b0c2af68a - Fix variables order (pet portlint) - Alphabetize USE_QT - Update knob to use options helpers - Remove GH_TAGNAME (except for deskutils/lumina-pdf and deskutils/lumina-calculator which haven't release tag) - Change GH_ACCOUNT from "trueos" to "lumina-desktop" - Add a new port deskutils/lumina-photo - Change I18N option to well know NLS option PR: 240749 Submitted by: Loic Bartoletti <lbartoletti@tuxfamily.org> Approved by: JT Pennington <jt@ixsystems.com> (maintainer) Differential Revision: D21749
Diffstat (limited to 'deskutils/lumina-fm/Makefile')
-rw-r--r--deskutils/lumina-fm/Makefile37
1 files changed, 13 insertions, 24 deletions
diff --git a/deskutils/lumina-fm/Makefile b/deskutils/lumina-fm/Makefile
index ad8e757f8f6b..d9c18ecd8646 100644
--- a/deskutils/lumina-fm/Makefile
+++ b/deskutils/lumina-fm/Makefile
@@ -1,41 +1,30 @@
-# Created by: Ken Moore <ken@pcbsd.org>
# $FreeBSD$
PORTNAME= lumina-fm
-PORTVERSION= 1.4.1
-PORTREVISION= 3
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.5.0
CATEGORIES= deskutils
MAINTAINER= jt@ixsystems.com
COMMENT= Insight file manager from the Lumina Desktop
LICENSE= BSD3CLAUSE
-LICENSE_FILE= ${WRKSRC}/../../../LICENSE
-CONFLICTS_INSTALL= lumina-1.2.*
-
-OPTIONS_DEFINE= I18N
-OPTIONS_DEFAULT= I18N
-OPTIONS_SUB= yes
-
-I18N_DESC= Install localization files
+USES= qmake qt:5
+USE_QT= buildtools_build concurrent core gui imageformats \
+ multimedia network svg widgets x11extras
+USE_GITHUB= yes
+GH_ACCOUNT= lumina-desktop
+GH_PROJECT= lumina
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
-MAKE_JOBS_UNSAFE=yes
+CONFLICTS_INSTALL= lumina-1.2.*
-USE_QT= core gui widgets network svg imageformats \
- buildtools_build x11extras multimedia concurrent
-USES= compiler:c++11-lang qmake qt:5
-USE_GITHUB= yes
-GH_ACCOUNT= trueos
-GH_PROJECT= lumina
-GH_TAGNAME= b6536c1547571ae8dd0618bed752e2e0025bf2a7
WRKSRC_SUBDIR= src-qt5/desktop-utils/${PORTNAME}
-.if${PORT_OPTIONS:MI18N}
-USE_QT+= linguisttools_build
-QMAKE_ARGS+=CONFIG+=WITH_I18N
-.endif
+NLS_USE= QT=linguist_build
+NLS_QMAKE_ON= CONFIG+=WITH_I18N
.include <bsd.port.mk>