aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/lumina-textedit/Makefile
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
committertcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
commit2a8bcfc8ea71d4438b926a8adc477de360863145 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /deskutils/lumina-textedit/Makefile
parent62341874a942de5989d54a3ba471cb8719d251ee (diff)
downloadfreebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.gz
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.zst
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Diffstat (limited to 'deskutils/lumina-textedit/Makefile')
-rw-r--r--deskutils/lumina-textedit/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/deskutils/lumina-textedit/Makefile b/deskutils/lumina-textedit/Makefile
index 795aaa7cbe18..6e4fb37965a2 100644
--- a/deskutils/lumina-textedit/Makefile
+++ b/deskutils/lumina-textedit/Makefile
@@ -23,9 +23,9 @@ I18N_DESC= Install localization files
MAKE_JOBS_UNSAFE=yes
-USE_QT5= core gui widgets network svg printsupport \
+USE_QT= core gui widgets network svg printsupport \
buildtools_build x11extras concurrent multimedia
-USES= qmake
+USES= qmake qt:5
USE_GITHUB= yes
GH_ACCOUNT= trueos
GH_PROJECT= lumina
@@ -33,7 +33,7 @@ GH_TAGNAME= b6536c1547571ae8dd0618bed752e2e0025bf2a7
WRKSRC_SUBDIR= src-qt5/desktop-utils/${PORTNAME}
.if${PORT_OPTIONS:MI18N}
-USE_QT5+= linguist_build
+USE_QT+= linguist_build
QMAKE_ARGS+=CONFIG+=WITH_I18N
.endif