aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/lumina-textedit/Makefile
diff options
context:
space:
mode:
authorkmoore <kmoore@FreeBSD.org>2017-09-19 01:45:33 +0800
committerkmoore <kmoore@FreeBSD.org>2017-09-19 01:45:33 +0800
commitc2aa798212cb4ee3e7476f2f44e9fa3ebb7195f6 (patch)
treee483dd11edb92e6b6065f8eb1bd03c15af8cbf72 /deskutils/lumina-textedit/Makefile
parent9e9971df47b87a39f55a046c741ca56e0341c5d6 (diff)
downloadfreebsd-ports-gnome-c2aa798212cb4ee3e7476f2f44e9fa3ebb7195f6.tar.gz
freebsd-ports-gnome-c2aa798212cb4ee3e7476f2f44e9fa3ebb7195f6.tar.zst
freebsd-ports-gnome-c2aa798212cb4ee3e7476f2f44e9fa3ebb7195f6.zip
- Update x11/lumina to 1.3.0
- Bring in Lumina utilities as their own ports PR: 220387 Submitted by: Ken Moore <ken@pcbsd.org> Sponsored by: iXsystems
Diffstat (limited to 'deskutils/lumina-textedit/Makefile')
-rw-r--r--deskutils/lumina-textedit/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/deskutils/lumina-textedit/Makefile b/deskutils/lumina-textedit/Makefile
new file mode 100644
index 000000000000..8635eb5ea255
--- /dev/null
+++ b/deskutils/lumina-textedit/Makefile
@@ -0,0 +1,37 @@
+# Created by: Ken Moore <ken@pcbsd.org>
+# $FreeBSD$
+
+PORTNAME= lumina-textedit
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.3.0-p1
+CATEGORIES= deskutils
+
+MAINTAINER= kmoore@FreeBSD.org
+COMMENT= Plaintext editor from the Lumina Desktop
+
+LICENSE= BSD3CLAUSE
+
+CONFLICTS_INSTALL= lumina-1.2.*
+
+OPTIONS_DEFINE= I18N
+OPTIONS_DEFAULT= I18N
+I18N_DESC= Install localization files
+
+.include <bsd.port.options.mk>
+
+MAKE_JOBS_UNSAFE=yes
+
+USE_QT5= core gui widgets network svg \
+ buildtools_build x11extras concurrent multimedia
+USES= desktop-file-utils qmake
+USE_GITHUB= yes
+GH_ACCOUNT= trueos
+GH_PROJECT= lumina
+WRKSRC_SUBDIR= src-qt5/desktop-utils/${PORTNAME}
+
+.if${PORT_OPTIONS:MI18N}
+USE_QT5+= linguist_build
+QMAKE_ARGS+=CONFIG+=WITH_I18N
+.endif
+
+.include <bsd.port.mk>