aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/mdh/Makefile
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-10-10 18:28:04 +0800
committergarga <garga@FreeBSD.org>2005-10-10 18:28:04 +0800
commit292c5a198ec09f2438914c0a4436f6c732033345 (patch)
treea479d05d359b095edd28ea853e74285aa132daec /deskutils/mdh/Makefile
parent26e02c1c89edb3446c4543026be1215e338eeec7 (diff)
downloadfreebsd-ports-gnome-292c5a198ec09f2438914c0a4436f6c732033345.tar.gz
freebsd-ports-gnome-292c5a198ec09f2438914c0a4436f6c732033345.tar.zst
freebsd-ports-gnome-292c5a198ec09f2438914c0a4436f6c732033345.zip
- Update to 1.9.59
PR: ports/87056 Submitted by: Ports Fury
Diffstat (limited to 'deskutils/mdh/Makefile')
-rw-r--r--deskutils/mdh/Makefile39
1 files changed, 32 insertions, 7 deletions
diff --git a/deskutils/mdh/Makefile b/deskutils/mdh/Makefile
index 5c905923dde0..3a66a7eb12ac 100644
--- a/deskutils/mdh/Makefile
+++ b/deskutils/mdh/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mdh
-PORTVERSION= 1.9.54
-PORTREVISION= 7
+PORTVERSION= 1.9.59
CATEGORIES= deskutils gnome
MASTER_SITES= http://www.gozer.org/my_stuff/gtk/gtk/mdh/
@@ -16,13 +15,39 @@ COMMENT= GTK2-based toolbar, like a smaller GNOME panel
USE_BZIP2= yes
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
USE_GNOME= gnometarget gtk20
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+USE_GETOPT_LONG= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+.if defined(WITHOUT_GTOP)
+CONFIGURE_ARGS+= --disable-gtop
+.else
+LIB_DEPENDS+= gtop-2.0:${PORTSDIR}/devel/libgtop2
+.endif
+
+.if defined(WITHOUT_CURL)
+CONFIGURE_ARGS+= --disable-curl
+.else
+LIB_DEPENDS+= curl.3:${PORTSDIR}/ftp/curl
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's| make| $$(MAKE)|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|\.\./lib/getopt/getopt\.c||g ; \
+ s|\.\./lib/getopt/getopt1\.c||g ; \
+ s|-I../lib/getopt||g ; \
+ s|$$(CC) -g|$$(CC)|g ; \
+ s|@INSTALL@ -m 0775|@INSTALL_PROGRAM@|g ; \
+ s|cp -p|@INSTALL_DATA@|g' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|"getopt\.h"|<getopt.h>|g' ${WRKSRC}/src/mdh.c
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
+post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}