aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/mdh/Makefile
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2003-11-13 06:11:12 +0800
committeradamw <adamw@FreeBSD.org>2003-11-13 06:11:12 +0800
commit66e9fd679fe2afc990a1f4e3c7f2674fcaf9a799 (patch)
tree21705433f965318834d337deba0a8cf90187b996 /deskutils/mdh/Makefile
parentf8cd734dde97a2b057b4066bf10960539bb0ce03 (diff)
downloadfreebsd-ports-gnome-66e9fd679fe2afc990a1f4e3c7f2674fcaf9a799.tar.gz
freebsd-ports-gnome-66e9fd679fe2afc990a1f4e3c7f2674fcaf9a799.tar.zst
freebsd-ports-gnome-66e9fd679fe2afc990a1f4e3c7f2674fcaf9a799.zip
Add mdh, which is kindof like the GNOME panel except not.
Diffstat (limited to 'deskutils/mdh/Makefile')
-rw-r--r--deskutils/mdh/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/deskutils/mdh/Makefile b/deskutils/mdh/Makefile
new file mode 100644
index 000000000000..c56bdbf518db
--- /dev/null
+++ b/deskutils/mdh/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: mdh
+# Date created: 12 November 2003
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mdh
+PORTVERSION= 1.9.54
+CATEGORIES= deskutils gnome
+MASTER_SITES= http://www.gozer.org/my_stuff/gtk/gtk/mdh/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= GTK2-based toolbar, sortof a gnomepanel replacement sortof
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_GNOME= gnomehack gnomeprefix gnometarget gtk20
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|<wait.h>|<sys/wait.h>|" \
+ ${WRKSRC}/src/mdh.c ${WRKSRC}/src/mdh_panel_temp.c
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DATADIR}
+.endif
+
+.include <bsd.port.mk>