aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/note
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2018-04-15 19:10:28 +0800
committerkrion <krion@FreeBSD.org>2018-04-15 19:10:28 +0800
commitfaf16d245e74d2ae0892bf05d5d5780691df6e7e (patch)
tree06ac17774e9d9d87975c0a2fdee966153cfe604e /deskutils/note
parent8a4d6b7aa9c035e5a459fe626dac169e489c741e (diff)
downloadfreebsd-ports-gnome-faf16d245e74d2ae0892bf05d5d5780691df6e7e.tar.gz
freebsd-ports-gnome-faf16d245e74d2ae0892bf05d5d5780691df6e7e.tar.zst
freebsd-ports-gnome-faf16d245e74d2ae0892bf05d5d5780691df6e7e.zip
Update to version 1.3.22
Pass maintainership to submitter as agreed with previous maintainer PR: 227298 Submitted by: Alexandre C. GuimarĂ£es <lebarondemerde@privacychain.ch> Approved by: idefix@fechner.net
Diffstat (limited to 'deskutils/note')
-rw-r--r--deskutils/note/Makefile40
-rw-r--r--deskutils/note/distinfo5
-rw-r--r--deskutils/note/pkg-descr9
-rw-r--r--deskutils/note/pkg-plist18
4 files changed, 54 insertions, 18 deletions
diff --git a/deskutils/note/Makefile b/deskutils/note/Makefile
index 245e97fc7599..180839351579 100644
--- a/deskutils/note/Makefile
+++ b/deskutils/note/Makefile
@@ -1,20 +1,52 @@
# $FreeBSD$
PORTNAME= note
-PORTVERSION= 1.3.18
-PORTREVISION= 2
+DISTVERSION= 1.3.22
CATEGORIES= deskutils perl5
MASTER_SITES= http://www.daemon.de/idisk/Apps/note/
-MAINTAINER= idefix@fechner.net
+MAINTAINER= lebarondemerde@privacychain.ch
COMMENT= Console based tool to handle encrypted notes
LICENSE= GPLv1
RUN_DEPENDS= p5-YAML>=0.1:textproc/p5-YAML \
- p5-Crypt-IDEA>=1.0:security/p5-Crypt-IDEA
+ p5-Config-General>0:devel/p5-Config-General
USES= perl5
USE_PERL5= configure
+OPTIONS_DEFINE= MYSQL PWSAFE3
+OPTIONS_DEFAULT= BLOWFISH DES IDEA MYSQL PWSAFE3
+
+MYSQL_RUN_DEPENDS= p5-DBD-mysql>0:databases/p5-DBD-mysql \
+ p5-DBI>0:databases/p5-DBI
+
+PWSAFE3_DESC= Password Safe v3 backend
+PWSAFE3_RUN_DEPENDS= p5-Crypt-PWSafe3>0:security/p5-Crypt-PWSafe3
+
+OPTIONS_GROUP= CRYPTO
+OPTIONS_GROUP_CRYPTO= DES IDEA BLOWFISH
+
+CRYPTO_DESC= Encryption support
+CRYPTO_RUN_DEPENDS= p5-Crypt-CBC>0:security/p5-Crypt-CBC \
+ p5-Crypt-Rijndael>0:security/p5-Crypt-Rijndael
+
+BLOWFISH_DESC= BlowFish block cipher support
+BLOWFISH_RUN_DEPENDS= p5-Crypt-Blowfish>0:security/p5-Crypt-Blowfish
+
+DES_DESC= DES block cipher support
+DES_RUN_DEPENDS= p5-Crypt-DES>0:security/p5-Crypt-DES
+
+IDEA_DESC= IDEA block cipher support
+IDEA_RUN_DEPENDS= p5-Crypt-IDEA>0:security/p5-Crypt-IDEA
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|{{(|{\\{(|g' \
+ ${WRKSRC}/bin/note
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/config && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
+
.include <bsd.port.mk>
diff --git a/deskutils/note/distinfo b/deskutils/note/distinfo
index c3f3529dff91..41ebe6dd7c8d 100644
--- a/deskutils/note/distinfo
+++ b/deskutils/note/distinfo
@@ -1,2 +1,3 @@
-SHA256 (note-1.3.18.tar.gz) = ba3b4db2709ce4e662b205254dfc83a27ff6912316e80a8ed1e3b52a14847071
-SIZE (note-1.3.18.tar.gz) = 52108
+TIMESTAMP = 1522908300
+SHA256 (note-1.3.22.tar.gz) = d8821168ca6266c443d01a286ba3f410c8330d55abf9f9a993ea8950eeb31478
+SIZE (note-1.3.22.tar.gz) = 52827
diff --git a/deskutils/note/pkg-descr b/deskutils/note/pkg-descr
index dce9427b9bdc..8c2ccd83c0fc 100644
--- a/deskutils/note/pkg-descr
+++ b/deskutils/note/pkg-descr
@@ -1,5 +1,6 @@
-This is a small console program written in
-perl, which allows you to manage notes similar
-to programs like "knotes" from commandline.
+Console based tool to handle encrypted notes
-WWW: http://www.daemon.de/NOTE
+This is a small console program written in perl, which allows you to manage
+notes similar to programs like "knotes" from command line.
+
+WWW: https://www.daemon.de/NOTE
diff --git a/deskutils/note/pkg-plist b/deskutils/note/pkg-plist
index 0cf617f44de9..267076f229a3 100644
--- a/deskutils/note/pkg-plist
+++ b/deskutils/note/pkg-plist
@@ -1,12 +1,4 @@
bin/note
-%%PERL5_MAN3%%/NOTEDB::binary.3.gz
-%%PERL5_MAN3%%/NOTEDB::dbm.3.gz
-%%PERL5_MAN3%%/NOTEDB::dumper.3.gz
-%%PERL5_MAN3%%/NOTEDB::general.3.gz
-%%PERL5_MAN3%%/NOTEDB::mysql.3.gz
-%%PERL5_MAN3%%/NOTEDB::pwsafe3.3.gz
-%%PERL5_MAN3%%/NOTEDB::text.3.gz
-%%PERL5_MAN3%%/note.3.gz
%%SITE_PERL%%/NOTEDB.pm
%%SITE_PERL%%/NOTEDB/README
%%SITE_PERL%%/NOTEDB/binary.pm
@@ -16,4 +8,14 @@ bin/note
%%SITE_PERL%%/NOTEDB/mysql.pm
%%SITE_PERL%%/NOTEDB/pwsafe3.pm
%%SITE_PERL%%/NOTEDB/text.pm
+%%PERL5_MAN3%%/NOTEDB::binary.3.gz
+%%PERL5_MAN3%%/NOTEDB::dbm.3.gz
+%%PERL5_MAN3%%/NOTEDB::dumper.3.gz
+%%PERL5_MAN3%%/NOTEDB::general.3.gz
+%%PERL5_MAN3%%/NOTEDB::mysql.3.gz
+%%PERL5_MAN3%%/NOTEDB::pwsafe3.3.gz
+%%PERL5_MAN3%%/NOTEDB::text.3.gz
+%%PERL5_MAN3%%/note.3.gz
%%SITE_PERL%%/note.pod
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/noterc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rc