aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/treeline
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2013-07-11 03:41:30 +0800
committerpawel <pawel@FreeBSD.org>2013-07-11 03:41:30 +0800
commit4682c2c61dcb7a63ae78f7c087ba5d0bda84f154 (patch)
treef00883f68004a81b9e525ad5cc94de309898b666 /deskutils/treeline
parent31dd4fd824aafa89c7f4eb95e23f32974c053110 (diff)
downloadfreebsd-ports-gnome-4682c2c61dcb7a63ae78f7c087ba5d0bda84f154.tar.gz
freebsd-ports-gnome-4682c2c61dcb7a63ae78f7c087ba5d0bda84f154.tar.zst
freebsd-ports-gnome-4682c2c61dcb7a63ae78f7c087ba5d0bda84f154.zip
Convert my ports to current standards
- Switch USE_GMAKE to USES=gmake - Define supported options so users can see them in config dialogs - Use OPTIONS_SUB for plist alteration - Convert to options macros for better readability - Use PORTDOCS where it makes sense
Diffstat (limited to 'deskutils/treeline')
-rw-r--r--deskutils/treeline/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/deskutils/treeline/Makefile b/deskutils/treeline/Makefile
index f8c3b4a1a643..f6c55034ac14 100644
--- a/deskutils/treeline/Makefile
+++ b/deskutils/treeline/Makefile
@@ -39,16 +39,12 @@ ISPELL_DESC= Install with ispell support
PYXML_DESC= Use pythons py-xml instead of textproc/expat2
OPTIONS_DEFAULT= ASPELL PYXML
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MASPELL}
-BUILD_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
-.endif
+ASPELL_BUILD_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
+ISPELL_BUILD_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
-.if ${PORT_OPTIONS:MISPELL}
-BUILD_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
-.endif
+.include <bsd.port.options.mk>
.if !${PORT_OPTIONS:MPYXML}
LIB_DEPENDS+= expat:${PORTSDIR}/textproc/expat2
@@ -56,9 +52,6 @@ LIB_DEPENDS+= expat:${PORTSDIR}/textproc/expat2
.if ${PORT_OPTIONS:MHTTPLOAD}
DISTFILES+= httpload2.py:plugins
-PLIST_SUB+= HTTPLOAD=""
-.else
-PLIST_SUB+= HTTPLOAD="@comment "
.endif
do-install: