aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/xfce4-notifyd/Makefile
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2016-07-30 20:51:17 +0800
committerOlivier Duchateau <olivierd@FreeBSD.org>2016-07-30 20:51:17 +0800
commitdbc611804782af27b597405edb91b6b803b57380 (patch)
tree355bb71080e0755b0624d400b60640bd395823c2 /deskutils/xfce4-notifyd/Makefile
parent5855d39dec9046ef97ed3aee42ba29a73144511b (diff)
downloadfreebsd-ports-gnome-dbc611804782af27b597405edb91b6b803b57380.tar.gz
freebsd-ports-gnome-dbc611804782af27b597405edb91b6b803b57380.tar.zst
freebsd-ports-gnome-dbc611804782af27b597405edb91b6b803b57380.zip
- Update to 0.3.0
- Convert to options helpers - Sort USES - Add comment for the next upgrade of x11-toolkits/gtk30 (>= 3.20) PR: 211446 Submitted by: myself Approved by: ehaupt@ (maintainer)
Diffstat (limited to 'deskutils/xfce4-notifyd/Makefile')
-rw-r--r--deskutils/xfce4-notifyd/Makefile30
1 files changed, 12 insertions, 18 deletions
diff --git a/deskutils/xfce4-notifyd/Makefile b/deskutils/xfce4-notifyd/Makefile
index b9b3e8c2ef0f..f1f5603bdcc2 100644
--- a/deskutils/xfce4-notifyd/Makefile
+++ b/deskutils/xfce4-notifyd/Makefile
@@ -1,11 +1,14 @@
# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
# $FreeBSD$
+#
+# !!!NOTE!!! Update of x11-toolkits/gtk30 (specially >= 3.20.x) must be
+# accompanied by PORTREVISION bumps of this port.
+# Support of GTK+ is checked at compile time and themes directories too.
PORTNAME= xfce4-notifyd
-PORTVERSION= 0.2.4
-PORTREVISION= 1
+PORTVERSION= 0.3.0
CATEGORIES= deskutils xfce
-MASTER_SITES= XFCE/src/apps/${PORTNAME}/${PORTVERSION:R}
+MASTER_SITES= http://errements.eu/distfiles/
DIST_SUBDIR= xfce4
MAINTAINER= ehaupt@FreeBSD.org
@@ -16,25 +19,16 @@ LICENSE= GPLv3
LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libnotify.so:devel/libnotify
-USES= gmake libtool pkgconfig gettext-tools xfce tar:bzip2
+USES= gmake gettext-tools libtool pkgconfig tar:bzip2 xfce:gtk3
GNU_CONFIGURE= yes
-USE_GNOME= gtk20 intltool intlhack
+USE_GNOME= gtk30 glib20 cairo intltool
USE_XFCE= libmenu
INSTALLS_ICONS= yes
-USE_XORG= x11
+USE_XORG= ice sm x11
OPTIONS_DEFINE= NLS
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext-runtime
-CONFIGURE_ARGS+=--enable-nls
-PLIST_SUB+= NLS=""
-.else
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+NLS_USES= gettext-runtime
+NLS_EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure
+OPTIONS_SUB= yes
.include <bsd.port.mk>